You are not logged in.

#1 2021-09-23 06:03:51

skolind
Member
Registered: 2021-09-23
Posts: 10

[SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

I am trying to update to the latest kernel; linux-5.14.6.arch1-1, but when I reboot I get the attached screenshot. It is a relatively new install of Arch (4 weeks). I can get back to normal by using the cached version: 5.13.13-arch1-1.

When I update via `sudo pacman -Syu` I see no errors and everything looks to be updating as it should, so I have no clue of where to look for a resolution, which is why I am trying the forums now.

Let me know, if you need me to post any additional information.

(I cannot get the img tag to work, so here is the direct link to the screenshot)
https://imgur.com/CW8OBDx

This is what I see right after updating all packages, including linux-5.14.6.arch1-1
https://imgur.com/a/rx9cUmI

Last edited by skolind (2021-09-23 11:59:05)

Offline

#2 2021-09-23 07:02:24

seth
Member
Registered: 2012-09-03
Posts: 23,978

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

I cannot get the img tag to work

Do not post huge images anyway.

You either forgot to mount the /boot partition or you're actually booting from the root partition.
Either way, the booted and installed kernel fall out of sync and the booting kernel cannot find the required modules.

Offline

#3 2021-09-23 07:16:50

skolind
Member
Registered: 2021-09-23
Posts: 10

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

seth wrote:

I cannot get the img tag to work

Do not post huge images anyway.

You either forgot to mount the /boot partition or you're actually booting from the root partition.
Either way, the booted and installed kernel fall out of sync and the booting kernel cannot find the required modules.

Got the image thing.

It might be the case, yes, and it seems like I have mounted my root to / instead of /mnt, for some reason. Could that be the issue? If yes, how do I change the mountpoint?

This is output of lsblk:

NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
nvme0n1     259:0    0 238.5G  0 disk 
├─nvme0n1p1 259:1    0   600M  0 part 
├─nvme0n1p2 259:2    0     1G  0 part [SWAP]
└─nvme0n1p3 259:3    0 236.9G  0 part /

Offline

#4 2021-09-23 07:32:04

seth
Member
Registered: 2012-09-03
Posts: 23,978

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

seems like I have mounted my root to / instead of /mnt

That's supposed to be the case but I guess you're booting from nvme0n1p1?
Are there kernel and grub files on that partition?

Offline

#5 2021-09-23 07:53:47

skolind
Member
Registered: 2021-09-23
Posts: 10

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

seth wrote:

seems like I have mounted my root to / instead of /mnt

That's supposed to be the case but I guess you're booting from nvme0n1p1?
Are there kernel and grub files on that partition?

Yes, that is true, but for some reason it is not mounted. Shouldn't it do that by it self?
I have tried to mount nvme0n1p1 to /mnt/boot and install linux-5.14.6 again, but without luck.

Offline

#6 2021-09-23 08:00:12

seth
Member
Registered: 2012-09-03
Posts: 23,978

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

Shouldn't it do that by it self?

Nothing does anything by itself. Afaik systemd would mount it if it had a BOOT label or so.

I have tried to mount nvme0n1p1 to /mnt/boot

Are you operating from the installation iso? Did you chroot at some point?

Please don't paraphrase your actions, post the actual I/O.

Offline

#7 2021-09-23 08:10:04

skolind
Member
Registered: 2021-09-23
Posts: 10

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

seth wrote:

Are you operating from the installation iso? Did you chroot at some point?

I am not right now, no. But, shortly after the initial install, I had to chroot to make wifi work, but after that I have not chroot'et.

During my search for a solution elsewhere, I stumbled upon people mentioning that you should setup your fstab. My /etc/fstab is empty, but I am not sure that it is required to have it setup. And if it is, I am not sure which options to give each entry.

I should maybe mention that I am running with EFI:

sebastian@storm:~$ ls /mnt/boot
EFI  grub  initramfs-linux-fallback.img  initramfs-linux.img  intel-ucode.img  mach_kernel  System  vmlinuz-linux

EDIT:

I investigated the /mnt/boot directory, and found that I had some old fedora specific stuff, which surprises me since I thought I had done a clean install:

sebastian@storm:~$ ls /mnt/boot/efi
BOOT  fedora  GRUB
sebastian@storm:~$ ls /mnt/boot/efi/fedora
BOOTIA32.CSV  fonts        gcdx64.efi  grubia32.efi  mmia32.efi  shim.efi      shimx64.efi
BOOTX64.CSV   gcdia32.efi  grub.cfg    grubx64.efi   mmx64.efi   shimia32.efi
sebastian@storm:~$ 

Last edited by skolind (2021-09-23 08:14:10)

Offline

#8 2021-09-23 08:14:22

seth
Member
Registered: 2012-09-03
Posts: 23,978

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

The kernel and initramfs are installed into the /boot path of the running system, so unless you're operating from the install iso and mounted the root partition of the installed system to /mnt and use "pacman --sysroot /mnt" the partition needs to be mounted to /boot, not /mnt/somewhereelse

During my search for a solution elsewhere, I stumbled

How did you install archlinux? Which tutorial did you follow?
https://wiki.archlinux.org/title/Instal … uide#Fstab

Offline

#9 2021-09-23 08:20:58

skolind
Member
Registered: 2021-09-23
Posts: 10

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

seth wrote:

The kernel and initramfs are installed into the /boot path of the running system, so unless you're operating from the install iso and mounted the root partition of the installed system to /mnt and use "pacman --sysroot /mnt" the partition needs to be mounted to /boot, not /mnt/somewhereelse

During my search for a solution elsewhere, I stumbled

How did you install archlinux? Which tutorial did you follow?
https://wiki.archlinux.org/title/Instal … uide#Fstab

I used https://wiki.archlinux.org/title/Instal … le_layouts which tells me an example layout would be /mnt/boot for my EFI partition, which is why I thought it was supposed to be /mnt/boot and not /boot?

It seems I have missed the step with generating the fstab - the one you are linking to. Trying to do it now:

sebastian@storm:~$ genfstab -U /mnt >> /mnt/etc/fstab
bash: /mnt/etc/fstab: No such file or directory
sebastian@storm:~$ genfstab -U /mnt >> /etc/fstab
bash: /etc/fstab: Permission denied
sebastian@storm:~$ sudo genfstab -U /mnt >> /etc/fstab
bash: /etc/fstab: Permission denied

Last edited by skolind (2021-09-23 08:21:27)

Offline

#10 2021-09-23 08:24:46

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,063

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

The example layout list the situation before you actually chroot into it, once you chroot into the /mnt path as part of the installation everything under it becomes / (i.e. your new root) which would in practice end up being /boot.

As for the genfstab commands you are trying now the >> is evaluated by the shell which isn't elevated, use

sudo bash -c "genfstab -U /mnt >> /etc/fstab"

for example.

Offline

#11 2021-09-23 08:27:03

skolind
Member
Registered: 2021-09-23
Posts: 10

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

V1del wrote:

The example layout list the situation before you actually chroot into it, once you chroot into the /mnt path as part of the installation everything under it becomes / (i.e. your new root) which would in practice end up being /boot.

As for the genfstab commands you are trying now the >> is evaluated by the shell which isn't elevated, use

sudo bash -c "genfstab -U /mnt >> /etc/fstab"

for example.

I see. Thanks for explaining the /mnt part smile

Trying to do what you suggested gives me:

sebastian@storm:~$ sudo bash -c "genfstab -U /mnt >> /etc/fstab"
bash: line 1: genfstab: command not found

Doing su root and doing the same thing gives me the same result.

Last edited by skolind (2021-09-23 08:28:30)

Offline

#12 2021-09-23 08:29:57

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,499

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

$ pkgfile genfstab
extra/arch-install-scripts
$

install arch-install-scripts.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#13 2021-09-23 08:33:05

skolind
Member
Registered: 2021-09-23
Posts: 10

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

Installing the extra/arch-install-scripts and trying again gives me:

sebastian@storm:~$ sudo bash -c "genfstab -U /mnt >> /etc/fstab"
==> ERROR: /mnt is not a mountpoint

Edit:

I did / instead of /mnt which seems to be the correct way.

Last edited by skolind (2021-09-23 08:35:25)

Offline

#14 2021-09-23 08:47:08

skolind
Member
Registered: 2021-09-23
Posts: 10

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

After generating the /etc/fstab file, which looks like this:

# Static information about the filesystems.
# See fstab(5) for details.

# <file system> <dir> <type> <options> <dump> <pass>
# /dev/nvme0n1p3
UUID=5a7b4dca-de6b-411c-b33b-393450453a5c       /               ext4            rw,relatime     0 1

# tracefs
tracefs                 /sys/kernel/tracing     tracefs         rw,nosuid,nodev,noexec  0 0

# gvfsd-fuse
gvfsd-fuse              /run/user/1000/gvfs     fuse.gvfsd-fuse rw,nosuid,nodev,user_id=1000,group_id=1000      0 0

# portal
portal                  /run/user/1000/doc      fuse.portal     rw,nosuid,nodev,user_id=1000,group_id=1000      0 0

# /dev/nvme0n1p2
UUID=49dc8038-922d-419d-9e99-f3a53e48443c       none            swap            defaults        0 0

And installing linux-5.14.6 I get a couple of new errors: https://imgur.com/a/i2CzHR4

But, downgrading to linux-5.13.13 with the same /etc/fstab now also fails, and gives me the same as on the screenshot, without the Load Kernel Modules and CLI Netlifier Manager errors. So, I had to clear the fstab to even boot on 5.13.13.

Something seems very off with my setup.

Last edited by skolind (2021-09-23 08:47:46)

Offline

#15 2021-09-23 09:20:30

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,063

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

The genfstab command would've worked under the assumption that your /boot partition was still mounted to /mnt/boot and using the logical path of /mnt/boot instead.

This now doesn't make much sense anymore. Remove the three entries between your root and your swap. Then on the "working" kernel, mount your boot partition to /boot and write the fstab entry by hand it will be something like

UUID=$YOURUUID$  /boot vfat defaults 0 0

$YOURUUID$ is to be replaced with the UUID that e.g. lsblk -f gives you.

Last edited by V1del (2021-09-23 10:15:09)

Offline

#16 2021-09-23 09:36:20

skolind
Member
Registered: 2021-09-23
Posts: 10

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

V1del wrote:

The genfstab command would've worked under the assumption that your /boot partition was still mounted to /mnt/boot and using the logical path of /mnt/boot instead.

This now doesn't make much sense anymore. Remove the three entries between your root and your swap. Then on the "working" kernel, mount your boot partition to /boot and write the fstab entry by hand it will be something like

UUID=$YOURUUID$  /boot vfat defaults

$YOURUUID$ is to be replaced with the UUID that e.g. lsblk -f gives you.

Thank you.

Rebooting now on 5.13.13 is succesful and lsblk gives me:

NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
nvme0n1     259:0    0 238.5G  0 disk 
├─nvme0n1p1 259:1    0   600M  0 part /boot
├─nvme0n1p2 259:2    0     1G  0 part [SWAP]
└─nvme0n1p3 259:3    0 236.9G  0 part /

So I tried to upgrade to linux-5.14.6, which still gives me no erros, but after a reboot I am back to this: https://imgur.com/a/lFG8EW8

(Sorry for the images btw, but not sure how to get the logs after a downgrade)

Edit:

I also just realized that I have stuff in /boot even when it is not mounted, isn't that incorrect?

sebastian@storm:~$ lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
nvme0n1     259:0    0 238.5G  0 disk 
├─nvme0n1p1 259:1    0   600M  0 part 
├─nvme0n1p2 259:2    0     1G  0 part [SWAP]
└─nvme0n1p3 259:3    0 236.9G  0 part /
sebastian@storm:~$ ls /boot
initramfs-linux-fallback.img  initramfs-linux.img  vmlinuz-linux

Last edited by skolind (2021-09-23 09:48:03)

Offline

#17 2021-09-23 10:14:09

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,063

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

That is indeed incorrect, and the reason for the issue in this thread, a kernel update generates the necessary boot images to /boot . Whether that's a directory on your root partition or a mount point of a dedicated partition is irrelevant to the installation/update process. You can remove these, mount the partition instead and update the linux kernel.

A whoops I noticed I missed the two 0 0 for the dump and fsck line, not sure whether that leads to an issue on the fstab parser

For logs after the downgrade it might be helpful to post a full

sudo journalctl -b-1

for the boot prior to your current one https://wiki.archlinux.org/title/List_o … n_services

FWIW it could also be that the reverse is true as in that your boot loader loads images from the / rather than the explicit partition , which boot loader are you using and what is it's config?

Last edited by V1del (2021-09-23 10:21:55)

Offline

#18 2021-09-23 11:58:15

skolind
Member
Registered: 2021-09-23
Posts: 10

Re: [SOLVED] Linux 5.14.x: Failed to start: Load Kernel Modules

I finally, with all of your help, got it working. I removed the kernel stuff I had in my /boot whilst not being mounted. Then I added my /etc/fstab as V1del told me to do. Mounted /boot and updated to new kernel. Then I had an issue where it could not find my kernel, because GRUB was configured incorrectly, which required me to do:

set root='(hd0,gpt1)'
linux /vmlinuz-linux root=/dev/nvme0n1p3 ro
initrd /initramfs-linux.img
boot

And then I could boot, and I then had to do

sudo grub-mkconfig -o /boot/grub/grub.cfg

Voila! Now I am on the latest kernel, and I can reboot, poweroff and come back to live with no issues smile

Thank you all for helping out!

Offline

Board footer

Powered by FluxBB