You are not logged in.

#1 2021-09-28 14:30:37

LeonScoretzka
Member
Registered: 2021-09-28
Posts: 2

installing libcap breaks dependency required by lib32-libcap

I am trying to update my system using pacman -Syu, but it gives me this output:

:: Synchronizing package databases...
 testing                                                                                            23.5 KiB  47.1 KiB/s 00:01 [############################################################################] 100%
 core                                                                                              137.2 KiB   615 KiB/s 00:00 [############################################################################] 100%
 extra                                                                                            1567.6 KiB  3.12 MiB/s 00:00 [############################################################################] 100%
 community                                                                                           5.8 MiB  3.97 MiB/s 00:01 [############################################################################] 100%
 multilib                                                                                          151.8 KiB  1518 KiB/s 00:00 [############################################################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing libcap (2.59-1) breaks dependency 'libcap=2.58' required by lib32-libcap

How do I fix this?

Offline

#2 2021-09-28 14:39:19

Scimmia
Fellow
Registered: 2012-09-01
Posts: 8,699

Re: installing libcap breaks dependency required by lib32-libcap

The testing repos are all or nothing. You can't use testing without community-testing and multilib-testing (since you're using multilib).

Offline

#3 2021-09-28 14:44:17

LeonScoretzka
Member
Registered: 2021-09-28
Posts: 2

Re: installing libcap breaks dependency required by lib32-libcap

That fixed it. I have to use the testing repos for OpenJDK 17.

Offline

Board footer

Powered by FluxBB