You are not logged in.

#1 2021-10-02 14:20:07

notprash
Member
Registered: 2021-10-02
Posts: 6

[SOLVED] Cannot install spotify yay

I installed spotify once from the aur package. I added spicetify. I uninstalled it. Now when I install I get this error:

`

==> Verifying source file signatures with gpg...
    spotify-1.1.68.632-Release ... Passed
==> Making package: spotify 1:1.1.68.632-1 (Sat Oct  2 19:48:20 2021)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found spotify.protocol
  -> Found LICENSE
  -> Found spotify-1.1.68.632-x86_64.deb
  -> Found spotify-1.1.68.632-Release
  -> Found spotify-1.1.68.632-Release.sig
  -> Found spotify-1.1.68.632-x86_64-Packages
==> Validating source files with sha512sums...
    spotify.protocol ... Passed
    LICENSE ... Passed
    spotify-1.1.68.632-x86_64.deb ... Passed
    spotify-1.1.68.632-Release ... Skipped
    spotify-1.1.68.632-Release.sig ... Skipped
    spotify-1.1.68.632-x86_64-Packages ... Skipped
==> Verifying source file signatures with gpg...
    spotify-1.1.68.632-Release ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting spotify-1.1.68.632-x86_64.deb with bsdtar
==> Starting prepare()...
spotify-1.1.68.632-x86_64-Packages: OK
spotify-1.1.68.632-x86_64.deb: OK
==> Sources are ready.
==> Making package: spotify 1:1.1.68.632-1 (Sat Oct  2 19:48:21 2021)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Removing existing $pkgdir/ directory...
==> Entering fakeroot environment...
==> Starting package()...
==> ERROR: A failure occurred in package().
    Aborting...
error making: spotify

`

Last edited by notprash (2021-10-03 03:57:44)

Offline

#2 2021-10-02 15:01:00

seth
Member
Registered: 2012-09-03
Posts: 25,053

Re: [SOLVED] Cannot install spotify yay

The board doesn't use markdown, https://bbs.archlinux.org/help.php#bbcode

==> WARNING: Using existing $srcdir/ tree

Try to remove the sources from ~/.cache/yay and then rebuild it.
Alternatively build it using makepkg so you can actually see why package() fails, https://wiki.archlinux.org/title/Arch_U … g_packages

Offline

#3 2021-10-02 15:16:47

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,503
Website

Re: [SOLVED] Cannot install spotify yay

Mod note: moving to AUR Issues.


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#4 2021-10-03 03:27:40

notprash
Member
Registered: 2021-10-02
Posts: 6

Re: [SOLVED] Cannot install spotify yay

I ran makepkg - s

Still the same error

makepkg -s
==> Making package: spotify 1:1.1.68.632-1 (Sun Oct  3 08:53:46 2021)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found spotify.protocol
  -> Found LICENSE
  -> Downloading spotify-1.1.68.632-x86_64.deb...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  107M  100  107M    0     0  3528k      0  0:00:31  0:00:31 --:--:-- 2132k
  -> Downloading spotify-1.1.68.632-Release...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  2447  100  2447    0     0   5566      0 --:--:-- --:--:-- --:--:--  5561
  -> Downloading spotify-1.1.68.632-Release.sig...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   833  100   833    0     0   2244      0 --:--:-- --:--:-- --:--:--  2251
  -> Downloading spotify-1.1.68.632-x86_64-Packages...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1210  100  1210    0     0   3225      0 --:--:-- --:--:-- --:--:--  3226
==> Validating source files with sha512sums...
    spotify.protocol ... Passed
    LICENSE ... Passed
    spotify-1.1.68.632-x86_64.deb ... Passed
    spotify-1.1.68.632-Release ... Skipped
    spotify-1.1.68.632-Release.sig ... Skipped
    spotify-1.1.68.632-x86_64-Packages ... Skipped
==> Verifying source file signatures with gpg...
    spotify-1.1.68.632-Release ... Passed
==> Extracting sources...
  -> Extracting spotify-1.1.68.632-x86_64.deb with bsdtar
==> Starting prepare()...
spotify-1.1.68.632-x86_64-Packages: OK
spotify-1.1.68.632-x86_64.deb: OK
==> Entering fakeroot environment...
==> Starting package()...
==> ERROR: A failure occurred in package().
    Aborting...
> makepkg --rmdeps
==> Making package: spotify 1:1.1.68.632-1 (Sun Oct  3 08:55:12 2021)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found spotify.protocol
  -> Found LICENSE
  -> Found spotify-1.1.68.632-x86_64.deb
  -> Found spotify-1.1.68.632-Release
  -> Found spotify-1.1.68.632-Release.sig
  -> Found spotify-1.1.68.632-x86_64-Packages
==> Validating source files with sha512sums...
    spotify.protocol ... Passed
    LICENSE ... Passed
    spotify-1.1.68.632-x86_64.deb ... Passed
    spotify-1.1.68.632-Release ... Skipped
    spotify-1.1.68.632-Release.sig ... Skipped
    spotify-1.1.68.632-x86_64-Packages ... Skipped
==> Verifying source file signatures with gpg...
    spotify-1.1.68.632-Release ... Passed
==> Extracting sources...
  -> Extracting spotify-1.1.68.632-x86_64.deb with bsdtar
==> Starting prepare()...
spotify-1.1.68.632-x86_64-Packages: OK
spotify-1.1.68.632-x86_64.deb: OK
==> Removing existing $pkgdir/ directory...
==> Entering fakeroot environment...
==> Starting package()...
==> ERROR: A failure occurred in package().
    Aborting...
> makepkg --clean
==> Making package: spotify 1:1.1.68.632-1 (Sun Oct  3 08:55:33 2021)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found spotify.protocol
  -> Found LICENSE
  -> Found spotify-1.1.68.632-x86_64.deb
  -> Found spotify-1.1.68.632-Release
  -> Found spotify-1.1.68.632-Release.sig
  -> Found spotify-1.1.68.632-x86_64-Packages
==> Validating source files with sha512sums...
    spotify.protocol ... Passed
    LICENSE ... Passed
    spotify-1.1.68.632-x86_64.deb ... Passed
    spotify-1.1.68.632-Release ... Skipped
    spotify-1.1.68.632-Release.sig ... Skipped
    spotify-1.1.68.632-x86_64-Packages ... Skipped
==> Verifying source file signatures with gpg...
    spotify-1.1.68.632-Release ... Passed
==> Extracting sources...
  -> Extracting spotify-1.1.68.632-x86_64.deb with bsdtar
==> Starting prepare()...
spotify-1.1.68.632-x86_64-Packages: OK
spotify-1.1.68.632-x86_64.deb: OK
==> Removing existing $pkgdir/ directory...
==> Entering fakeroot environment...
==> Starting package()...
==> ERROR: A failure occurred in package

Last edited by notprash (2021-10-03 03:50:28)

Offline

#5 2021-10-03 03:30:22

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,743
Website

Re: [SOLVED] Cannot install spotify yay

You were asked in post #2 to use code tags: edit and fix your post: https://wiki.archlinux.org/title/Genera … s_and_code


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#6 2021-10-03 03:55:51

notprash
Member
Registered: 2021-10-02
Posts: 6

Re: [SOLVED] Cannot install spotify yay

After rerunning spotify installed with yay. Everything worked. Thanks for your help. Really Appreciate it.

Offline

Board footer

Powered by FluxBB