You are not logged in.

#1 2021-10-05 20:53:04

sokol99
Member
Registered: 2021-09-25
Posts: 13

[SOLVED] Consistent GTK-3 Windows

Hi All,

I'm trying to get a consistent window border across my desktop apps and have been combing the wiki and forum but haven't found anything exactly on this topic.

I am using cinnamon and have installed some mint themes that I am able to set in the gui theme settings.  They take except for a handful of apps that appear to also be gtk 3 apps which is confusing to me.  A few include the chromium and brave browsers.  Both have windows borders that are different from each other and neither is the border I have set in the theme settings.  There are other apps as well.

I've confirmed both browser packages depend on gtk-3 and that my windows theme supports gtk-3.  (So the qt - gtk consistency topic doesn't seem to apply.)
I've found the gtk ini settings for both gtk-3 and gtk-4 at /usr/share/gtk-x.0/settings.ini.  Both look identical and appear to have been properly set by use of the "theme" settings.

It appears windows borders are 'client side decorations' of the themes so I am not sure exactly where my selection of theme 'x' window borders gets saved/referenced in the boot-up process.

Wisdom?

Thanks,
sokol99

Last edited by sokol99 (2021-10-06 19:17:18)

Offline

#2 2021-10-05 21:03:05

seth
Member
Registered: 2012-09-03
Posts: 25,019

Re: [SOLVED] Consistent GTK-3 Windows

https://aur.archlinux.org/packages/gtk3-nocsd-git/
chrome://settings/appearance has a setting to use the WMs decoration.

Offline

#3 2021-10-06 02:05:12

sokol99
Member
Registered: 2021-09-25
Posts: 13

Re: [SOLVED] Consistent GTK-3 Windows

Thanks.  I installed that but it doesn't appear to be working looking at the instructions here: https://github.com/PCMan/gtk3-nocsd

For example when I run:

./gtk3-nocsd brave from within /usr/bin nothing has changed.  Same with chromium.

I have also tried setting environmental variables in /etc/environment and restarting.

GTK_CSD=0
LD_PRELOAD="/lib/libgtk3-nocsd.so.0"

Oh, also, I do not see any setting for using the native WM in *chromium*.  Maybe it is in Chrome only..?

I'm probably messing something basic up...?

Last edited by sokol99 (2021-10-06 02:07:13)

Offline

#4 2021-10-06 06:23:10

seth
Member
Registered: 2012-09-03
Posts: 25,019

Re: [SOLVED] Consistent GTK-3 Windows

Brave and chromium and chrome are the same browser and the don't (really) use GTK

chrome://settings/appearance
https://www.simplified.guide/_media/goo … tok=94ba03
Might be buggy?
https://piunikaweb.com/2021/09/23/googl … ox-broken/

Offline

#5 2021-10-06 16:47:37

sokol99
Member
Registered: 2021-09-25
Posts: 13

Re: [SOLVED] Consistent GTK-3 Windows

Hi @seth, I found a way to do this for chromium and brave.

First, the option is not shown under settings but if you right click on the title bar at the top you can select "Use System Title Bar and Borders".   After that was done, the system-set borders did appear but only when the window was not maximized.  Maximizing the window hid the system borders on both browsers as if they were not considered part of the window.

Found this post about it which worked for me: https://piunikaweb.com/2021/09/23/googl … ox-broken/

The fix was to go to for example:
brave://flags/

And set use-ozone-platform to disabled and then relaunch the browser.  That seems to have done the trick for those two browsers. smile

Thanks!

Offline

#6 2021-10-06 17:42:23

seth
Member
Registered: 2012-09-03
Posts: 25,019

Re: [SOLVED] Consistent GTK-3 Windows

Please always remember to mark resolved threads by editing your initial posts subject - so others will know that there's no task left, but maybe a solution to find.
Thanks.

Offline

#7 2021-10-06 19:17:29

sokol99
Member
Registered: 2021-09-25
Posts: 13

Re: [SOLVED] Consistent GTK-3 Windows

Done. Thanks again!

Offline

Board footer

Powered by FluxBB