You are not logged in.

#1 2021-10-06 14:47:19

paulbrause
Member
Registered: 2021-10-06
Posts: 2

[SOLVED] Atlassian Jira Service not starting

Hi.

I just installed Atlassian Jira from AUR, but the service is not starting.

atlassian-jira $ systemctl status jira
× jira.service - Atlassian Jira Service
     Loaded: loaded (/usr/lib/systemd/system/jira.service; disabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Wed 2021-10-06 16:13:13 CEST; 13min ago
   Main PID: 188338 (code=exited, status=1/FAILURE)
        CPU: 8ms

Okt 06 16:13:13 paulbrauseDesktop systemd[1]: Started Atlassian Jira Service.
Okt 06 16:13:13 paulbrauseDesktop jira[188338]: Unrecognized VM option 'PrintGCDateStamps'
Okt 06 16:13:13 paulbrauseDesktop jira[188338]: Error: Could not create the Java Virtual Machine.
Okt 06 16:13:13 paulbrauseDesktop jira[188338]: Error: A fatal exception has occurred. Program will exit.
Okt 06 16:13:13 paulbrauseDesktop systemd[1]: jira.service: Main process exited, code=exited, status=1/FAILURE
Okt 06 16:13:13 paulbrauseDesktop systemd[1]: jira.service: Failed with result 'exit-code'.
atlassian-jira $ systemctl start jira
atlassian-jira $ systemctl status jira
× jira.service - Atlassian Jira Service
     Loaded: loaded (/usr/lib/systemd/system/jira.service; disabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Wed 2021-10-06 16:27:17 CEST; 2s ago
    Process: 193117 ExecStart=/usr/bin/env ${JAVA_HOME}/bin/java $JAVA_OPTS $CATALINA_OPTS -classpath ${CLASSPATH} -Dcatalina.base=${CATALINA_BASE} -Dcatalina.home=${CATALINA_HOME} -Djava.endorsed.dirs=${JAVA_ENDORSED_DIRS} -Djava>
   Main PID: 193117 (code=exited, status=1/FAILURE)
        CPU: 6ms

My OpenJDK-Version:

atlassian-jira $ java -version
openjdk version "16.0.2" 2021-07-20
OpenJDK Runtime Environment (build 16.0.2+7)
OpenJDK 64-Bit Server VM (build 16.0.2+7, mixed mode)

I tried installing "jdk11-openjdk" via pacman, but also no success.

Can someone help me? Am i missing something?

Thank you,
paulbrause

Last edited by paulbrause (2021-10-06 22:06:46)

Offline

#2 2021-10-06 15:00:03

Scimmia
Fellow
Registered: 2012-09-01
Posts: 8,747

Re: [SOLVED] Atlassian Jira Service not starting

The dep is on java-environment=8, not 11 or 16. Use archlinux-java to set the default to that.

Offline

#3 2021-10-06 15:43:31

Raynman
Member
Registered: 2011-10-22
Posts: 1,337

Re: [SOLVED] Atlassian Jira Service not starting

It would seem that overriding JAVA_HOME in /etc/conf.d/jira should work for the service, if you don't want to change the default. (I haven't really touched Java in years, so I might be missing something.)

Online

#4 2021-10-06 22:06:31

paulbrause
Member
Registered: 2021-10-06
Posts: 2

Re: [SOLVED] Atlassian Jira Service not starting

Scimmia wrote:

The dep is on java-environment=8, not 11 or 16. Use archlinux-java to set the default to that.

Ah, didn't noticed that. Already installed jdk8, but didn't set it to default.

Raynman wrote:

It would seem that overriding JAVA_HOME in /etc/conf.d/jira should work for the service, if you don't want to change the default. (I haven't really touched Java in years, so I might be missing something.)

That was the solution. Works like a charm.

Thank you!

Offline

Board footer

Powered by FluxBB