You are not logged in.

#1 2021-10-06 18:26:04

cornleader
Member
Registered: 2020-12-28
Posts: 8

laptop stuck on external monitor

A few months ago I tried to get my laptop to work on my TV in the basement. It took me a while but I got it working. Today I brought it upstairs and turned it on. I could see the boot info on the laptop screen then black. I hooked up the external HDMI and it works on the TV. I can't get the internal laptop monitor to display anything, it's stuck on the external HDMI. I can't remember what I did a few months ago to get the TV to work and I've been at it for hours. In my nvidia settings, it only shows the TV and xscreen 0 in the selection dropdown.

xrandr -q

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080     60.00 +  60.00*   59.99    59.94    29.97    23.98    60.05    60.00 
   1280x1024     60.02 
   1280x720      60.00    59.94 
   1024x768      60.00 
   800x600       60.32 
   720x480       59.94 
   640x480       59.95    59.94 
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)

lspci | egrep 'VGA|3D'

01:00.0 VGA compatible controller: NVIDIA Corporation GK104M [GeForce GTX 860M] (rev a1)

Offline

#2 2021-10-06 19:52:35

seth
Member
Registered: 2012-09-03
Posts: 24,101

Re: laptop stuck on external monitor

I could see the boot info on the laptop screen then black

Please post your xorg log, since the internal output doesn't show up in xrandr, I assume you "Ignore" it in some xorg.conf* file?

grep -ir ignore /{etc,usr/share}/X11/xorg.conf*

Online

#3 2021-10-07 12:41:21

cornleader
Member
Registered: 2020-12-28
Posts: 8

Re: laptop stuck on external monitor

seth wrote:

I could see the boot info on the laptop screen then black

Please post your xorg log, since the internal output doesn't show up in xrandr, I assume you "Ignore" it in some xorg.conf* file?

grep -ir ignore /{etc,usr/share}/X11/xorg.conf*

/var/log/Xorg.0.log

[     8.861] (--) Log file renamed from "/var/log/Xorg.pid-1565.log" to "/var/log/Xorg.0.log"
[     8.863] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[     8.863] 
X.Org X Server 1.20.13
X Protocol Version 11, Revision 0
[     8.863] Build Operating System: Linux Archlinux
[     8.863] Current Operating System: Linux lappy3 5.14.9-arch2-1 #1 SMP PREEMPT Fri, 01 Oct 2021 19:03:20 +0000 x86_64
[     8.863] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=a4b69620-154b-4114-8412-077f88b0f9db rw loglevel=3
[     8.863] Build Date: 04 August 2021  08:13:54AM
[     8.863]  
[     8.863] Current version of pixman: 0.40.0
[     8.863] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[     8.863] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     8.863] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Oct  7 09:18:34 2021
[     8.865] (==) Using config directory: "/etc/X11/xorg.conf.d"
[     8.865] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     8.867] (==) No Layout section.  Using the first Screen section.
[     8.867] (==) No screen section available. Using defaults.
[     8.867] (**) |-->Screen "Default Screen Section" (0)
[     8.867] (**) |   |-->Monitor "<default monitor>"
[     8.867] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[     8.867] (==) Automatically adding devices
[     8.867] (==) Automatically enabling devices
[     8.867] (==) Automatically adding GPU devices
[     8.867] (==) Automatically binding GPU devices
[     8.867] (==) Max clients allowed: 256, resource mask: 0x1fffff
[     8.868] (WW) The directory "/usr/share/fonts/misc" does not exist.
[     8.868] 	Entry deleted from font path.
[     8.868] (WW) The directory "/usr/share/fonts/TTF" does not exist.
[     8.868] 	Entry deleted from font path.
[     8.868] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[     8.868] 	Entry deleted from font path.
[     8.868] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[     8.868] 	Entry deleted from font path.
[     8.868] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[     8.868] 	Entry deleted from font path.
[     8.868] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[     8.868] 	Entry deleted from font path.
[     8.868] (==) FontPath set to:
	
[     8.868] (==) ModulePath set to "/usr/lib/xorg/modules"
[     8.868] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[     8.868] (II) Module ABI versions:
[     8.868] 	X.Org ANSI C Emulation: 0.4
[     8.868] 	X.Org Video Driver: 24.1
[     8.868] 	X.Org XInput driver : 24.1
[     8.868] 	X.Org Server Extension : 10.0
[     8.869] (++) using VT number 2

[     8.870] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_33
[     8.871] (II) xfree86: Adding drm device (/dev/dri/card0)
[     8.872] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 11 paused 0
[     8.873] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/xorg/modules"
[     8.873] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/xorg/modules"
[     8.873] (**) OutputClass "nvidia" setting /dev/dri/card0 as PrimaryGPU
[     8.874] (--) PCI:*(1@0:0:0) 10de:119a:1028:05ae rev 161, Mem @ 0xd0000000/16777216, 0xb0000000/268435456, 0xc0000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/524288
[     8.874] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[     8.874] (II) LoadModule: "glx"
[     8.875] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[     8.877] (II) Module glx: vendor="X.Org Foundation"
[     8.877] 	compiled for 1.20.13, module version = 1.0.0
[     8.877] 	ABI class: X.Org Server Extension, version 10.0
[     8.877] (II) Applying OutputClass "nvidia" to /dev/dri/card0
[     8.877] 	loading driver: nvidia
[     8.877] (II) Applying OutputClass "nvidia" to /dev/dri/card0
[     8.877] 	loading driver: nvidia
[     8.877] (==) Matched nvidia as autoconfigured driver 0
[     8.877] (==) Matched nouveau as autoconfigured driver 1
[     8.877] (==) Matched nv as autoconfigured driver 2
[     8.877] (==) Matched modesetting as autoconfigured driver 3
[     8.877] (==) Matched fbdev as autoconfigured driver 4
[     8.877] (==) Matched vesa as autoconfigured driver 5
[     8.877] (==) Assigned the driver to the xf86ConfigLayout
[     8.877] (II) LoadModule: "nvidia"
[     8.878] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[     8.885] (II) Module nvidia: vendor="NVIDIA Corporation"
[     8.885] 	compiled for 1.6.99.901, module version = 1.0.0
[     8.885] 	Module class: X.Org Video Driver
[     8.885] (II) LoadModule: "nouveau"
[     8.886] (WW) Warning, couldn't open module nouveau
[     8.886] (EE) Failed to load module "nouveau" (module does not exist, 0)
[     8.886] (II) LoadModule: "nv"
[     8.886] (WW) Warning, couldn't open module nv
[     8.886] (EE) Failed to load module "nv" (module does not exist, 0)
[     8.886] (II) LoadModule: "modesetting"
[     8.886] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[     8.887] (II) Module modesetting: vendor="X.Org Foundation"
[     8.887] 	compiled for 1.20.13, module version = 1.20.13
[     8.887] 	Module class: X.Org Video Driver
[     8.887] 	ABI class: X.Org Video Driver, version 24.1
[     8.887] (II) LoadModule: "fbdev"
[     8.887] (WW) Warning, couldn't open module fbdev
[     8.887] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     8.887] (II) LoadModule: "vesa"
[     8.888] (WW) Warning, couldn't open module vesa
[     8.888] (EE) Failed to load module "vesa" (module does not exist, 0)
[     8.888] (II) NVIDIA dlloader X Driver  470.74  Mon Sep 13 23:05:04 UTC 2021
[     8.888] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[     8.888] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[     8.888] (II) systemd-logind: releasing fd for 226:0
[     8.889] (II) Loading sub module "fb"
[     8.889] (II) LoadModule: "fb"
[     8.889] (II) Loading /usr/lib/xorg/modules/libfb.so
[     8.890] (II) Module fb: vendor="X.Org Foundation"
[     8.890] 	compiled for 1.20.13, module version = 1.0.0
[     8.890] 	ABI class: X.Org ANSI C Emulation, version 0.4
[     8.890] (II) Loading sub module "wfb"
[     8.890] (II) LoadModule: "wfb"
[     8.890] (II) Loading /usr/lib/xorg/modules/libwfb.so
[     8.891] (II) Module wfb: vendor="X.Org Foundation"
[     8.891] 	compiled for 1.20.13, module version = 1.0.0
[     8.891] 	ABI class: X.Org ANSI C Emulation, version 0.4
[     8.891] (II) Loading sub module "ramdac"
[     8.891] (II) LoadModule: "ramdac"
[     8.891] (II) Module "ramdac" already built-in
[     8.894] (WW) Falling back to old probe method for modesetting
[     8.894] (II) NVIDIA(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[     8.894] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[     8.894] (==) NVIDIA(0): RGB weight 888
[     8.894] (==) NVIDIA(0): Default visual is TrueColor
[     8.894] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[     8.894] (II) Applying OutputClass "nvidia" options to /dev/dri/card0
[     8.894] (II) Applying OutputClass "nvidia" options to /dev/dri/card0
[     8.894] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration"
[     8.894] (**) NVIDIA(0): Enabling 2D acceleration
[     8.895] (II) Loading sub module "glxserver_nvidia"
[     8.895] (II) LoadModule: "glxserver_nvidia"
[     8.895] (II) Loading /usr/lib/nvidia/xorg/libglxserver_nvidia.so
[     8.959] (II) Module glxserver_nvidia: vendor="NVIDIA Corporation"
[     8.959] 	compiled for 1.6.99.901, module version = 1.0.0
[     8.959] 	Module class: X.Org Server Extension
[     8.959] (II) NVIDIA GLX Module  470.74  Mon Sep 13 23:02:11 UTC 2021
[     8.961] (II) NVIDIA: The X server supports PRIME Render Offload.
[    11.141] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[    11.141] (--) NVIDIA(0):     DFP-0 (boot)
[    11.141] (--) NVIDIA(0):     DFP-1
[    11.141] (--) NVIDIA(0):     DFP-2
[    11.141] (--) NVIDIA(0):     DFP-3
[    11.141] (--) NVIDIA(0):     DFP-4
[    11.142] (II) NVIDIA(0): NVIDIA GPU NVIDIA GeForce GTX 860M (GK104) at PCI:1:0:0
[    11.142] (II) NVIDIA(0):     (GPU-0)
[    11.142] (--) NVIDIA(0): Memory: 2097152 kBytes
[    11.142] (--) NVIDIA(0): VideoBIOS: 80.04.f5.00.06
[    11.142] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    11.190] (--) NVIDIA(GPU-0): LG Electronics LG TV (DFP-0): connected
[    11.190] (--) NVIDIA(GPU-0): LG Electronics LG TV (DFP-0): Internal TMDS
[    11.190] (--) NVIDIA(GPU-0): LG Electronics LG TV (DFP-0): 340.0 MHz maximum pixel clock
[    11.190] (--) NVIDIA(GPU-0): 
[    11.190] (--) NVIDIA(GPU-0): DFP-1: disconnected
[    11.190] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[    11.190] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[    11.190] (--) NVIDIA(GPU-0): 
[    11.190] (--) NVIDIA(GPU-0): DFP-2: disconnected
[    11.190] (--) NVIDIA(GPU-0): DFP-2: Internal TMDS
[    11.190] (--) NVIDIA(GPU-0): DFP-2: 165.0 MHz maximum pixel clock
[    11.190] (--) NVIDIA(GPU-0): 
[    11.190] (--) NVIDIA(GPU-0): DFP-3: disconnected
[    11.190] (--) NVIDIA(GPU-0): DFP-3: Internal DisplayPort
[    11.190] (--) NVIDIA(GPU-0): DFP-3: 960.0 MHz maximum pixel clock
[    11.190] (--) NVIDIA(GPU-0): 
[    11.190] (--) NVIDIA(GPU-0): DFP-4: disconnected
[    11.190] (--) NVIDIA(GPU-0): DFP-4: Internal DisplayPort
[    11.190] (--) NVIDIA(GPU-0): DFP-4: 960.0 MHz maximum pixel clock
[    11.190] (--) NVIDIA(GPU-0): 
[    11.193] (==) NVIDIA(0): 
[    11.193] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[    11.193] (==) NVIDIA(0):     will be used as the requested mode.
[    11.193] (==) NVIDIA(0): 
[    11.193] (II) NVIDIA(0): Validated MetaModes:
[    11.193] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"
[    11.193] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[    11.197] (--) NVIDIA(0): DPI set to (304, 304); computed from "UseEdidDpi" X config
[    11.197] (--) NVIDIA(0):     option
[    11.197] (II) UnloadModule: "modesetting"
[    11.197] (II) Unloading modesetting
[    11.197] (II) NVIDIA: Reserving 6144.00 MB of virtual memory for indirect memory
[    11.197] (II) NVIDIA:     access.
[    11.200] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[    11.200] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[    11.200] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[    11.200] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[    11.200] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[    11.200] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[    11.200] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[    11.200] (II) NVIDIA(0):     Config Options in the README.
[    11.467] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[    11.709] (==) NVIDIA(0): Disabling shared memory pixmaps
[    11.709] (==) NVIDIA(0): Backing store enabled
[    11.709] (==) NVIDIA(0): Silken mouse disabled
[    11.709] (==) NVIDIA(0): DPMS enabled
[    11.710] (WW) NVIDIA(0): Option "PrimaryGPU" is not used
[    11.710] (II) Loading sub module "dri2"
[    11.710] (II) LoadModule: "dri2"
[    11.710] (II) Module "dri2" already built-in
[    11.710] (II) NVIDIA(0): [DRI2] Setup complete
[    11.710] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    11.711] (II) Initializing extension Generic Event Extension
[    11.711] (II) Initializing extension SHAPE
[    11.711] (II) Initializing extension MIT-SHM
[    11.711] (II) Initializing extension XInputExtension
[    11.711] (II) Initializing extension XTEST
[    11.712] (II) Initializing extension BIG-REQUESTS
[    11.712] (II) Initializing extension SYNC
[    11.712] (II) Initializing extension XKEYBOARD
[    11.712] (II) Initializing extension XC-MISC
[    11.712] (II) Initializing extension SECURITY
[    11.712] (II) Initializing extension XFIXES
[    11.712] (II) Initializing extension RENDER
[    11.712] (II) Initializing extension RANDR
[    11.712] (II) Initializing extension COMPOSITE
[    11.712] (II) Initializing extension DAMAGE
[    11.712] (II) Initializing extension MIT-SCREEN-SAVER
[    11.712] (II) Initializing extension DOUBLE-BUFFER
[    11.712] (II) Initializing extension RECORD
[    11.712] (II) Initializing extension DPMS
[    11.712] (II) Initializing extension Present
[    11.712] (II) Initializing extension DRI3
[    11.712] (II) Initializing extension X-Resource
[    11.712] (II) Initializing extension XVideo
[    11.712] (II) Initializing extension XVideo-MotionCompensation
[    11.712] (II) Initializing extension GLX
[    11.712] (II) Initializing extension GLX
[    11.712] (II) Indirect GLX disabled.
[    11.712] (II) GLX: Another vendor is already registered for screen 0
[    11.712] (II) Initializing extension XFree86-VidModeExtension
[    11.712] (II) Initializing extension XFree86-DGA
[    11.712] (II) Initializing extension XFree86-DRI
[    11.712] (II) Initializing extension DRI2
[    11.712] (II) Initializing extension NV-GLX
[    11.712] (II) Initializing extension NV-CONTROL
[    11.712] (II) Initializing extension XINERAMA
[    11.776] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[    11.776] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[    11.776] (II) LoadModule: "libinput"
[    11.776] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    11.778] (II) Module libinput: vendor="X.Org Foundation"
[    11.778] 	compiled for 1.20.13, module version = 1.2.0
[    11.778] 	Module class: X.Org XInput Driver
[    11.778] 	ABI class: X.Org XInput driver, version 24.1
[    11.778] (II) Using input driver 'libinput' for 'Power Button'
[    11.779] (II) systemd-logind: got fd for /dev/input/event2 13:66 fd 34 paused 0
[    11.779] (**) Power Button: always reports core events
[    11.779] (**) Option "Device" "/dev/input/event2"
[    11.779] (**) Option "_source" "server/udev"
[    11.786] (II) event2  - Power Button: is tagged by udev as: Keyboard
[    11.786] (II) event2  - Power Button: device is a keyboard
[    11.786] (II) event2  - Power Button: device removed
[    11.786] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[    11.786] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    11.787] (II) event2  - Power Button: is tagged by udev as: Keyboard
[    11.787] (II) event2  - Power Button: device is a keyboard
[    11.787] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[    11.788] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[    11.788] (II) Using input driver 'libinput' for 'Power Button'
[    11.788] (II) systemd-logind: got fd for /dev/input/event0 13:64 fd 37 paused 0
[    11.788] (**) Power Button: always reports core events
[    11.788] (**) Option "Device" "/dev/input/event0"
[    11.788] (**) Option "_source" "server/udev"
[    11.789] (II) event0  - Power Button: is tagged by udev as: Keyboard
[    11.789] (II) event0  - Power Button: device is a keyboard
[    11.789] (II) event0  - Power Button: device removed
[    11.789] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:01/PNP0C0C:00/input/input0/event0"
[    11.789] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[    11.790] (II) event0  - Power Button: is tagged by udev as: Keyboard
[    11.790] (II) event0  - Power Button: device is a keyboard
[    11.791] (II) config/udev: Adding input device Video Bus (/dev/input/event14)
[    11.791] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[    11.791] (II) Using input driver 'libinput' for 'Video Bus'
[    11.792] (II) systemd-logind: got fd for /dev/input/event14 13:78 fd 38 paused 0
[    11.792] (**) Video Bus: always reports core events
[    11.792] (**) Option "Device" "/dev/input/event14"
[    11.792] (**) Option "_source" "server/udev"
[    11.792] (II) event14 - Video Bus: is tagged by udev as: Keyboard
[    11.793] (II) event14 - Video Bus: device is a keyboard
[    11.793] (II) event14 - Video Bus: device removed
[    11.793] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:48/LNXVIDEO:00/input/input16/event14"
[    11.793] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 8)
[    11.793] (II) event14 - Video Bus: is tagged by udev as: Keyboard
[    11.794] (II) event14 - Video Bus: device is a keyboard
[    11.794] (II) config/udev: Adding input device Lid Switch (/dev/input/event1)
[    11.794] (II) No input driver specified, ignoring this device.
[    11.794] (II) This device may have been added with another device file.
[    11.795] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=8 (/dev/input/event8)
[    11.795] (II) No input driver specified, ignoring this device.
[    11.795] (II) This device may have been added with another device file.
[    11.795] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=9 (/dev/input/event9)
[    11.795] (II) No input driver specified, ignoring this device.
[    11.795] (II) This device may have been added with another device file.
[    11.795] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=10 (/dev/input/event10)
[    11.795] (II) No input driver specified, ignoring this device.
[    11.795] (II) This device may have been added with another device file.
[    11.796] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event6)
[    11.796] (II) No input driver specified, ignoring this device.
[    11.796] (II) This device may have been added with another device file.
[    11.796] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event7)
[    11.796] (II) No input driver specified, ignoring this device.
[    11.796] (II) This device may have been added with another device file.
[    11.796] (II) config/udev: Adding input device Laptop_Integrated_Webcam_FHD: I (/dev/input/event5)
[    11.796] (**) Laptop_Integrated_Webcam_FHD: I: Applying InputClass "libinput keyboard catchall"
[    11.796] (II) Using input driver 'libinput' for 'Laptop_Integrated_Webcam_FHD: I'
[    11.797] (II) systemd-logind: got fd for /dev/input/event5 13:69 fd 39 paused 0
[    11.797] (**) Laptop_Integrated_Webcam_FHD: I: always reports core events
[    11.797] (**) Option "Device" "/dev/input/event5"
[    11.797] (**) Option "_source" "server/udev"
[    11.798] (II) event5  - Laptop_Integrated_Webcam_FHD: I: is tagged by udev as: Keyboard
[    11.798] (II) event5  - Laptop_Integrated_Webcam_FHD: I: device is a keyboard
[    11.799] (II) event5  - Laptop_Integrated_Webcam_FHD: I: device removed
[    11.799] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0/input/input7/event5"
[    11.799] (II) XINPUT: Adding extended input device "Laptop_Integrated_Webcam_FHD: I" (type: KEYBOARD, id 9)
[    11.799] (II) event5  - Laptop_Integrated_Webcam_FHD: I: is tagged by udev as: Keyboard
[    11.800] (II) event5  - Laptop_Integrated_Webcam_FHD: I: device is a keyboard
[    11.800] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event11)
[    11.800] (II) No input driver specified, ignoring this device.
[    11.800] (II) This device may have been added with another device file.
[    11.800] (II) config/udev: Adding input device HDA Intel PCH Headphone Front (/dev/input/event12)
[    11.800] (II) No input driver specified, ignoring this device.
[    11.800] (II) This device may have been added with another device file.
[    11.800] (II) config/udev: Adding input device HDA Intel PCH Headphone Surround (/dev/input/event13)
[    11.800] (II) No input driver specified, ignoring this device.
[    11.800] (II) This device may have been added with another device file.
[    11.801] (II) config/udev: Adding input device Dell WMI hotkeys (/dev/input/event15)
[    11.801] (**) Dell WMI hotkeys: Applying InputClass "libinput keyboard catchall"
[    11.801] (II) Using input driver 'libinput' for 'Dell WMI hotkeys'
[    11.801] (II) systemd-logind: got fd for /dev/input/event15 13:79 fd 40 paused 0
[    11.801] (**) Dell WMI hotkeys: always reports core events
[    11.802] (**) Option "Device" "/dev/input/event15"
[    11.802] (**) Option "_source" "server/udev"
[    11.802] (II) event15 - Dell WMI hotkeys: is tagged by udev as: Keyboard
[    11.802] (II) event15 - Dell WMI hotkeys: device is a keyboard
[    11.803] (II) event15 - Dell WMI hotkeys: device removed
[    11.803] (**) Option "config_info" "udev:/sys/devices/platform/PNP0C14:01/wmi_bus/wmi_bus-PNP0C14:01/9DBB5994-A997-11DA-B012-B622A1EF5492/input/input17/event15"
[    11.803] (II) XINPUT: Adding extended input device "Dell WMI hotkeys" (type: KEYBOARD, id 10)
[    11.804] (II) event15 - Dell WMI hotkeys: is tagged by udev as: Keyboard
[    11.804] (II) event15 - Dell WMI hotkeys: device is a keyboard
[    11.804] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event3)
[    11.804] (**) AT Translated Set 2 keyboard: Applying InputClass "libinput keyboard catchall"
[    11.804] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[    11.805] (II) systemd-logind: got fd for /dev/input/event3 13:67 fd 41 paused 0
[    11.805] (**) AT Translated Set 2 keyboard: always reports core events
[    11.805] (**) Option "Device" "/dev/input/event3"
[    11.805] (**) Option "_source" "server/udev"
[    11.806] (II) event3  - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[    11.806] (II) event3  - AT Translated Set 2 keyboard: device is a keyboard
[    11.806] (II) event3  - AT Translated Set 2 keyboard: device removed
[    11.806] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input3/event3"
[    11.806] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 11)
[    11.807] (II) event3  - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[    11.807] (II) event3  - AT Translated Set 2 keyboard: device is a keyboard
[    11.808] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event16)
[    11.808] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "libinput touchpad catchall"
[    11.808] (II) Using input driver 'libinput' for 'SynPS/2 Synaptics TouchPad'
[    11.808] (II) systemd-logind: got fd for /dev/input/event16 13:80 fd 42 paused 0
[    11.808] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    11.808] (**) Option "Device" "/dev/input/event16"
[    11.808] (**) Option "_source" "server/udev"
[    11.809] (II) event16 - SynPS/2 Synaptics TouchPad: is tagged by udev as: Touchpad
[    11.810] (II) event16 - SynPS/2 Synaptics TouchPad: device is a touchpad
[    11.810] (II) event16 - SynPS/2 Synaptics TouchPad: device removed
[    11.811] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input6/event16"
[    11.811] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 12)
[    11.811] (**) Option "AccelerationScheme" "none"
[    11.811] (**) SynPS/2 Synaptics TouchPad: (accel) selected scheme none/0
[    11.811] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    11.811] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    11.812] (II) event16 - SynPS/2 Synaptics TouchPad: is tagged by udev as: Touchpad
[    11.813] (II) event16 - SynPS/2 Synaptics TouchPad: device is a touchpad
[    11.814] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[    11.814] (II) No input driver specified, ignoring this device.
[    11.814] (II) This device may have been added with another device file.
[    11.814] (II) config/udev: Adding input device PC Speaker (/dev/input/event4)
[    11.814] (II) No input driver specified, ignoring this device.
[    11.814] (II) This device may have been added with another device file.
[    12.696] (--) NVIDIA(GPU-0): LG Electronics LG TV (DFP-0): connected
[    12.696] (--) NVIDIA(GPU-0): LG Electronics LG TV (DFP-0): Internal TMDS
[    12.696] (--) NVIDIA(GPU-0): LG Electronics LG TV (DFP-0): 340.0 MHz maximum pixel clock
[    12.696] (--) NVIDIA(GPU-0): 
[    12.696] (--) NVIDIA(GPU-0): DFP-1: disconnected
[    12.696] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[    12.696] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[    12.696] (--) NVIDIA(GPU-0): 
[    12.696] (--) NVIDIA(GPU-0): DFP-2: disconnected
[    12.696] (--) NVIDIA(GPU-0): DFP-2: Internal TMDS
[    12.696] (--) NVIDIA(GPU-0): DFP-2: 165.0 MHz maximum pixel clock
[    12.696] (--) NVIDIA(GPU-0): 
[    12.696] (--) NVIDIA(GPU-0): DFP-3: disconnected
[    12.696] (--) NVIDIA(GPU-0): DFP-3: Internal DisplayPort
[    12.696] (--) NVIDIA(GPU-0): DFP-3: 960.0 MHz maximum pixel clock
[    12.696] (--) NVIDIA(GPU-0): 
[    12.696] (--) NVIDIA(GPU-0): DFP-4: disconnected
[    12.696] (--) NVIDIA(GPU-0): DFP-4: Internal DisplayPort
[    12.696] (--) NVIDIA(GPU-0): DFP-4: 960.0 MHz maximum pixel clock
[    12.696] (--) NVIDIA(GPU-0): 
[    12.847] (II) NVIDIA(0): Setting mode "HDMI-0: 1920x1080_60_0 @1920x1080 +0+0 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}"
[    16.284] (--) NVIDIA(GPU-0): LG Electronics LG TV (DFP-0): connected
[    16.284] (--) NVIDIA(GPU-0): LG Electronics LG TV (DFP-0): Internal TMDS
[    16.284] (--) NVIDIA(GPU-0): LG Electronics LG TV (DFP-0): 340.0 MHz maximum pixel clock
[    16.284] (--) NVIDIA(GPU-0): 
[    16.284] (--) NVIDIA(GPU-0): DFP-1: disconnected
[    16.284] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[    16.284] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[    16.284] (--) NVIDIA(GPU-0): 
[    16.284] (--) NVIDIA(GPU-0): DFP-2: disconnected
[    16.284] (--) NVIDIA(GPU-0): DFP-2: Internal TMDS
[    16.284] (--) NVIDIA(GPU-0): DFP-2: 165.0 MHz maximum pixel clock
[    16.284] (--) NVIDIA(GPU-0): 
[    16.284] (--) NVIDIA(GPU-0): DFP-3: disconnected
[    16.284] (--) NVIDIA(GPU-0): DFP-3: Internal DisplayPort
[    16.284] (--) NVIDIA(GPU-0): DFP-3: 960.0 MHz maximum pixel clock
[    16.284] (--) NVIDIA(GPU-0): 
[    16.284] (--) NVIDIA(GPU-0): DFP-4: disconnected
[    16.284] (--) NVIDIA(GPU-0): DFP-4: Internal DisplayPort
[    16.284] (--) NVIDIA(GPU-0): DFP-4: 960.0 MHz maximum pixel clock
[    16.284] (--) NVIDIA(GPU-0): 
[    17.341] (--) NVIDIA(GPU-0): LG Electronics LG TV (DFP-0): connected
[    17.341] (--) NVIDIA(GPU-0): LG Electronics LG TV (DFP-0): Internal TMDS
[    17.341] (--) NVIDIA(GPU-0): LG Electronics LG TV (DFP-0): 340.0 MHz maximum pixel clock
[    17.341] (--) NVIDIA(GPU-0): 
[    17.342] (--) NVIDIA(GPU-0): DFP-1: disconnected
[    17.342] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[    17.342] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[    17.342] (--) NVIDIA(GPU-0): 
[    17.342] (--) NVIDIA(GPU-0): DFP-2: disconnected
[    17.342] (--) NVIDIA(GPU-0): DFP-2: Internal TMDS
[    17.342] (--) NVIDIA(GPU-0): DFP-2: 165.0 MHz maximum pixel clock
[    17.342] (--) NVIDIA(GPU-0): 
[    17.342] (--) NVIDIA(GPU-0): DFP-3: disconnected
[    17.342] (--) NVIDIA(GPU-0): DFP-3: Internal DisplayPort
[    17.342] (--) NVIDIA(GPU-0): DFP-3: 960.0 MHz maximum pixel clock
[    17.342] (--) NVIDIA(GPU-0): 
[    17.342] (--) NVIDIA(GPU-0): DFP-4: disconnected
[    17.342] (--) NVIDIA(GPU-0): DFP-4: Internal DisplayPort
[    17.342] (--) NVIDIA(GPU-0): DFP-4: 960.0 MHz maximum pixel clock
[    17.342] (--) NVIDIA(GPU-0): 
[   259.050] (EE) event16 - SynPS/2 Synaptics TouchPad: client bug: event processing lagging behind by 14ms, your system is too slow
[   282.687] (EE) event16 - SynPS/2 Synaptics TouchPad: client bug: event processing lagging behind by 15ms, your system is too slow

Offline

#4 2021-10-07 13:37:54

seth
Member
Registered: 2012-09-03
Posts: 24,101

Re: laptop stuck on external monitor

seth wrote:
grep -ir ignore /{etc,usr/share}/X11/xorg.conf*

Online

#5 2021-10-07 13:44:58

cornleader
Member
Registered: 2020-12-28
Posts: 8

Re: laptop stuck on external monitor

seth wrote:
grep -ir ignore /{etc,usr/share}/X11/xorg.conf*
/usr/share/X11/xorg.conf.d/10-quirks.conf:        Option "Ignore" "on"
/usr/share/X11/xorg.conf.d/10-quirks.conf:# Explicitly tell evdev to not ignore the absolute axes.
/usr/share/X11/xorg.conf.d/10-quirks.conf:        Option "IgnoreAbsoluteAxes" "off"
/usr/share/X11/xorg.conf.d/10-quirks.conf:        Option "IgnoreRelativeAxes" "off"

Offline

#6 2021-10-07 13:48:52

seth
Member
Registered: 2012-09-03
Posts: 24,101

Re: laptop stuck on external monitor

Nope.

I could see the boot info on the laptop screen then black.

BIOS, boot loader or boot messages from the kernel?
Can you boot
a) w/ the "nomodeset" kernel parameter
b) the multi-user.target (2nd link below)

Online

#7 2021-10-07 14:37:06

cornleader
Member
Registered: 2020-12-28
Posts: 8

Re: laptop stuck on external monitor

BIOS, boot loader or boot messages from the kernel?

just the regular verbose boot info, lines start with green [OK]

a) w/ the "nomodeset" kernel parameter

The laptop screen flickers a few times after the boot info comes on the screen, nothing on the laptop or TV, had to do ctl alt del, then the messages came up on the TV before shutdown, im not sure if they come from the boot loader or the kernel. same lines as when booting.

b) the multi-user.target (2nd link below)

boots to terminal on laptop screen, nothing on TV. When I do "systemctl start gdm", laptop goes black and gnome starts on TV.

Offline

#8 2021-10-07 14:40:45

seth
Member
Registered: 2012-09-03
Posts: 24,101

Re: laptop stuck on external monitor

Sounds like https://wiki.archlinux.org/title/GDM#Se … r_settings forces the external display? Doesn't explain why apparently only the HDMI is shown in xrandr, but it's start by moving away the monitors.xml

Edit:

When I do "systemctl start gdm", laptop goes black and gnome starts

Autologin?

Last edited by seth (2021-10-07 14:41:25)

Online

#9 2021-10-07 15:02:44

cornleader
Member
Registered: 2020-12-28
Posts: 8

Re: laptop stuck on external monitor

When I do "systemctl start gdm", laptop goes black and gnome starts
Autologin?

Yes.

Sounds like https://wiki.archlinux.org/title/GDM#Se … r_settings forces the external display? Doesn't explain why apparently only the HDMI is shown in xrandr, but it's start by moving away the monitors.xml

not sure if you want me to do something here.
there are 2 relevant files here...
monitors.xml~
monitors.xml.old
I may have moved the original to *.old  during troubleshooting
I re-enabled the *.old file, rebooted, but same. only external monitor.

Offline

#10 2021-10-07 15:17:02

seth
Member
Registered: 2012-09-03
Posts: 24,101

Re: laptop stuck on external monitor

there are 2 relevant files here...

In your $HOME or /var/lib/gdm/.config/ ?

Yes.

Disable that, start GDM - do you use the internal display before logging into the gnome session and do you maybe keep using it logging into eg. openbox/icewm…?

Online

#11 2021-10-07 15:42:06

cornleader
Member
Registered: 2020-12-28
Posts: 8

Re: laptop stuck on external monitor

seth wrote:

there are 2 relevant files here...

In your $HOME or /var/lib/gdm/.config/ ?

~/.config

seth wrote:

Yes.

Disable that, start GDM - do you use the internal display before logging into the gnome session and do you maybe keep using it logging into eg. openbox/icewm…?

disabled autologin. Login screen shows on TV.

Offline

#12 2021-10-07 16:07:49

seth
Member
Registered: 2012-09-03
Posts: 24,101

Re: laptop stuck on external monitor

~/.config

Which is meaningless for GDM, so check /var/lib/gdm/.config …

Online

#13 2021-10-07 16:16:43

cornleader
Member
Registered: 2020-12-28
Posts: 8

Re: laptop stuck on external monitor

seth wrote:

~/.config

Which is meaningless for GDM, so check /var/lib/gdm/.config …

No monitors.xml in that location

Offline

#14 2021-10-07 20:10:21

seth
Member
Registered: 2012-09-03
Posts: 24,101

Re: laptop stuck on external monitor

Are there any other files in that path?
Make sure to https://wiki.archlinux.org/title/GDM#Use_Xorg_backend and eventually write https://wiki.archlinux.org/title/GDM#Se … r_settings

One thing that bothers me is that there's just one output in the xrandr query, though apparently you've two attached - you may want to establish what that output is and also that this is a gnome/gdm issue.
Try to start a simple X11 session(eg. openbox or even just an xterm) via startx/xinit, https://wiki.archlinux.org/title/Xinit

Online

#15 2021-10-09 12:50:57

cornleader
Member
Registered: 2020-12-28
Posts: 8

Re: laptop stuck on external monitor

Thank you for the help however I needed to get my laptop working so I was forced to reinstall linux. As much as I love Arch, I installed Manjaro as I find it to work very well and stable on this laptop, (still running arch on my server though). Since I have separate partitions for home, boot and root, re-installs are fast and easy and I can preserve my home folder and most of my program settings still work.

Once again thanks but couldn't afford the downtime.

Offline

Board footer

Powered by FluxBB