You are not logged in.

#1 2021-10-11 18:19:55

Hubbleexplorer
Member
Registered: 2021-05-15
Posts: 6

No sound on HP Pavilon 14 with dual boot

So i have this weird problem where the sound is detected but the speakers don't produce any sound. The sound works perfectly on windows and

speaker-test

also doesn't work.
Output of 

 pacmd list-sinks
Dninif_user ~ $: pacmd list-sinks                                                                        
1 sink(s) available.
  * index: 2
        name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
        driver: <module-alsa-card.c>
        flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
        state: RUNNING
        suspend cause: (none)
        priority: 9039
        volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
                balance 0.00
        base volume: 65536 / 100% / 0.00 dB
        volume steps: 65537
        muted: no
        current latency: 3.41 ms
        max request: 0 KiB
        max rewind: 0 KiB
        monitor source: 4
        sample spec: s16le 2ch 44100Hz
        channel map: front-left,front-right
                     Stereo
        used by: 3
        linked by: 3
        configured latency: 2.51 ms; range is 2.00 .. 2000.00 ms
        card: 0 <alsa_card.pci-0000_00_1f.3>
        module: 6
        properties:
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
                alsa.name = "Generic Analog"
                alsa.id = "Generic Analog"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "0"
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0x6017110000 irq 152"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1f.3"
                sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "34c8"
                device.product.name = "Ice Lake-LP Smart Sound Technology Audio Controller"
                device.form_factor = "internal"
                device.string = "front:0"
                device.buffering.buffer_size = "352800"
                device.buffering.fragment_size = "176400"
                device.access_mode = "mmap+timer"
                device.profile.name = "analog-stereo"
                device.profile.description = "Analog Stereo"
                device.description = "Built-in Audio Analog Stereo"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        ports:
                analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
                        properties:
                                device.icon_name = "audio-speakers"
                analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-headphones"
        active port: <analog-output-speaker>

Help is appreciated, and thank you for your time

Offline

#2 2021-10-11 18:57:33

Morta
Member
Registered: 2019-07-07
Posts: 113

Re: No sound on HP Pavilon 14 with dual boot

https://wiki.archlinux.org/title/Laptop/HP

HP Pavilion Laptop 14-ce0xxx     2019.07     Intel i7-8550U (8) @ 4.000GHz     Working with Alsa     RTL8111/8168/8411     RTL8821CE     Untested     ACPI: Working
Suspend to RAM: Working
Suspend to Disk: Working
Battery: Working
Display dimming: Working
CPU frequency scaling: Untested
Rotation sensor: Untested     Untested     Hot Keys: Working
Webcam: Untested
Keyboard backlight: Working     For WiFi you need to download an unofficial version from GitHub.

As info from ArchWiki the sound should work with alsa...

Have you installed alsa and pulseaudio?

Offline

#3 2021-10-11 19:06:51

Hubbleexplorer
Member
Registered: 2021-05-15
Posts: 6

Re: No sound on HP Pavilon 14 with dual boot

Morta wrote:

https://wiki.archlinux.org/title/Laptop/HP

HP Pavilion Laptop 14-ce0xxx     2019.07     Intel i7-8550U (8) @ 4.000GHz     Working with Alsa     RTL8111/8168/8411     RTL8821CE     Untested     ACPI: Working
Suspend to RAM: Working
Suspend to Disk: Working
Battery: Working
Display dimming: Working
CPU frequency scaling: Untested
Rotation sensor: Untested     Untested     Hot Keys: Working
Webcam: Untested
Keyboard backlight: Working     For WiFi you need to download an unofficial version from GitHub.

As info from ArchWiki the sound should work with alsa...

Have you installed alsa and pulseaudio?

Yes i have double check that they are both working

Offline

Board footer

Powered by FluxBB