You are not logged in.

#1 2021-10-12 10:54:56

sayonalion
Member
Registered: 2016-10-25
Posts: 33

Unable to update opencv

Hi.

When trying to upgrade the system by using `pacman -Syu` I get the following error.

error: failed retrieving file 'opencv-4.5.4-1-x86_64.pkg.tar.zst' from mirror.yandex.ru : The requested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (failed to retrieve some files)

This has been happening already for two days. As is clear from the error message, for some reason the package is absent in the repository. What can be done in this situation to fix the described problem?

Thanks.

Offline

#2 2021-10-12 11:16:49

dogknowsnx
Member
Registered: 2021-04-12
Posts: 58

Re: Unable to update opencv

Offline

#3 2021-10-12 11:22:57

sayonalion
Member
Registered: 2016-10-25
Posts: 33

Re: Unable to update opencv

Could you be more specific. What exactly could be done from my side to fix the problem?

Offline

#4 2021-10-12 11:32:40

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,112

Re: Unable to update opencv

You need to change your top mirror to a more active one, see https://archlinux.org/mirrors/status/ the mirror it tries to use here has a potential synchronisation delay of 15 hours.

Offline

#5 2021-10-12 13:38:43

sayonalion
Member
Registered: 2016-10-25
Posts: 33

Re: Unable to update opencv

V1del The mirror I use (`http://mirror.yandex.ru/archlinux/`) is listed in the successfully synced mirrors table with 100% completion. The package opencv-4.5.4-1-x86_64.pkg.tar.zst is present in the repository. However I still can't upgrade the system.

error: failed retrieving file 'opencv-4.5.4-1-x86_64.pkg.tar.zst' from mirror.yandex.ru : The requested URL returned error: 404

I understand, I can change the mirror, but I'd like to figure out the reason behind the situation.

Offline

#6 2021-10-12 13:43:44

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,112

Re: Unable to update opencv

The entry exists, but the package doesn't. Try clicking on it. The mirror is broken, for at least this package

Offline

#7 2021-10-12 14:45:02

Scimmia
Fellow
Registered: 2012-09-01
Posts: 8,699

Re: Unable to update opencv

sayonalion wrote:

V1del The mirror I use (`http://mirror.yandex.ru/archlinux/`) is listed in the successfully synced mirrors table with 100% completion. The package opencv-4.5.4-1-x86_64.pkg.tar.zst is present in the repository. However I still can't upgrade the system.

error: failed retrieving file 'opencv-4.5.4-1-x86_64.pkg.tar.zst' from mirror.yandex.ru : The requested URL returned error: 404

I understand, I can change the mirror, but I'd like to figure out the reason behind the situation.

"successfully syncing" just means that the mirror says it's synced in the last few days. "100% completion" just means that the checks completed; ie the mirror isn't offline. Neither one means that it isn't broken.

Offline

#8 2021-10-13 11:28:47

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,515

Re: Unable to update opencv

Yesterday the mirror showed 2 versions of opencv , 4.5.3 and 4.5.4 .
Today it shows  only 4.5.4 .

Looks like the mirror server broke syrubng a sync operation .
Do you have multiple mirrors enabled and use parallel downloads ?


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#9 2021-10-13 16:27:52

sayonalion
Member
Registered: 2016-10-25
Posts: 33

Re: Unable to update opencv

Today I was successfully upgrade the system. OpenCV was updated to 4.5.4 without any errors. It seems there were some temporary problems on the mirror provider side.

This was the first time in 5 or 6 years of using Arch on this machine I run into a situation of inability to upgrade the system for several days.

Lone_Wolf I have only one mirror enabled. Pacman downloads packages in parallel.

Offline

Board footer

Powered by FluxBB