You are not logged in.

#1 2021-10-13 20:19:04

Markov889889
Member
Registered: 2021-10-13
Posts: 4

Cannot login to the desktop[SOLVED]

I am unable to login to my xfce desktop. Everytime i put in correct name and password, the screen goes black for couple seconds and gives me back the log in prompt.

However i am able to log in through tty2

Im failing to figure out what is the problem. But i will try to detail what happened:

i first followed this turtorial https://e-leclercq.github.io/posts/2020/03/blog-post-3/

and did everything said on it. After launching startx i couldnt exit i3 and return to my xfce and system running in the background. So i restarted the system.

This is when this all started. I proceeded to redo all the steps mentioned in the link by removing everything i installed. Then i update my system, re-installed xorg, re installed xfce, and i still couldnt fix it.

I cant figure out what is the problem, and thus cant get my pc running properly again.

Last edited by Markov889889 (2021-10-14 10:05:25)

Offline

#2 2021-10-13 20:37:41

Ammako
Member
Registered: 2021-07-16
Posts: 266

Re: Cannot login to the desktop[SOLVED]

Random internet guides aren't the way to go here.

https://wiki.archlinux.org/title/I3

https://wiki.archlinux.org/title/Xfce

What have you actually done? This page mentions nothing about xfce, so we have no idea what your system is set up like.

Sounds like you ran startx to run i3 on top of Xfce? Why? It may be possible to replace Xfwm with i3, but that's really not the way you do that kind of thing.

This black screen login loop is usually caused by your home folder being missing, or file permissions on it (or critical files within it) being wrong. For KDE that is what happens, no idea if Xfce behaves the same way.

Last edited by Ammako (2021-10-13 20:39:26)

Offline

#3 2021-10-13 20:47:08

Markov889889
Member
Registered: 2021-10-13
Posts: 4

Re: Cannot login to the desktop[SOLVED]

I have quite litterally did everything as laid out in the mentioned link... except of course i did it on top xfce. I mean i did know it could go wrong, but not this wrong.....

Last edited by Markov889889 (2021-10-13 20:47:29)

Offline

#4 2021-10-13 21:32:30

loqs
Member
Registered: 2014-03-06
Posts: 14,248

Re: Cannot login to the desktop[SOLVED]

That link contains

This can be done by appending exec i3 to the bottom of your user’s .xinitrc file.

Which will not as claimed execute i3 when startx is executed,  it will have no effect.  Given startx executed i3 you did not exactly follow the flawed instructions.
What is the contents of .xinitrc as it is now?

You have not explained what if any changes you made that might be starting X on login / boot.

Last edited by loqs (2021-10-13 21:37:59)

Offline

#5 2021-10-13 21:36:14

seth
Member
Registered: 2012-09-03
Posts: 24,984

Re: Cannot login to the desktop[SOLVED]

1. how do you start xfce? startx or some DM (lightdm etc.)
2. cat ~/.xinitrc
3. 2. cat ~/.dmrc

Offline

#6 2021-10-14 09:24:10

Markov889889
Member
Registered: 2021-10-13
Posts: 4

Re: Cannot login to the desktop[SOLVED]

when i try to run lightdm i get a error response:

“ lightdm:600) WARNING: 10:51:54.449: Error getting  user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.error.ServiceUnknowm: The name org.freedesktop.Aacounts was not provided by any .service files. Failed to use bus name org.freedesktop.Displaamanager, do you have appropriate permissions?”


the content of .dmrc on my home directory is

“[Desktop]
Session=xfce”

meanwhile i have no .xinitric directory on my home folder. I used to have it but i deleted it. And so far by undoing steps from formentioned  turtorial i managed to delete i3, and of course reinstalling xorg.

Other than that i litterally did everything said by flawed instruction. It did start i3, albeit in more or less weird way. I really dont know how it did.

Last edited by Markov889889 (2021-10-14 09:25:31)

Offline

#7 2021-10-14 09:55:16

Markov889889
Member
Registered: 2021-10-13
Posts: 4

Re: Cannot login to the desktop[SOLVED]

Alright the problem is solved, after i removed: rm ~/.Xauthority

Thank you all, i should be more careful next time.

Offline

Board footer

Powered by FluxBB