You are not logged in.

#1 2021-10-21 17:20:45

sklorpion
Member
From: Cracovia
Registered: 2013-02-03
Posts: 9

after update i got problems "pyGTK missing, install python"

Hi,

i recently did some update& upgrade :

cat /var/log/pacman.log | grep 2021-10-2.*
[2021-10-20T20:08:12+0200] [PACMAN] Running 'pacman --sync -y -u --'
[2021-10-20T20:08:12+0200] [PACMAN] synchronizing package lists
[2021-10-20T20:08:16+0200] [PACMAN] starting full system upgrade
[2021-10-20T20:11:41+0200] [ALPM] transaction started
[2021-10-20T20:11:41+0200] [ALPM] upgraded blosc (1.21.0-1 -> 1.21.1-1)
[2021-10-20T20:11:41+0200] [ALPM] upgraded libffi (3.3-4 -> 3.4.2-4)
[2021-10-20T20:11:41+0200] [ALPM] upgraded libp11-kit (0.24.0-1 -> 0.24.0-2)
[2021-10-20T20:11:41+0200] [ALPM] upgraded glib2 (2.70.0-1 -> 2.70.0-2)
[2021-10-20T20:11:41+0200] [ALPM] upgraded p11-kit (0.24.0-1 -> 0.24.0-2)
[2021-10-20T20:11:41+0200] [ALPM] upgraded file (5.40-6 -> 5.41-1)
[2021-10-20T20:11:41+0200] [ALPM] upgraded wayland (1.19.0-1 -> 1.19.0-2)
[2021-10-20T20:11:42+0200] [ALPM] upgraded llvm-libs (12.0.1-4 -> 12.0.1-5)
[2021-10-20T20:11:42+0200] [ALPM] upgraded chromium (94.0.4606.81-1 -> 95.0.4638.54-2)
[2021-10-20T20:11:42+0200] [ALPM] upgraded gobject-introspection-runtime (1.70.0-1 -> 1.70.0-2)
[2021-10-20T20:11:42+0200] [ALPM] upgraded cjs (5.0.1-1 -> 5.0.1-2)
[2021-10-20T20:11:42+0200] [ALPM] upgraded gambas3-runtime (3.16.3-2 -> 3.16.3-3)
[2021-10-20T20:11:42+0200] [ALPM] upgraded gambas3-dev-tools (3.16.3-2 -> 3.16.3-3)
[2021-10-20T20:11:42+0200] [ALPM] upgraded gambas3-gb-image (3.16.3-2 -> 3.16.3-3)
[2021-10-20T20:11:42+0200] [ALPM] upgraded gambas3-gb-desktop (3.16.3-2 -> 3.16.3-3)
[2021-10-20T20:11:42+0200] [ALPM] upgraded gambas3-gb-desktop-x11 (3.16.3-2 -> 3.16.3-3)
[2021-10-20T20:11:43+0200] [ALPM] upgraded qt5-base (5.15.2+kde+r243-1 -> 5.15.2+kde+r247-1)
[2021-10-20T20:11:43+0200] [ALPM] upgraded qt5-declarative (5.15.2+kde+r33-1 -> 5.15.2+kde+r34-1)
[2021-10-20T20:11:43+0200] [ALPM] upgraded gambas3-gb-qt5 (3.16.3-2 -> 3.16.3-3)
[2021-10-20T20:11:43+0200] [ALPM] upgraded gambas3-gb-form (3.16.3-2 -> 3.16.3-3)
[2021-10-20T20:11:43+0200] [ALPM] upgraded glib2-docs (2.70.0-1 -> 2.70.0-2)
[2021-10-20T20:11:43+0200] [ALPM] upgraded python (3.9.7-1 -> 3.9.7-2)
[2021-10-20T20:11:43+0200] [ALPM] upgraded gobject-introspection (1.70.0-1 -> 1.70.0-2)
[2021-10-20T20:11:43+0200] [ALPM] upgraded guile (2.2.7-1 -> 2.2.7-2)
[2021-10-20T20:11:43+0200] [ALPM] upgraded guile2.0 (2.0.14-5 -> 2.0.14-6)
[2021-10-20T20:11:43+0200] [ALPM] upgraded lib32-libffi (3.3-4.1 -> 3.4.2-3)
[2021-10-20T20:11:43+0200] [ALPM] upgraded lib32-glib2 (2.70.0-1 -> 2.70.0-5)
[2021-10-20T20:11:44+0200] [ALPM] upgraded lib32-llvm-libs (12.0.1-2 -> 12.0.1-3)
[2021-10-20T20:11:44+0200] [ALPM] upgraded mpg123 (1.29.0-1 -> 1.29.1-1)
[2021-10-20T20:11:44+0200] [ALPM] upgraded lib32-mpg123 (1.29.0-1 -> 1.29.1-1)
[2021-10-20T20:11:44+0200] [ALPM] upgraded lib32-p11-kit (0.24.0-1 -> 0.24.0-2)
[2021-10-20T20:11:44+0200] [ALPM] upgraded lib32-wayland (1.19.0-1 -> 1.19.0-2)
[2021-10-20T20:11:45+0200] [ALPM] upgraded llvm (12.0.1-4 -> 12.0.1-5)
[2021-10-20T20:11:45+0200] [ALPM] upgraded mplayer (38157-4 -> 38322-1)
[2021-10-20T20:11:45+0200] [ALPM] upgraded ocaml-ctypes (0.17.1-6 -> 0.17.1-8)
[2021-10-20T20:11:45+0200] [ALPM] upgraded openttd (1.11.2-5 -> 12.0-1)
[2021-10-20T20:11:45+0200] [ALPM] upgraded openttd-opengfx (0.6.1-1 -> 7.1-1)
[2021-10-20T20:11:45+0200] [ALPM] upgraded perl-glib-object-introspection (0.047-6 -> 0.047-7)
[2021-10-20T20:11:45+0200] [ALPM] installed perl-yaml-pp (0.026-1)
[2021-10-20T20:11:45+0200] [ALPM] upgraded perl-pegex (0.70-4 -> 0.75-1)
[2021-10-20T20:11:46+0200] [ALPM] upgraded php (8.0.11-1 -> 8.0.11-2)
[2021-10-20T20:11:46+0200] [ALPM] upgraded php-apache (8.0.11-1 -> 8.0.11-2)
[2021-10-20T20:11:46+0200] [ALPM] upgraded python-cffi (1.14.6-1 -> 1.14.6-2)
[2021-10-20T20:11:46+0200] [ALPM] upgraded python-feedparser (5.2.1-9 -> 6.0.1-1)
[2021-10-20T20:11:46+0200] [ALPM] upgraded python-gobject (3.40.1-1 -> 3.40.1-2)
[2021-10-20T20:11:47+0200] [ALPM] upgraded python-pyqt5 (5.15.4-1 -> 5.15.5-1)
[2021-10-20T20:11:47+0200] [ALPM] upgraded python2 (2.7.18-4 -> 2.7.18-5)
[2021-10-20T20:11:47+0200] [ALPM] upgraded python2-gobject (3.36.1-3 -> 3.36.1-4)
[2021-10-20T20:11:47+0200] [ALPM] upgraded ruby (3.0.2-1 -> 3.0.2-2)
[2021-10-20T20:11:47+0200] [ALPM] upgraded ruby-ffi (1.15.4-1 -> 1.15.4-2)
[2021-10-20T20:11:48+0200] [ALPM] upgraded thunderbird (91.2.0-1 -> 91.2.0-2)
[2021-10-20T20:11:48+0200] [ALPM] upgraded thunderbird-i18n-pl (91.2.0-1 -> 91.2.0-2)
[2021-10-20T20:11:48+0200] [ALPM] transaction completed
[2021-10-20T20:11:49+0200] [ALPM] running '30-systemd-update.hook'...
[2021-10-20T20:11:49+0200] [ALPM] running 'detect-old-perl-modules.hook'...
[2021-10-20T20:11:49+0200] [ALPM-SCRIPTLET] ostrzeżenie: plik konfiguracyjny /etc/pacman.conf, linia 36: dyrektywa 'TotalDownload' w sekcji 'options' nie została rozpoznana.
[2021-10-20T20:11:49+0200] [ALPM-SCRIPTLET] WARNING: '/usr/lib/perl5/5.28' contains data from at least 5 packages which will NOT be used by the installed perl interpreter.
[2021-10-20T20:11:49+0200] [ALPM-SCRIPTLET]  -> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/5.28'
[2021-10-20T20:11:49+0200] [ALPM-SCRIPTLET] ostrzeżenie: plik konfiguracyjny /etc/pacman.conf, linia 36: dyrektywa 'TotalDownload' w sekcji 'options' nie została rozpoznana.
[2021-10-20T20:11:49+0200] [ALPM-SCRIPTLET] WARNING: '/usr/lib/perl5/5.30' contains data from at least 1 packages which will NOT be used by the installed perl interpreter.
[2021-10-20T20:11:49+0200] [ALPM-SCRIPTLET]  -> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/5.30'
[2021-10-20T20:11:49+0200] [ALPM] running 'gtk-update-icon-cache.hook'...
[2021-10-20T20:11:49+0200] [ALPM] running 'texinfo-install.hook'...
[2021-10-20T20:11:50+0200] [ALPM] running 'update-desktop-database.hook'...
[2021-10-20T20:16:57+0200] [PACMAN] Running 'pacman -Syu'
[2021-10-20T20:16:57+0200] [PACMAN] synchronizing package lists
[2021-10-20T20:16:57+0200] [PACMAN] starting full system upgrade
[2021-10-20T20:17:05+0200] [PACMAN] Running 'pacman -S -y -u --config /etc/pacman.conf --'
[2021-10-20T20:17:05+0200] [PACMAN] synchronizing package lists
[2021-10-20T20:17:05+0200] [PACMAN] starting full system upgrade
[2021-10-20T20:17:27+0200] [PACMAN] Running 'pacman -S -y -u --config /etc/pacman.conf --'
[2021-10-20T20:17:27+0200] [PACMAN] synchronizing package lists
[2021-10-20T20:17:27+0200] [PACMAN] starting full system upgrade
[2021-10-20T20:17:43+0200] [PACMAN] Running 'pacman -S -y -u --config /etc/pacman.conf --'
[2021-10-20T20:17:43+0200] [PACMAN] synchronizing package lists
[2021-10-20T20:17:44+0200] [PACMAN] starting full system upgrade
[2021-10-20T20:18:30+0200] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/caca/.cache/yay/brave-bin/brave-bin-1:1.31.87-1-x86_64.pkg.tar'
[2021-10-20T20:18:30+0200] [ALPM] transaction started
[2021-10-20T20:18:30+0200] [ALPM] upgraded brave-bin (1:1.30.89-1 -> 1:1.31.87-1)
[2021-10-20T20:18:30+0200] [ALPM] transaction completed
[2021-10-20T20:18:30+0200] [ALPM] running '30-systemd-update.hook'...
[2021-10-20T20:18:30+0200] [ALPM] running 'gtk-update-icon-cache.hook'...
[2021-10-20T20:18:30+0200] [ALPM] running 'update-desktop-database.hook'...
[2021-10-20T20:18:42+0200] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/caca/.cache/yay/google-chrome/google-chrome-95.0.4638.54-1-x86_64.pkg.tar'
[2021-10-20T20:18:42+0200] [ALPM] transaction started
[2021-10-20T20:18:42+0200] [ALPM] upgraded google-chrome (94.0.4606.81-1 -> 95.0.4638.54-1)
[2021-10-20T20:18:42+0200] [ALPM-SCRIPTLET] ==> NOTE: Custom flags should be put directly in: ~/.config/chrome-flags.conf
[2021-10-20T20:18:42+0200] [ALPM-SCRIPTLET] ==> NOTE: The launcher is called: 'google-chrome-stable'
[2021-10-20T20:18:42+0200] [ALPM] transaction completed
[2021-10-20T20:18:42+0200] [ALPM] running '30-systemd-update.hook'...
[2021-10-20T20:18:42+0200] [ALPM] running 'gtk-update-icon-cache.hook'...
[2021-10-20T20:18:42+0200] [ALPM] running 'update-desktop-database.hook'...
[2021-10-20T20:19:57+0200] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/caca/.cache/yay/mangohud/mangohud-common-0.6.6-2-x86_64.pkg.tar /home/caca/.cache/yay/mangohud/lib32-mangohud-0.6.6-2-x86_64.pkg.tar /home/caca/.cache/yay/mangohud/mangohud-0.6.6-2-x86_64.pkg.tar'
[2021-10-20T20:19:57+0200] [ALPM] transaction started
[2021-10-20T20:19:57+0200] [ALPM] upgraded mangohud-common (0.6.5-1 -> 0.6.6-2)
[2021-10-20T20:19:57+0200] [ALPM] upgraded lib32-mangohud (0.6.5-1 -> 0.6.6-2)
[2021-10-20T20:19:57+0200] [ALPM] upgraded mangohud (0.6.5-1 -> 0.6.6-2)
[2021-10-20T20:19:57+0200] [ALPM] transaction completed
[2021-10-20T20:19:57+0200] [ALPM] running '30-systemd-update.hook'...
[2021-10-20T20:20:15+0200] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/caca/.cache/yay/pamac-aur/pamac-aur-10.2.2-1-x86_64.pkg.tar'
[2021-10-20T20:20:15+0200] [ALPM] transaction started
[2021-10-20T20:20:15+0200] [ALPM] upgraded pamac-aur (10.2.1-2 -> 10.2.2-1)
[2021-10-20T20:20:16+0200] [ALPM] transaction completed
[2021-10-20T20:20:16+0200] [ALPM] running '30-systemd-update.hook'...
[2021-10-20T20:20:16+0200] [ALPM] running 'gtk-update-icon-cache.hook'...
[2021-10-20T20:20:16+0200] [ALPM] running 'update-desktop-database.hook'...
[2021-10-21T18:05:13+0200] [PACMAN] Running 'pacman --sync -y -u --'
[2021-10-21T18:05:13+0200] [PACMAN] synchronizing package lists
[2021-10-21T18:05:17+0200] [PACMAN] starting full system upgrade
[2021-10-21T18:07:43+0200] [ALPM] running '60-mkinitcpio-remove.hook'...
[2021-10-21T18:07:43+0200] [ALPM] running '71-dkms-remove.hook'...
[2021-10-21T18:07:43+0200] [ALPM-SCRIPTLET] ==> dkms remove --no-depmod -m vboxhost -v 6.1.26_OSE -k 5.14.9-arch2-1
[2021-10-21T18:07:44+0200] [ALPM-SCRIPTLET] ==> depmod 5.14.9-arch2-1
[2021-10-21T18:07:47+0200] [ALPM-SCRIPTLET] ==> Unable to remove module ddcci/0.4.1 for kernel 5.14.12-zen1-1-zen: Not found in dkms status output.
[2021-10-21T18:07:47+0200] [ALPM-SCRIPTLET] ==> Unable to remove module v4l2loopback/0.12.5 for kernel 5.14.12-zen1-1-zen: Not found in dkms status output.
[2021-10-21T18:07:47+0200] [ALPM-SCRIPTLET] ==> Unable to remove module vboxhost/6.1.26_OSE for kernel 5.14.12-zen1-1-zen: Not found in dkms status output.
[2021-10-21T18:07:47+0200] [ALPM-SCRIPTLET] ==> Unable to remove module ntfs3/5.15 for kernel 5.14.12-zen1-1-zen: Not found in dkms status output.
[2021-10-21T18:07:47+0200] [ALPM-SCRIPTLET] ==> Unable to remove module rtl88x2bu/5.8.7.4.r129.15c214d for kernel 5.14.12-zen1-1-zen: Not found in dkms status output.
[2021-10-21T18:07:47+0200] [ALPM-SCRIPTLET] ==> Unable to remove module v4l2loopback-dc/1.8.0 for kernel 5.14.12-zen1-1-zen: Not found in dkms status output.
[2021-10-21T18:07:47+0200] [ALPM-SCRIPTLET] ==> Unable to remove module rtl88x2bu/5.3.1.r41.c1a5dab for kernel 5.14.12-zen1-1-zen: Not found in dkms status output.
[2021-10-21T18:07:47+0200] [ALPM] transaction started
[2021-10-21T18:07:47+0200] [ALPM] removed python-sgmllib (5.2.1-9)
[2021-10-21T18:07:47+0200] [ALPM] upgraded i3-gaps (4.19.1-1 -> 4.20-1)
[2021-10-21T18:07:47+0200] [ALPM] upgraded systemd-libs (249.5-1 -> 249.5-2)
[2021-10-21T18:07:47+0200] [ALPM] upgraded libsrtp (1:2.4.0-1 -> 1:2.4.2-1)
[2021-10-21T18:07:47+0200] [ALPM] upgraded systemd (249.5-1 -> 249.5-2)
[2021-10-21T18:07:48+0200] [ALPM] upgraded linux-zen (5.14.12.zen1-1 -> 5.14.14.zen1-1)
[2021-10-21T18:07:48+0200] [ALPM] upgraded opera-ffmpeg-codecs (94.0.4606.61-1 -> 94.0.4606.81-1)
[2021-10-21T18:07:48+0200] [ALPM] upgraded php (8.0.11-2 -> 8.0.12-1)
[2021-10-21T18:07:48+0200] [ALPM] upgraded php-apache (8.0.11-2 -> 8.0.12-1)
[2021-10-21T18:07:48+0200] [ALPM] installed python-sgmllib3k (1.0.0-2)
[2021-10-21T18:07:48+0200] [ALPM] upgraded python-feedparser (6.0.1-1 -> 6.0.1-2)
[2021-10-21T18:07:49+0200] [ALPM] upgraded qt5-base (5.15.2+kde+r247-1 -> 5.15.2+kde+r251-1)
[2021-10-21T18:07:49+0200] [ALPM] upgraded qt5-declarative (5.15.2+kde+r34-1 -> 5.15.2+kde+r36-1)
[2021-10-21T18:07:49+0200] [ALPM] upgraded systemd-sysvcompat (249.5-1 -> 249.5-2)
[2021-10-21T18:07:49+0200] [ALPM] upgraded virtualbox-host-dkms (6.1.26-1 -> 6.1.28-2)
[2021-10-21T18:07:49+0200] [ALPM] upgraded virtualbox (6.1.26-1 -> 6.1.28-2)
[2021-10-21T18:07:50+0200] [ALPM] upgraded wine-staging (6.17-1 -> 6.18-1)
[2021-10-21T18:07:50+0200] [ALPM] transaction completed
[2021-10-21T18:07:50+0200] [ALPM] running '20-systemd-sysusers.hook'...
[2021-10-21T18:07:50+0200] [ALPM] running '30-systemd-binfmt.hook'...
[2021-10-21T18:07:50+0200] [ALPM] running '30-systemd-catalog.hook'...
[2021-10-21T18:07:51+0200] [ALPM] running '30-systemd-daemon-reload.hook'...
[2021-10-21T18:07:51+0200] [ALPM] running '30-systemd-hwdb.hook'...
[2021-10-21T18:07:51+0200] [ALPM] running '30-systemd-sysctl.hook'...
[2021-10-21T18:07:51+0200] [ALPM] running '30-systemd-tmpfiles.hook'...
[2021-10-21T18:07:51+0200] [ALPM] running '30-systemd-udev-reload.hook'...
[2021-10-21T18:07:51+0200] [ALPM] running '30-systemd-update.hook'...
[2021-10-21T18:07:51+0200] [ALPM] running '60-depmod.hook'...
[2021-10-21T18:07:52+0200] [ALPM] running '70-dkms-install.hook'...
[2021-10-21T18:07:53+0200] [ALPM-SCRIPTLET] ==> dkms install --no-depmod -m vboxhost -v 6.1.28_OSE -k 5.14.9-arch2-1
[2021-10-21T18:07:59+0200] [ALPM-SCRIPTLET] ==> depmod 5.14.9-arch2-1
[2021-10-21T18:08:00+0200] [ALPM-SCRIPTLET] ==> Unable to install module ddcci/0.4.1 for kernel 5.14.14-zen1-1-zen: Missing kernel headers.
[2021-10-21T18:08:00+0200] [ALPM-SCRIPTLET] ==> Unable to install module vboxhost/6.1.28_OSE for kernel 5.14.14-zen1-1-zen: Missing kernel headers.
[2021-10-21T18:08:00+0200] [ALPM-SCRIPTLET] ==> Unable to install module v4l2loopback-dc/1.8.0 for kernel 5.14.14-zen1-1-zen: Missing kernel headers.
[2021-10-21T18:08:00+0200] [ALPM-SCRIPTLET] ==> Unable to install module ntfs3/5.15 for kernel 5.14.14-zen1-1-zen: Missing kernel headers.
[2021-10-21T18:08:00+0200] [ALPM-SCRIPTLET] ==> Unable to install module rtl88x2bu/5.8.7.4.r129.15c214d for kernel 5.14.14-zen1-1-zen: Missing kernel headers.
[2021-10-21T18:08:00+0200] [ALPM-SCRIPTLET] ==> Unable to install module v4l2loopback/0.12.5 for kernel 5.14.14-zen1-1-zen: Missing kernel headers.
[2021-10-21T18:08:00+0200] [ALPM-SCRIPTLET] ==> Unable to install module rtl88x2bu/5.3.1.r41.c1a5dab for kernel 5.14.14-zen1-1-zen: Missing kernel headers.
[2021-10-21T18:08:00+0200] [ALPM] running '90-mkinitcpio-install.hook'...
[2021-10-21T18:08:00+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2021-10-21T18:08:00+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2021-10-21T18:08:00+0200] [ALPM-SCRIPTLET] ==> Starting build: 5.14.9-arch2-1
[2021-10-21T18:08:00+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2021-10-21T18:08:00+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2021-10-21T18:08:00+0200] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2021-10-21T18:08:00+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2021-10-21T18:08:00+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2021-10-21T18:08:01+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2021-10-21T18:08:01+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2021-10-21T18:08:01+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2021-10-21T18:08:01+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2021-10-21T18:08:01+0200] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2021-10-21T18:08:02+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2021-10-21T18:08:02+0200] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2021-10-21T18:08:04+0200] [ALPM-SCRIPTLET] ==> Image generation successful
[2021-10-21T18:08:04+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2021-10-21T18:08:04+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2021-10-21T18:08:04+0200] [ALPM-SCRIPTLET] ==> Starting build: 5.14.9-arch2-1
[2021-10-21T18:08:04+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2021-10-21T18:08:05+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2021-10-21T18:08:05+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2021-10-21T18:08:05+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2021-10-21T18:08:05+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2021-10-21T18:08:05+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2021-10-21T18:08:06+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2021-10-21T18:08:07+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2021-10-21T18:08:08+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2021-10-21T18:08:08+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2021-10-21T18:08:08+0200] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2021-10-21T18:08:09+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2021-10-21T18:08:09+0200] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2021-10-21T18:08:13+0200] [ALPM-SCRIPTLET] ==> Image generation successful
[2021-10-21T18:08:13+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-zen.preset: 'default'
[2021-10-21T18:08:13+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-zen -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-zen.img
[2021-10-21T18:08:13+0200] [ALPM-SCRIPTLET] ==> Starting build: 5.14.14-zen1-1-zen
[2021-10-21T18:08:13+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2021-10-21T18:08:13+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2021-10-21T18:08:13+0200] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2021-10-21T18:08:13+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2021-10-21T18:08:13+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2021-10-21T18:08:13+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2021-10-21T18:08:13+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2021-10-21T18:08:14+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2021-10-21T18:08:14+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2021-10-21T18:08:14+0200] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2021-10-21T18:08:14+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2021-10-21T18:08:14+0200] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-zen.img
[2021-10-21T18:08:16+0200] [ALPM-SCRIPTLET] ==> Image generation successful
[2021-10-21T18:08:16+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-zen.preset: 'fallback'
[2021-10-21T18:08:16+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-zen -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-zen-fallback.img -S autodetect
[2021-10-21T18:08:16+0200] [ALPM-SCRIPTLET] ==> Starting build: 5.14.14-zen1-1-zen
[2021-10-21T18:08:17+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2021-10-21T18:08:17+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2021-10-21T18:08:17+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2021-10-21T18:08:17+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2021-10-21T18:08:17+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2021-10-21T18:08:17+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2021-10-21T18:08:18+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2021-10-21T18:08:19+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2021-10-21T18:08:19+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2021-10-21T18:08:19+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2021-10-21T18:08:20+0200] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2021-10-21T18:08:21+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2021-10-21T18:08:21+0200] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-zen-fallback.img
[2021-10-21T18:08:24+0200] [ALPM-SCRIPTLET] ==> Image generation successful
[2021-10-21T18:08:24+0200] [ALPM] running 'dbus-reload.hook'...
[2021-10-21T18:08:24+0200] [ALPM] running 'fontconfig.hook'...
[2021-10-21T18:08:24+0200] [ALPM] running 'fontconfig-32.hook'...
[2021-10-21T18:08:24+0200] [ALPM] running 'gtk-update-icon-cache.hook'...
[2021-10-21T18:08:24+0200] [ALPM] running 'update-desktop-database.hook'...
[2021-10-21T18:08:24+0200] [ALPM] running 'update-mime-database.hook'...
[2021-10-21T18:08:57+0200] [PACMAN] Running 'pacman --sync -y -u --'
[2021-10-21T18:08:57+0200] [PACMAN] synchronizing package lists
[2021-10-21T18:08:58+0200] [PACMAN] starting full system upgrade
[2021-10-21T18:24:14+0200] [PACMAN] Running 'pacman -S python-gtk2'
[2021-10-21T18:27:01+0200] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/caca/.cache/yay/pygtk/pygtk-2.24.0-12-x86_64.pkg.tar'
[2021-10-21T18:27:01+0200] [ALPM] transaction started
[2021-10-21T18:27:01+0200] [ALPM] reinstalled pygtk (2.24.0-12)
[2021-10-21T18:27:01+0200] [ALPM] transaction completed
[2021-10-21T18:27:01+0200] [ALPM] running '30-systemd-update.hook'...
[2021-10-21T18:29:54+0200] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/caca/.cache/yay/czkawka-gui-bin/czkawka-gui-bin-3.2.0-1-x86_64.pkg.tar'
[2021-10-21T18:29:54+0200] [ALPM] transaction started
[2021-10-21T18:29:54+0200] [ALPM] installed czkawka-gui-bin (3.2.0-1)
[2021-10-21T18:29:54+0200] [ALPM] transaction completed
[2021-10-21T18:29:54+0200] [ALPM] running '30-systemd-update.hook'...
[2021-10-21T18:29:54+0200] [ALPM] running 'update-desktop-database.hook'...
[2021-10-21T18:42:19+0200] [PACMAN] Running 'pacman -U https://archive.archlinux.org/packages/p/python2/python2-2.7.18-5-x86_64.pkg.tar.zst'
[2021-10-21T18:42:37+0200] [PACMAN] Running 'pacman -U https://archive.archlinux.org/packages/p/python2/python2-2.7.18-4-x86_64.pkg.tar.zst'
[2021-10-21T18:42:40+0200] [ALPM] transaction started
[2021-10-21T18:42:40+0200] [ALPM] downgraded python2 (2.7.18-5 -> 2.7.18-4)
[2021-10-21T18:42:40+0200] [ALPM] transaction completed
[2021-10-21T18:42:40+0200] [ALPM] running '30-systemd-update.hook'...
[2021-10-21T18:44:26+0200] [PACMAN] Running 'pacman -U https://archive.archlinux.org/packages/p/python-feedparser/python-feedparser-6.0.1-1-any.pkg.tar.zst'
[2021-10-21T18:44:41+0200] [PACMAN] Running 'pacman -U https://archive.archlinux.org/packages/p/python-feedparser/python-feedparser-5.2.1-9-any.pkg.tar.zst'
[2021-10-21T18:44:43+0200] [ALPM] transaction started
[2021-10-21T18:44:43+0200] [ALPM] downgraded python-feedparser (6.0.1-2 -> 5.2.1-9)
[2021-10-21T18:44:43+0200] [ALPM] transaction completed
[2021-10-21T18:44:43+0200] [ALPM] running '30-systemd-update.hook'...
[2021-10-21T18:47:16+0200] [PACMAN] Running 'pacman -Syu'
[2021-10-21T18:47:16+0200] [PACMAN] synchronizing package lists
[2021-10-21T18:47:16+0200] [PACMAN] starting full system upgrade
[2021-10-21T18:47:38+0200] [PACMAN] Running 'pacman -S sgmllib3k'
[2021-10-21T18:48:37+0200] [PACMAN] Running 'pacman -S --config /etc/pacman.conf -- extra/python-sgmllib3k'
[2021-10-21T18:48:41+0200] [ALPM] transaction started
[2021-10-21T18:48:41+0200] [ALPM] reinstalled python-sgmllib3k (1.0.0-2)
[2021-10-21T18:48:41+0200] [ALPM] transaction completed
[2021-10-21T18:48:41+0200] [ALPM] running '30-systemd-update.hook'...
[2021-10-21T18:50:37+0200] [PACMAN] Running 'pacman -S --config /etc/pacman.conf -- extra/python2'
[2021-10-21T18:50:40+0200] [ALPM] transaction started
[2021-10-21T18:50:41+0200] [ALPM] upgraded python2 (2.7.18-4 -> 2.7.18-5)
[2021-10-21T18:50:41+0200] [ALPM] transaction completed
[2021-10-21T18:50:41+0200] [ALPM] running '30-systemd-update.hook'...
[2021-10-21T18:54:31+0200] [PAMAC] synchronizing package lists
[2021-10-21T18:54:33+0200] [ALPM] transaction started
[2021-10-21T18:54:34+0200] [ALPM] upgraded python-feedparser (5.2.1-9 -> 6.0.1-2)
[2021-10-21T18:54:34+0200] [ALPM] transaction completed
[2021-10-21T18:54:34+0200] [ALPM] running '30-systemd-update.hook'...

and now i cant run thing like obkey or oblogout
one says

 > obkey
Traceback (most recent call last):
  File "/usr/bin/obkey", line 26, in <module>
    import gtk
  File "/usr/lib/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 30, in <module>
    import gobject as _gobject
  File "/usr/lib/python2.7/site-packages/gobject/__init__.py", line 47, in <module>
    from gobject.constants import *
  File "/usr/lib/python2.7/site-packages/gobject/constants.py", line 24, in <module>
    import gobject._gobject
ImportError: libffi.so.7: cannot open shared object file: No such file or directory 

and the other

 > oblogout
pyGTK missing, install python-gtk2 

i've already tried to donwgrade python2, reinstall  etc. Donno what happend here. Can You help me?

Offline

#2 2021-10-21 17:28:44

Scimmia
Fellow
Registered: 2012-09-01
Posts: 8,747

Re: after update i got problems "pyGTK missing, install python"

It's your responsibility to rebuild any AUR packages you have installed when they need to be. Start by looking at the list of foreign packages you have installed.

Offline

#3 2021-10-21 17:42:02

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,498
Website

Re: after update i got problems "pyGTK missing, install python"

Mod note: Moving to AUR Issues.


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#4 2021-10-22 13:57:56

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,582

Re: after update i got problems "pyGTK missing, install python"

Both those packages haven't seen upstream activity in years and rely on the EOL python2 , you may want to look for alternatives.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Online

#5 2021-10-24 14:27:02

seth
Member
Registered: 2012-09-03
Posts: 24,977

Offline

Board footer

Powered by FluxBB