You are not logged in.

#1 2021-10-26 11:27:04

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 7,294

[solved] cuda-11.5.0-1 cannot be installed (PGP sig invalid/corrupted)

(25/25) checking keys in keyring                                      [######################################] 100%
(25/25) checking package integrity                                    [######################################] 100%
error: cuda: signature from "Sven-Hendrik Haase <svenstaro@archlinux.org>" is invalid
:: File /var/cache/pacman/pkg/cuda-11.5.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

pacman-key --delete on Sven-Hendrik Haase's key and pacman-key --populate archlinux didn't help.

pacman-key --refresh-keys didn't help either, in fact it comes up with quite a few 'error retrieving ...... via WKD: No data'

Not sure what else to debug, except to say I've tried this on two different internet connections (physically separate locations).

Last edited by ngoonee (2021-10-26 16:02:06)


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#2 2021-10-26 11:46:56

Scimmia
Fellow
Registered: 2012-09-01
Posts: 8,751

Re: [solved] cuda-11.5.0-1 cannot be installed (PGP sig invalid/corrupted)

This isn't a keyring problem, so pacman-key isn't going to help you. The error is that the sig is invalid, not that the key is expired or marginal trust or whatever.

Delete it and redownload. If that doesn't work, try a different mirror.

Offline

#3 2021-10-26 16:01:49

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 7,294

Re: [solved] cuda-11.5.0-1 cannot be installed (PGP sig invalid/corrupted)

Redownloaded previously (sorry for not mentioning), but changing mirror worked, thanks.


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

Board footer

Powered by FluxBB