You are not logged in.

#1 2021-11-04 08:30:52

kokoko3k
Member
Registered: 2008-11-14
Posts: 2,231

Tearing in Firefox with no compositor on Haswel igpu on X11

Hi there,
since the last couple of releases of firefox, i can't get rid of tearing while scrolling or watch videos in firefox.
Enabling an X11 compositor workarounds that issue, but often i leave it disabled to have a snappier desktop. (*1)
I've no vsync problem with other apps (compositor itself, games, mpv), but i just cannot find a setting in firefox to get rid of it.

Now i'm at firefox version 93, and i even tried version 95 from official binary package from mozilla to no avail, even starting on a clean profile, won't make a difference.
I'm on a dual head setup, but even disabling one of the monitors can't stop the tearing.

I'm using the intel driver with sna enabled because the modesetting one produces tearing in dual head with every app; also, i'd like to avoid his "tearfree" for the reason *1.

Is there a known magic recipe i'm missing? I'm fairly confident that in the past firefox's vsync worked, maybe it is an issue with the new webrender engine, but so far i was unable to disable it ( my gfx.webrender.enabled is even set to false and i also tried with gfx.webrender.force-disabled to true).
It seems that setting gfx.x11-egl.force-enabled to true makes tearing less invasive as the whole screen does not shake like mad anymore, but just the lower quarter of it.

-EDIT-
Just tried firefox version 60 and there i can stop it from tear by setting layers.acceleration.force-enabled to true.
In that case in about:support the compositing type switches from "basic" to "opengl", now i've "webrender" there; so i wonder if it is webrender itself the root of the issue. (?)

Thanks!

Last edited by kokoko3k (2021-11-04 09:06:40)


Help me to improve ssh-rdp !

Offline

Board footer

Powered by FluxBB