You are not logged in.

#1 2021-10-27 09:06:12

DarioP
Member
From: Geneva
Registered: 2011-01-05
Posts: 165

GDM black screen after entering credentials

I have a desktop (AMD CPU with no iGPU + NVIDIA discrete card) where GDM starts up fine at boot, but once I enter the password I end up with a black screen.
No matter if running Gnome on Wayland or Xorg.
If I swap to TTY3 and restart gdm.service, then it works.

I tried everything that I have been able to research (NVIDIA early kms, delay GDM start, random entropy generators) but they seem to apply to GDM not showing up at all, and have no effect to my case.

Any log that I should try to look into? Thanks!

Last edited by DarioP (2021-10-27 09:12:02)

Offline

#2 2021-10-27 09:19:39

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 15,031

Re: GDM black screen after entering credentials

Post the journal after reproduction

sudo journalctl -b

could also be some general session wonkyness, something breaking during the first start.

Offline

#3 2021-10-27 11:05:32

DarioP
Member
From: Geneva
Registered: 2011-01-05
Posts: 165

Re: GDM black screen after entering credentials

Pretty huge log, there are few errors/warnings here and there but I cannot tell which one are relevant.

https://drive.google.com/file/d/1o7KCzn … sp=sharing

In this case I was trying to start a Xorg session. I restarted GDM before trying, but it still failed, restarted again and went fine.

Thank you!

Offline

#4 2021-10-27 12:11:25

DarioP
Member
From: Geneva
Registered: 2011-01-05
Posts: 165

Re: GDM black screen after entering credentials

maybe these lines:

Oct 27 12:47:59 ogscfd systemd[1]: Starting User Manager for UID 120...
Oct 27 12:47:59 ogscfd systemd[1860]: user@120.service: Failed to attach to cgroup /user.slice/user-120.slice/user@120.service: Device or resource busy
Oct 27 12:47:59 ogscfd systemd[1860]: user@120.service: Failed at step CGROUP spawning /usr/lib/systemd/systemd: Device or resource busy
Oct 27 12:47:59 ogscfd systemd[1]: user@120.service: Main process exited, code=exited, status=219/CGROUP
Oct 27 12:47:59 ogscfd systemd[1]: user@120.service: Failed with result 'exit-code'.
Oct 27 12:47:59 ogscfd systemd[1]: Failed to start User Manager for UID 120.

If I am not mistaking they only appear after the first login attempt. I will try to investigate.

Offline

#5 2021-10-27 12:28:03

seth
Member
Registered: 2012-09-03
Posts: 26,378

Re: GDM black screen after entering credentials

Black screen and a mouse cursor?

Oct 27 12:47:34 ogscfd systemd-logind[687]: New session 9 of user dario.
Oct 27 12:47:34 ogscfd systemd[1]: Started Session 9 of User dario
…
# the X11 server starts w/o notable problems
…
Oct 27 12:47:34 ogscfd /usr/lib/gdm-x-session[1812]: localuser:dario being added to access control list
Oct 27 12:47:34 ogscfd /usr/lib/gdm-x-session[1806]: /etc/gdm/Xsession: Setup done, will execute: /usr/bin/gnome-session

But nothing happens until

Oct 27 12:47:46 ogscfd /usr/lib/gdm-x-session[1803]: (**) Option "fd" "32"
Oct 27 12:47:46 ogscfd /usr/lib/gdm-x-session[1803]: (II) event1  - Power Button: device removed
Oct 27 12:47:46 ogscfd /usr/lib/gdm-x-session[1803]: (**) Option "fd" "35"
Oct 27 12:47:46 ogscfd /usr/lib/gdm-x-session[1803]: (II) event0  - Power Button: device removed
Oct 27 12:47:46 ogscfd /usr/lib/gdm-x-session[1803]: (**) Option "fd" "36"
Oct 27 12:47:46 ogscfd /usr/lib/gdm-x-session[1803]: (**) Option "fd" "37"
Oct 27 12:47:46 ogscfd /usr/lib/gdm-x-session[1803]: (II) event16 - Logitech Wireless Mouse: device removed
Oct 27 12:47:46 ogscfd /usr/lib/gdm-x-session[1803]: (**) Option "fd" "36"
Oct 27 12:47:46 ogscfd /usr/lib/gdm-x-session[1803]: (II) event15 - Logitech Wireless Keyboard PID:4075: device removed
Oct 27 12:47:46 ogscfd gsd-media-keys[1049]: Unable to get default sink
Oct 27 12:47:46 ogscfd pipewire-media-session[971]: ms.mod.default-profile: device 'alsa_card.pci-0000_08_00.1': can't restore profile: No such device
Oct 27 12:47:46 ogscfd /usr/lib/gdm-x-session[1803]: (II) systemd-logind: got pause for 13:79
Oct 27 12:47:46 ogscfd /usr/lib/gdm-x-session[1803]: (II) systemd-logind: got pause for 13:65
Oct 27 12:47:46 ogscfd /usr/lib/gdm-x-session[1803]: (II) systemd-logind: got pause for 13:64
Oct 27 12:47:46 ogscfd /usr/lib/gdm-x-session[1803]: (II) systemd-logind: got pause for 13:80
Oct 27 12:47:49 ogscfd systemd[1]: Stopping GNOME Display Manager...

~10 sedconds later you lost patience ;-)

The run on 12:48:07 then looks a bit more successful.

Can you immediately start eg. an openbox session?

Offline

#6 2021-10-28 06:18:19

DarioP
Member
From: Geneva
Registered: 2011-01-05
Posts: 165

Re: GDM black screen after entering credentials

seth wrote:

Black screen and a mouse cursor?

Black screen. No mouse cursor is visible.
On Wayland a frozen underscore appears on the top left of the screen, on Xorg nothing at all.
I have been waiting more than 10 seconds on other occasions, but when it works, gnome-shell comes up in a fraction of a second, so I saw no point in collecting logs after that time.

seth wrote:

Can you immediately start eg. an openbox session?

Via GDM or from the TTY? I need to install it, but I could try...

I also tried early KMS but it made no difference.
I am lost, but at least restarting GDM after the failure always allows me to get in...

Offline

#7 2021-10-28 06:49:24

seth
Member
Registered: 2012-09-03
Posts: 26,378

Re: GDM black screen after entering credentials

Via GDM - GDM starts, you try to login, GDM says it's gonna start gnome-session-binary… but doesn't.
We need to see whether that's a GDM or gnome-session-binary issue.

Last edited by seth (2021-10-28 06:54:53)

Offline

#8 2021-10-29 06:52:43

DarioP
Member
From: Geneva
Registered: 2011-01-05
Posts: 165

Re: GDM black screen after entering credentials

Ok, I can launch openbox from GDM straight from the boot.
Then if I logout I can switch to gnome.

But if I launch gnome directly I still get a black screen.

Offline

#9 2021-10-29 07:20:09

seth
Member
Registered: 2012-09-03
Posts: 26,378

Re: GDM black screen after entering credentials

Do you try to start gnome on xorg or gnome on wayland when it fails?

Offline

#10 2021-10-29 10:43:05

DarioP
Member
From: Geneva
Registered: 2011-01-05
Posts: 165

Re: GDM black screen after entering credentials

It makes no difference, but I can compare the logs for both cases and see if I get any hint...

Last edited by DarioP (2021-10-29 10:48:27)

Offline

#11 2021-10-29 11:11:48

seth
Member
Registered: 2012-09-03
Posts: 26,378

Re: GDM black screen after entering credentials

Sorry, missed that (and it was a tempting distinction)

So it's gnome.

I have been waiting more than 10 seconds on other occasions, but when it works, gnome-shell comes up in a fraction of a second, so I saw no point in collecting logs after that time.

Have you ever been waiting for minutes?
If there's an issue w/ the dbus, it only times out after 25 seconds and there might be an entire chain of failing bus accesses.
Waiting for 1 or 2 minutes on the failing session should then hopefully spit some timout errors into the journal…

Offline

#12 2021-11-05 07:07:50

DarioP
Member
From: Geneva
Registered: 2011-01-05
Posts: 165

Re: GDM black screen after entering credentials

Here is the news: I tried to create a new user, and with that I could login straight from the boot.

I believe some local config files went bad. I have never put my hands in those, but who knows...
I will probably delete all of my local gnome folders and see how it goes.

Offline

Board footer

Powered by FluxBB