You are not logged in.

#1 2021-11-06 19:00:26

matteodev
Member
From: Austria
Registered: 2021-08-17
Posts: 17
Website

[SOLVED] Replace AUR packages with pacman packages?

I wanted to try out mesa-git, then I wanted to reinstall the normal mesa from pacman again but I got a dependency error:

checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing mesa-git breaks dependency 'mesa' required by gst-plugins-base-libs
:: removing mesa-git breaks dependency 'mesa' required by gtk3
:: removing mesa-git breaks dependency 'mesa-git' required by lib32-mesa-git
:: removing mesa-git breaks dependency 'mesa' required by libglvnd
:: removing mesa-git breaks dependency 'opengl-driver' required by libglvnd
:: removing mesa-git breaks dependency 'mesa' required by minecraft-launcher
:: removing mesa-git breaks dependency 'mesa' required by qemu
:: removing mesa-git breaks dependency 'mesa' required by qt5-base
:: removing mesa-git breaks dependency 'mesa' required by retroarch-git
:: removing mesa-git breaks dependency 'vulkan-driver' required by steam
:: removing mesa-git breaks dependency 'mesa' required by virglrenderer
:: removing mesa-git breaks dependency 'mesa' required by xf86-video-amdgpu

Last edited by matteodev (2021-11-07 06:36:53)

Offline

#2 2021-11-06 19:25:27

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,872

Re: [SOLVED] Replace AUR packages with pacman packages?

Post the exact command you are running and the full output

Offline

#3 2021-11-06 19:58:24

matteodev
Member
From: Austria
Registered: 2021-08-17
Posts: 17
Website

Re: [SOLVED] Replace AUR packages with pacman packages?

arojas wrote:

Post the exact command you are running and the full output

Here

matteo@aorbox /home/matteo                                                                                    
⚡ LC_ALL=C sudo pacman -R mesa-git lib32-mesa-git
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing mesa-git breaks dependency 'mesa' required by gst-plugins-base-libs
:: removing mesa-git breaks dependency 'mesa' required by gtk3
:: removing lib32-mesa-git breaks dependency 'lib32-mesa' required by lib32-gtk3
:: removing lib32-mesa-git breaks dependency 'lib32-mesa' required by lib32-libglvnd
:: removing lib32-mesa-git breaks dependency 'lib32-opengl-driver' required by lib32-libglvnd
:: removing mesa-git breaks dependency 'mesa' required by libglvnd
:: removing mesa-git breaks dependency 'opengl-driver' required by libglvnd
:: removing mesa-git breaks dependency 'mesa' required by minecraft-launcher
:: removing mesa-git breaks dependency 'mesa' required by qemu
:: removing mesa-git breaks dependency 'mesa' required by qt5-base
:: removing mesa-git breaks dependency 'mesa' required by retroarch-git
:: removing mesa-git breaks dependency 'vulkan-driver' required by steam
:: removing lib32-mesa-git breaks dependency 'lib32-vulkan-driver' required by steam
:: removing mesa-git breaks dependency 'mesa' required by virglrenderer
:: removing mesa-git breaks dependency 'mesa' required by xf86-video-amdgpu

matteo@aorbox /home/matteo                                                                                    
⚡ 

I want to use mesa and lib32-mesa

Offline

#4 2021-11-06 20:00:58

Raynman
Member
Registered: 2011-10-22
Posts: 1,337

Re: [SOLVED] Replace AUR packages with pacman packages?

You said you wanted to reinstall mesa, but that command is for removing mesa-git. Try actually (re)installing mesa. You should have done it the same way when going from mesa to mesa-git.

Offline

#5 2021-11-06 20:02:41

matteodev
Member
From: Austria
Registered: 2021-08-17
Posts: 17
Website

Re: [SOLVED] Replace AUR packages with pacman packages?

Raynman wrote:

You said you wanted to reinstall mesa, but that command is for removing mesa-git. Try actually (re)installing mesa. You should have done it the same way when going from mesa to mesa-git.

I used yay -S mesa-git lib32-mesa-git

I already tried yay -S mesa lib32-mesa and got this error:

matteo@aorbox /home/matteo                                                                                    
⚡ LC_ALL=C yay -S mesa lib32-mesa
resolving dependencies...
looking for conflicting packages...
:: mesa and mesa-git are in conflict (mesa-libgl). Remove mesa-git? [y/N] y
:: lib32-mesa and lib32-mesa-git are in conflict. Remove lib32-mesa-git? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing mesa-git breaks dependency 'vulkan-driver' required by steam
:: removing lib32-mesa-git breaks dependency 'lib32-vulkan-driver' required by steam
 -> error installing repo packages

matteo@aorbox /home/matteo                                                                                    
⚡ 

Offline

#6 2021-11-06 20:10:37

Raynman
Member
Registered: 2011-10-22
Posts: 1,337

Re: [SOLVED] Replace AUR packages with pacman packages?

Well, yay would still call pacman for the installation; the point is you didn't remove mesa separately and then install mesa-git, but you replaced mesa and lib32-mesa with a single command (one transaction) so there's no intermediate state with broken dependencies.

pacman says steam needs a vulkan-driver and apparently mesa-git provides one and mesa does not. So you pick one (maybe the same you had before mesa-git?) and include that in the transaction as well.

Offline

#7 2021-11-06 20:14:49

matteodev
Member
From: Austria
Registered: 2021-08-17
Posts: 17
Website

Re: [SOLVED] Replace AUR packages with pacman packages?

Raynman wrote:

Well, yay would still call pacman for the installation; the point is you didn't remove mesa separately and then install mesa-git, but you replaced mesa and lib32-mesa with a single command (one transaction) so there's no intermediate state with broken dependencies.

pacman says steam needs a vulkan-driver and apparently mesa-git provides one and mesa does not. So you pick one (maybe the same you had before mesa-git?) and include that in the transaction as well.

If I try to reinstall vulkan-driver, mesa-git already provides one but pacman wants to remove mesa-git which results at the big dependencies list again

Offline

#8 2021-11-06 20:20:27

Raynman
Member
Registered: 2011-10-22
Posts: 1,337

Re: [SOLVED] Replace AUR packages with pacman packages?

Again command/output missing, but it seems you're still not getting the point about doing things in one transaction?

Offline

#9 2021-11-06 20:31:16

matteodev
Member
From: Austria
Registered: 2021-08-17
Posts: 17
Website

Re: [SOLVED] Replace AUR packages with pacman packages?

Raynman wrote:

Again command/output missing, but it seems you're still not getting the point about doing things in one transaction?

Offline

#10 2021-11-06 20:32:52

matteodev
Member
From: Austria
Registered: 2021-08-17
Posts: 17
Website

Re: [SOLVED] Replace AUR packages with pacman packages?

matteodev wrote:
Raynman wrote:

Again command/output missing, but it seems you're still not getting the point about doing things in one transaction?

matteo@aorbox /home/matteo                                                                                                                                      
⚡ LC_ALL=C yay -S vulkan-driver
:: There are 8 providers available for vulkan-driver:
:: Repository testing
   1) vulkan-intel  2) vulkan-radeon  3) vulkan-swrast
:: Repository extra
   4) amdvlk  5) nvidia-utils  6) vulkan-intel  7) vulkan-radeon  8) vulkan-swrast

Enter a number (default=1): 2
resolving dependencies...
looking for conflicting packages...
:: vulkan-radeon and mesa-git are in conflict. Remove mesa-git? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing mesa-git breaks dependency 'mesa' required by gst-plugins-base-libs
:: removing mesa-git breaks dependency 'mesa' required by gtk3
:: removing mesa-git breaks dependency 'mesa-git' required by lib32-mesa-git
:: removing mesa-git breaks dependency 'mesa' required by libglvnd
:: removing mesa-git breaks dependency 'opengl-driver' required by libglvnd
:: removing mesa-git breaks dependency 'mesa' required by minecraft-launcher
:: removing mesa-git breaks dependency 'mesa' required by qemu
:: removing mesa-git breaks dependency 'mesa' required by qt5-base
:: removing mesa-git breaks dependency 'mesa' required by retroarch-git
:: removing mesa-git breaks dependency 'mesa' required by virglrenderer
:: removing mesa-git breaks dependency 'mesa' required by xf86-video-amdgpu
 -> error installing repo packages

matteo@aorbox /home/matteo                                                                                                                                      
⚡

Last edited by matteodev (2021-11-06 20:33:15)

Offline

#11 2021-11-06 20:36:25

progandy
Member
Registered: 2012-05-17
Posts: 4,634

Re: [SOLVED] Replace AUR packages with pacman packages?

Doing everything in a single transaction means installing all packages you want (mesa...,  vulkan...) at the same time in the same pacman command.

Last edited by progandy (2021-11-06 20:37:44)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#12 2021-11-06 20:37:39

matteodev
Member
From: Austria
Registered: 2021-08-17
Posts: 17
Website

Re: [SOLVED] Replace AUR packages with pacman packages?

progandy wrote:

Doing everything in a single transaction means installing all packages (mesa...,  vulkan...) at the same time in the same pacman command.

Thanks, so do I need to install mesa while removing mesa-git?

Offline

#13 2021-11-06 20:39:11

progandy
Member
Registered: 2012-05-17
Posts: 4,634

Re: [SOLVED] Replace AUR packages with pacman packages?

Basically yes, but you only tell pacman to install the new packages. Installing mesa will conflict with mesa-git. Then pacman will ask if you want to remove mesa-git. Confirm that.


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#14 2021-11-06 20:40:57

matteodev
Member
From: Austria
Registered: 2021-08-17
Posts: 17
Website

Re: [SOLVED] Replace AUR packages with pacman packages?

progandy wrote:

Basically yes, but you only tell pacman to install the new packages. Installing mesa will conflict with mesa-git. Then pacman will ask if you want to remove mesa-git. Confirm that.

Is that mentioned in the wiki? I never did that

Offline

#15 2021-11-06 22:36:03

dogknowsnx
Member
Registered: 2021-04-12
Posts: 74

Re: [SOLVED] Replace AUR packages with pacman packages?

Offline

#16 2021-11-07 00:50:36

Sinistar
Member
Registered: 2021-01-02
Posts: 11

Re: [SOLVED] Replace AUR packages with pacman packages?

Seeing xf86-video-amdgpu in your first post, I am assuming you are using and AMD Radeon GPU. Installing the following should work for you. If you are using an LLVM git, you will need to downgrade that at the same time.

   vulkan-mesa-layers
   opencl-mesa  (probably don't need)
   vulkan-radeon
   libva-mesa-driver
   mesa
   lib32-vulkan-mesa-layers
   lib32-opencl-mesa  (probably don't need)
   lib32-vulkan-radeon
   lib32-libva-mesa-driver
   lib32-mesa

Offline

#17 2021-11-07 06:36:38

matteodev
Member
From: Austria
Registered: 2021-08-17
Posts: 17
Website

Re: [SOLVED] Replace AUR packages with pacman packages?

Sinistar wrote:

Seeing xf86-video-amdgpu in your first post, I am assuming you are using and AMD Radeon GPU. Installing the following should work for you. If you are using an LLVM git, you will need to downgrade that at the same time.

   vulkan-mesa-layers
   opencl-mesa  (probably don't need)
   vulkan-radeon
   libva-mesa-driver
   mesa
   lib32-vulkan-mesa-layers
   lib32-opencl-mesa  (probably don't need)
   lib32-vulkan-radeon
   lib32-libva-mesa-driver
   lib32-mesa


It worked! Thanks!

Offline

Board footer

Powered by FluxBB