You are not logged in.

#1 2004-03-25 13:31:36

trey
Member
From: Alpharetta, GA
Registered: 2003-10-18
Posts: 73

Guarddog

The guarddog firewall program would be great to have as a pacman package.

Offline

#2 2004-03-25 14:03:59

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,752

Re: Guarddog

What about snort.....


Mr Green

Offline

#3 2004-03-25 15:14:51

trey
Member
From: Alpharetta, GA
Registered: 2003-10-18
Posts: 73

Re: Guarddog

Snort, as I understand it, is more for network intrusion detection whereas guarddog is a GUI frontend for IP tables.

Alas, it appears a lot of these (including firestarter which IS in the repositories) have very spotty or non-existant support for the 2.6 kernels.

sad  sad  sad

Offline

#4 2004-03-25 15:19:07

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,752

Re: Guarddog

looking at Guarddog it has 2.6 support...


Mr Green

Offline

#5 2004-03-25 16:24:32

trey
Member
From: Alpharetta, GA
Registered: 2003-10-18
Posts: 73

Re: Guarddog

Yes, it appears that this is kind of 'newish' so it should work.  I've put a bug in the bugtracker that the version in the repository needs to be updated to support 2.6.

Offline

#6 2004-03-25 19:44:53

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Guarddog

What's diffirent about 2.6 firewall stuff?  I use fwbuilder with no problems on 2.6.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#7 2004-03-25 23:21:07

trey
Member
From: Alpharetta, GA
Registered: 2003-10-18
Posts: 73

Re: Guarddog

Not sure specifically, but this is the error I get on trying to install firestarter:

[root@salamander trey]# pacman -S firestarter
:: firestarter conflicts with kernel26. Remove kernel26? [Y/n] 

So *some* type of changes have occured between 2.4 and 2.6 that it's having an issue with.

I'll try fwbuilder.

Offline

#8 2004-03-26 10:25:25

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,752

Re: Guarddog

Hi,

Guarddog runs on mine....seems Ok...easy to set up.....got to be with me using it  lol

Mr Green


Mr Green

Offline

#9 2004-03-26 16:07:31

mico
Member
From: Slovenia
Registered: 2004-02-08
Posts: 239

Re: Guarddog

How did you install it? I made a package with makepkg and it doesn't work: when I run guarddog this notice pops up:

An error occured while reading the protocol database.
Details: "Unable to open the network protocol database XML file."

in console:

bash-2.05b$ guarddog
QFile::open: No file name specified

my PKGBUILD:

pkgname=guarddog
pkgver=2.2.0
pkgrel=1
pkgdesc="A firewall configuration utility"
url="http://www.simonzone.com/software/guarddog/"
depends=('kdelibs')
source=(http://www.simonzone.com/software/$pkgname/$pkgname-$pkgver.tar.gz)
md5sums=('9272553b075fedb851e385d40e9602db')

build() {
  cd $startdir/src/$pkgname-$pkgver
  ./configure --prefix=/usr
  make || return 1
  make DESTDIR=$startdir/pkg install
}

namcap output:

bash-2.05b$ namcap guarddog-2.2.0-1.pkg.tar.gz
guarddog   W: Library /usr/lib/libGLcore.so.1 has no package associated

Offline

#10 2004-03-26 16:14:59

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,752

Re: Guarddog

Downloaded tar.....unpacked read install doc ...followed that then at $ guarddog..


Did you pacman -A <package>?


Mr Green


Mr Green

Offline

#11 2004-03-26 17:33:20

mico
Member
From: Slovenia
Registered: 2004-02-08
Posts: 239

Re: Guarddog

Thanks, I got it now. Looks like it works, at least with kernel 2.4, though I didn't test the firewall yet. I also didn't find any info about 2.6 kernels, I just read it is strongly recommended to use 2.4 kernel and iptables, but that section was about 2.2 vs 2.4, the 2.6 is not even mentioned.

PKGBUILD:

# Contributor: Mitja Vardjan <mvardjan@volja.net>

pkgname=guarddog
pkgver=2.2.0
pkgrel=1
pkgdesc="A firewall configuration utility"
url="http://www.simonzone.com/software/guarddog/"
depends=('kdelibs' 'iptables' 'gawk')
source=(http://www.simonzone.com/software/$pkgname/$pkgname-$pkgver.tar.gz)
md5sums=('9272553b075fedb851e385d40e9602db')

build() {
  cd $startdir/src/$pkgname-$pkgver
  ./configure --prefix=`kde-config --prefix`
  make || return 1
  make prefix=$startdir/pkg/`kde-config --prefix` install
}

EDIT: 'gawk' dependency added

Offline

#12 2004-03-26 17:42:16

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,752

Re: Guarddog

Well that looks good.....I am running 2.6.3 so I guess we will just have to see....

Mr Green  tongue


Mr Green

Offline

#13 2004-03-26 23:25:03

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Guarddog

trey wrote:

Not sure specifically, but this is the error I get on trying to install firestarter:

[root@salamander trey]# pacman -S firestarter
:: firestarter conflicts with kernel26. Remove kernel26? [Y/n] 

So *some* type of changes have occured between 2.4 and 2.6 that it's having an issue with.

I'll try fwbuilder.

I'd say that's a bug in the package and should probably be submitted as such.  There's no problem with 2.6 and iptables.  Not only that, but just because someone has the 2.6 kernel installed doesn't mean they're running it.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

Board footer

Powered by FluxBB