You are not logged in.

#1 2021-11-08 00:29:51

Mischa85
Member
Registered: 2020-12-06
Posts: 11

[SOLVED] Chromium depends on several outdated libraries

The chromium package in the official Arch repo depends on several outdated libraries. Some of these have been replaced in the official repo months ago, but new versions of Chromium are still being build against them.

libvpx-1.10.0 -> libvpx.so.6
codec2-1:0.9.2 -> libcodec2.so.0.9
x264-3:0.161 -> libx264.so.161
mbedtls-2.25.0 -> libmbedcrypto.so.6

Last edited by Mischa85 (2021-11-08 02:21:06)

Offline

#2 2021-11-08 00:45:27

loqs
Member
Registered: 2014-03-06
Posts: 14,282

Re: [SOLVED] Chromium depends on several outdated libraries

What commands are you using to produce those results?  What versions of those packages are installed on your system?
Edit:
From chromium-95.0.4638.69-2-x86_64.pkg.tar.zst .BUILDINFO

...
installed = x264-3:0.163.r3060.5db6aa6-1-x86_64
...
installed = libvpx-1.11.0-1-x86_64
...

No codec2 or mbedtls listed.  Meaning those packages were not installed in the build environment.

Last edited by loqs (2021-11-08 00:52:43)

Offline

#3 2021-11-08 02:07:02

Mischa85
Member
Registered: 2020-12-06
Posts: 11

Re: [SOLVED] Chromium depends on several outdated libraries

[marcel@knaagbeest /]$ pacman -Q chromium
chromium 95.0.4638.69-2

Chromium complains about missing these after a system update:

[marcel@knaagbeest /]$ chromium 
/usr/lib/chromium/chromium: error while loading shared libraries: libvpx.so.6: cannot open shared object file: No such file or directory
[marcel@knaagbeest /]$ chromium 
/usr/lib/chromium/chromium: error while loading shared libraries: libcodec2.so.0.9: cannot open shared object file: No such file or directory
[marcel@knaagbeest /]$ chromium 
/usr/lib/chromium/chromium: error while loading shared libraries: libx264.so.161: cannot open shared object file: No such file or directory
[marcel@knaagbeest /]$ chromium 
/usr/lib/chromium/chromium: error while loading shared libraries: libmbedcrypto.so.6: cannot open shared object file: No such file or directory

ldd confirms package depends on them:

[marcel@knaagbeest /]$ ldd /usr/lib/chromium/chromium | grep libvpx
	libvpx.so.6 => /usr/lib/libvpx.so.6 (0x00007fc9e8dc5000)
[marcel@knaagbeest /]$ ldd /usr/lib/chromium/chromium | grep libcodec2
	libcodec2.so.0.9 => /usr/lib/libcodec2.so.0.9 (0x00007ff134495000)
[marcel@knaagbeest /]$ ldd /usr/lib/chromium/chromium | grep libx264
	libx264.so.161 => /usr/lib/libx264.so.161 (0x00007f03ea352000)
[marcel@knaagbeest /]$ ldd /usr/lib/chromium/chromium | grep libmbedcrypto
	libmbedcrypto.so.6 => /usr/lib/libmbedcrypto.so.6 (0x00007f2501350000)

Offline

#4 2021-11-08 02:10:32

loqs
Member
Registered: 2014-03-06
Posts: 14,282

Re: [SOLVED] Chromium depends on several outdated libraries

Please post the output of the following which requires pax-utils

lddtree /usr/lib/chromium/chromium

Offline

#5 2021-11-08 02:20:26

Mischa85
Member
Registered: 2020-12-06
Posts: 11

Re: [SOLVED] Chromium depends on several outdated libraries

loqs wrote:

Please post the output of the following which requires pax-utils

lddtree /usr/lib/chromium/chromium

Derp. That made things clear.

Chromium depends on libavcodec.so.58, which is part of ffmpeg. I had ffmpeg-full installed from AUR which was build against the outdated libs. I was looking in the wrong direction.

Thank you for pointing me in the right direction.

TL;DR user error.

Offline

Board footer

Powered by FluxBB