You are not logged in.

#1 2021-11-13 10:23:41

sebastian-65
Member
Registered: 2021-11-08
Posts: 14

Waiting for device on boot (LVM on LUKS, systemd-boot, mkinitcpio)

I'm getting emergency mode on boot with error. What might be wrong?

Timed out waiting for device /dev/pool/root.
Dependency failed fo File System Check on /dev/pool/root.
  • UEFI

  • LVM on LUKS

  • ext4

  • systemd-boot

  • mkinitcpio

  • fresh Arch install (new laptop Asus Vivobook), Intel


--------------------------------------------------------------------------------------------------

/boot/loader/entries/arch.conf

title	Arch Linux
linux	/vmlinuz-linux
initrd	/intel-ucode.img
initrd	/initramfs-linux.img
options rd.luks.name=80910763-5993-4816-9a04-f7e0f3b49880=luks root=/dev/pool/root resume=/dev/pool/swap rd.luks.options=discard mem_sleep_default=deep quiet splash rw

/etc/mkinitcpio.conf

MODULES=(vfat ext4)
HOOKS=(base systemd autodetect keyboard sd-vconsole modconf block sd-encrypt lvm2 filesystems fsck)

blkid

/dev/nvme0n1p1: UUID="879D-B00B" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="cb3ab5a8-b343-4f48-b206-4d1c6e6af3cb"
/dev/nvme0n1p2: UUID="80910763-5993-4816-9a04-f7e0f3b49880" TYPE="crypto_LUKS" PARTLABEL="primary" PARTUUID="68285656-9183-43b2-afa2-93e74d8de5c7"
/dev/mapper/luks: UUID="XMHCol-Gjb8-IdRD-xzil-1ESw-98hr-WOxSaR" TYPE="LVM2_member"
/dev/mapper/pool-swap: UUID="0473030f-9118-45c6-8e24-0f1334bdaa12" TYPE="swap"
/dev/mapper/pool-root: UUID="731f8d30-94a9-46ff-b15c-b12e8ed7886f" BLOCK_SIZE="4096" TYPE="ext4"
/dev/mapper/pool-home: UUID="6de6114d-11f9-42d2-8c6b-83ea7c55d471" BLOCK_SIZE="4096" TYPE="ext4"
/dev/mapper/pool-warehouse: UUID="76cb98be-5729-4ad7-84e2-53c34b1e269a" BLOCK_SIZE="4096" TYPE="ext4"
/dev/mapper/pool-data: UUID="f272a852-8724-46dc-a686-ab1111400315" BLOCK_SIZE="4096" TYPE="ext4"

fstab

# /dev/mapper/pool-root
UUID=731f8d30-94a9-46ff-b15c-b12e8ed7886f	/         	ext4      	rw,relatime	0 1

# /dev/mapper/pool-swap
UUID=0473030f-9118-45c6-8e24-0f1334bdaa12	none      	swap      	defaults  	0 0

# /dev/nvme0n1p1
UUID=879D-B00B      	/boot     	vfat      	rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro	0 2

lvscan

  ACTIVE            '/dev/pool/swap' [2.00 GiB] inherit
  ACTIVE            '/dev/pool/root' [30.00 GiB] inherit
  ACTIVE            '/dev/pool/home' [100.00 GiB] inherit
  ACTIVE            '/dev/pool/warehouse' [200.00 GiB] inherit
  ACTIVE            '/dev/pool/data' [<621.56 GiB] inherit

pvscan

  PV /dev/mapper/luks   VG pool            lvm2 [<953.56 GiB / 0    free]

vgscan

Found volume group "pool" using metadata type lvm2

Last edited by sebastian-65 (2021-11-16 14:21:22)

Offline

#2 2021-11-13 12:19:40

frostschutz
Member
Registered: 2013-11-15
Posts: 1,089

Re: Waiting for device on boot (LVM on LUKS, systemd-boot, mkinitcpio)

You are using sd-encrypt hook, but cryptdevice= parameter only works for regular non-systemd encrypt hook. See mkinitcpio -H encrypt vs. sd-encrypt

Other than that I recommend using UUID for LUKS and filesystem instead of PARTUUID / filepaths.

Last edited by frostschutz (2021-11-13 12:19:57)

Offline

#3 2021-11-14 18:25:05

sebastian-65
Member
Registered: 2021-11-08
Posts: 14

Re: Waiting for device on boot (LVM on LUKS, systemd-boot, mkinitcpio)

I have updated mkinitcpio.conf and bootloader entry (arch.conf) accordingly to sd-hooks fashion (see updated files). I still do end in emergency mode with blank screen first, after a minute or so it shows the same error "Timed out waiting for device /dev/pool/root". What could be wrong? Does that "cryptlvm" name has to match anything? It shouldn't, right?

Offline

#4 2021-11-15 00:38:03

jonno2002
Member
Registered: 2016-11-21
Posts: 222

Re: Waiting for device on boot (LVM on LUKS, systemd-boot, mkinitcpio)

try changing "sd-lvm2" to "lvm2" in your mkinitcpio.conf

Offline

#5 2021-11-15 10:12:16

sebastian-65
Member
Registered: 2021-11-08
Posts: 14

Re: Waiting for device on boot (LVM on LUKS, systemd-boot, mkinitcpio)

I replaced sd-lvm2 to lvm2 when mkinitcpio output told me that this module is deprecated. I ran "mkinitcpio -P" afterwards successfully. Same result, though.

Offline

#6 2021-11-15 10:28:45

frostschutz
Member
Registered: 2013-11-15
Posts: 1,089

Re: Waiting for device on boot (LVM on LUKS, systemd-boot, mkinitcpio)

wrong uuid (lvm instead of luks)

Offline

#7 2021-11-15 15:12:44

cloverskull
Member
Registered: 2018-09-30
Posts: 81

Re: Waiting for device on boot (LVM on LUKS, systemd-boot, mkinitcpio)

The UUID you need to use in your bootloader is the UUID of /dev/nvme0n1p2

Offline

#8 2021-11-15 17:41:01

sebastian-65
Member
Registered: 2021-11-08
Posts: 14

Re: Waiting for device on boot (LVM on LUKS, systemd-boot, mkinitcpio)

I did change UUID, but it surprisingly didn't help either. Black screen at first (no output), after 2-3 minutes emergency mode shows up (timed out waiting for device /dev/pool/root).

Offline

#9 2021-11-15 20:33:01

cloverskull
Member
Registered: 2018-09-30
Posts: 81

Re: Waiting for device on boot (LVM on LUKS, systemd-boot, mkinitcpio)

Try changing from /dev/pool/root and /dev/pool/swap to /dev/mapper/pool-root and /dev/mapper/pool-swap.

Another thing you may want to try would be to install grub. Hear me out. Grub can be installed and later removed, /but/ if you install grub and it "just works", you can probably look at grub's configuration and suss out what's gone wrong with the way you have things configured with systemd-boot.

Offline

#10 2021-11-15 20:45:08

sebastian-65
Member
Registered: 2021-11-08
Posts: 14

Re: Waiting for device on boot (LVM on LUKS, systemd-boot, mkinitcpio)

Still no luck. I've already tried rEFInd before systemd-boot, but I might try installing grub and hopefully see what's going on. Thank you for your advice, guys.

Offline

#11 2021-11-15 21:41:49

cloverskull
Member
Registered: 2018-09-30
Posts: 81

Re: Waiting for device on boot (LVM on LUKS, systemd-boot, mkinitcpio)

Here's my working config:

/boot/loader/entries/arch.conf

title   Arch Linux
linux   /vmlinuz-linux
initrd  /intel-ucode.img
initrd  /initramfs-linux.img
options rd.luks.name=5057546b-2bd2-4ee9-a840-ae7d888a9f22=cryptlvm root=/dev/MyVolGroup/root resume=/dev/MyVolGroup/swap sysrq_always_enabled=1 ro quiet splash vt.global_cursor_default=0 loglevel=3 rd.udev.log_level=3 rd.systemd.show_status=auto fbcon=nodefer nowatchdog nmi_watchdog=0 random.trust_cpu=on lsm=landlock,lockdown,yama,apparmor,bpf audit=1 audit_backlog_limit=8192 transparent_hugepage=never

/etc/mkinitcpio.conf

MODULES=(i915 vfat ext4 vmw_pvscsi vmxnet3)
BINARIES=()
FILES=()
HOOKS=(base systemd sd-plymouth autodetect keyboard modconf block sd-encrypt lvm2)
COMPRESSION="zstd"
COMPRESSION_OPTIONS=(-9)

blkid

/dev/mapper/MyVolGroup-swap: UUID="d8b4d39c-0e36-4bb9-9649-f78a6681c84d" TYPE="swap"
/dev/nvme0n1p1: UUID="7E95-8EB1" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="b981d90c-cde2-4769-94e7-71baf627c257"
/dev/nvme0n1p2: UUID="5057546b-2bd2-4ee9-a840-ae7d888a9f22" TYPE="crypto_LUKS" PARTLABEL="Linux filesystem" PARTUUID="e62fae66-fe03-419d-8ea3-d1bd12074c9c"
/dev/mapper/MyVolGroup-root: UUID="ce3537a4-1540-4f4b-9f96-5c5237497e38" BLOCK_SIZE="4096" TYPE="ext4"
/dev/loop0: TYPE="squashfs"
/dev/mapper/cryptlvm: UUID="GI2pmV-cjiF-FEcU-GTYm-NY3y-1i23-42esZA" TYPE="LVM2_member"

fstab

UUID=ce3537a4-1540-4f4b-9f96-5c5237497e38       /               ext4            rw,noatime,errors=remount-ro    0 1
UUID=7E95-8EB1          /boot           vfat            rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro   0 2
UUID=d8b4d39c-0e36-4bb9-9649-f78a6681c84d       none            swap            defaults        0 0

lvscan

  ACTIVE            '/dev/MyVolGroup/swap' [32.00 GiB] inherit
  ACTIVE            '/dev/MyVolGroup/root' [<1.79 TiB] inherit

pvscan

  PV /dev/mapper/cryptlvm   VG MyVolGroup      lvm2 [<1.82 TiB / 0    free]
  Total: 1 [<1.82 TiB] / in use: 1 [<1.82 TiB] / in no VG: 0 [0   ]

vgscan

  Found volume group "MyVolGroup" using metadata type lvm2

Offline

#12 2021-11-15 21:43:28

cloverskull
Member
Registered: 2018-09-30
Posts: 81

Re: Waiting for device on boot (LVM on LUKS, systemd-boot, mkinitcpio)

A-ha, I think you need to change from cryptlvm to luks (your actual label):

rd.luks.name=80910763-5993-4816-9a04-f7e0f3b49880=cryptlvm

to

rd.luks.name=80910763-5993-4816-9a04-f7e0f3b49880=luks

Offline

#13 2021-11-15 21:52:47

frostschutz
Member
Registered: 2013-11-15
Posts: 1,089

Re: Waiting for device on boot (LVM on LUKS, systemd-boot, mkinitcpio)

otherwise in the emergency shell, check

cat /proc/cmdline # parameters as expected?
cat /proc/partitions # devices as expected?
ls -l /dev/disk/by-uuid # uuid as expected?

Offline

#14 2021-11-16 09:24:27

sebastian-65
Member
Registered: 2021-11-08
Posts: 14

Re: Waiting for device on boot (LVM on LUKS, systemd-boot, mkinitcpio)

"luks" label fixed. Same situation, still.

When in emergency mode, interestingly enough, system won't let me get into the shell.  It still tries to periodically load configuration.

Last edited by sebastian-65 (2021-11-16 09:25:43)

Offline

#15 2021-11-17 16:15:40

sebastian-65
Member
Registered: 2021-11-08
Posts: 14

Re: Waiting for device on boot (LVM on LUKS, systemd-boot, mkinitcpio)

I've decided to go for ZFS filesystem afterall, which might be a better choice anyway, hopefully to avoid this thing. Thank you guys again for your advices.

How can I close this thread?

Offline

Board footer

Powered by FluxBB