You are not logged in.

#1 2021-11-12 04:09:01

Megarock90
Member
Registered: 2012-01-18
Posts: 22

Retroarch issues on vulkan under wayland but only on dedicated AMD GPU

So here's the deal.
Decided to give Wayland a new chance a couple days ago and is.... surprisingly good this time around (at least in Plasma)
Everything so far works EXCEPT for the thing on the subject. But here's the thing, if I were to run it on the integrated vega of the APU it would render and run properly (slow for anything above PS1 with almost no effects, but properly). If I want to run it on the RX560M I get greeted by this:
https://files.catbox.moe/dc6paw.png
Laptop is an ASUS FX505DY (Ryzen 3550H + radeon RX560M) so drivers shouldn't be an issue, right?
So I'm at a loss, any input appreciated

edit:
Don't see anything worthy on the verbose output either.

retroarch -v
[INFO] [Config]: Loading default config.
[INFO] [Config]: Looking for config in: "/home/me/.config/retroarch/retroarch.cfg".
[INFO] RetroArch 1.9.13 (Git 1280151d13)
[INFO] === Build =======================================
[INFO] CPU Model Name: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx  
[INFO] Capabilities:  MMX MMXEXT SSE SSE2 SSE3 SSSE3 SSE4 SSE4.2 AES AVX AVX2
[INFO] Built: Nov 11 2021
[INFO] Version: 1.9.13
[INFO] Git: 1280151d13
[INFO] =================================================
[INFO] [Input]: Found input driver: "x".
[INFO] [Environ]: SET_PIXEL_FORMAT: RGB565.
[INFO] Version of libretro API: 1
[INFO] Compiled against API: 1
[INFO] [Audio]: Set audio input rate to: 48000.00 Hz.
[INFO] [Video]: Video @ fullscreen
[INFO] [Video]: Starting threaded video driver ...
[INFO] [Vulkan]: Vulkan dynamic library loaded.
[INFO] [Vulkan]: Found vulkan context: vk_wayland
[INFO] [Vulkan]: Detecting screen resolution 0x0.
[INFO] [Vulkan]: Found GPU at index 0: AMD RADV RAVEN
[INFO] [Vulkan]: Found GPU at index 1: AMD RADV POLARIS11
[INFO] [Vulkan]: Using GPU index 1.
[INFO] [Vulkan]: Using fences for WSI acquire.
[INFO] [Vulkan]: Using GPU: AMD RADV POLARIS11
[INFO] [Vulkan]: Queue family 0 supports 1 sub-queues.
[INFO] [Vulkan]: Using resolution 1920x1080
[INFO] [Vulkan]: Using RGB565 format.
[INFO] [Vulkan]: Loading stock shader.
[INFO] [Joypad]: Found joypad driver: "udev".
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [Video]: Found display server: null
[INFO] [PulseAudio]: Requested 24576 bytes buffer, got 18432.
[INFO] [Display]: Found display driver: "vulkan".
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [Font]: Using font rendering backend: freetype.
[WARN] [XMB] Asset missing: /usr/share/retroarch/assets/xmb/systematic/png/disc.png
[INFO] [SRAM]: SRAM will not be saved.
[INFO] [Playlist]: Loading history file: [/home/me/.config/retroarch/content_history.lpl].
[INFO] [Playlist]: Loading history file: [/home/me/.config/retroarch/content_music_history.lpl].
[INFO] [Playlist]: Loading history file: [/home/me/.config/retroarch/content_video_history.lpl].
[INFO] [Playlist]: Loading history file: [/home/me/.config/retroarch/content_image_history.lpl].
[INFO] [Playlist]: Loading favorites file: [/home/me/.config/retroarch/content_favorites.lpl].
[INFO] [Config]: Saved new config to "/home/me/.config/retroarch/retroarch.cfg".
[INFO] [Core]: Content ran for a total of: 00 hours, 00 minutes, 00 seconds.
[INFO] [PulseAudio]: Pausing.
[INFO] [Core]: Unloading core..
[INFO] [Core]: Unloading core symbols..
[INFO] Threaded video stats: Frames pushed: 3693, Frames dropped: 0.

Mod edit: Turned oversized image to link -- V1del

Last edited by V1del (2021-11-13 12:56:32)

Offline

#2 2021-11-13 12:53:34

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,583

Re: Retroarch issues on vulkan under wayland but only on dedicated AMD GPU

Please post output of

$ ls /usr/share/vulkan/icd.d/
$ vulkaninfo --summary

Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2021-11-13 12:59:31

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,444

Re: Retroarch issues on vulkan under wayland but only on dedicated AMD GPU

Please don't embed huge images directly https://wiki.archlinux.org/title/Genera … s_and_code

AFAIK properly doing this is still quite wonky on most Wayland implementations, potentially the Wayland protocol in general. FWIW as a test, what's the behaviour if you start retroarch with

DRI_PRIME=1 retroarch

Offline

#4 2021-11-14 11:06:48

Megarock90
Member
Registered: 2012-01-18
Posts: 22

Re: Retroarch issues on vulkan under wayland but only on dedicated AMD GPU

Lone_Wolf wrote:

Please post output of

ls /usr/share/vulkan/icd.d/
radeon_icd.i686.json  radeon_icd.x86_64.json
vulkaninfo --summary
==========
VULKANINFO
==========

Vulkan Instance Version: 1.2.194


Instance Extensions: count = 19
-------------------------------
VK_EXT_acquire_drm_display             : extension revision 1
VK_EXT_acquire_xlib_display            : extension revision 1
VK_EXT_debug_report                    : extension revision 10
VK_EXT_debug_utils                     : extension revision 2
VK_EXT_direct_mode_display             : extension revision 1
VK_EXT_display_surface_counter         : extension revision 1
VK_KHR_device_group_creation           : extension revision 1
VK_KHR_display                         : extension revision 23
VK_KHR_external_fence_capabilities     : extension revision 1
VK_KHR_external_memory_capabilities    : extension revision 1
VK_KHR_external_semaphore_capabilities : extension revision 1
VK_KHR_get_display_properties2         : extension revision 1
VK_KHR_get_physical_device_properties2 : extension revision 2
VK_KHR_get_surface_capabilities2       : extension revision 1
VK_KHR_surface                         : extension revision 25
VK_KHR_surface_protected_capabilities  : extension revision 1
VK_KHR_wayland_surface                 : extension revision 6
VK_KHR_xcb_surface                     : extension revision 6
VK_KHR_xlib_surface                    : extension revision 6

Instance Layers: count = 6
--------------------------
VK_LAYER_AEJS_DeviceChooserLayer  Device chooser layer         1.2.131  version 1
VK_LAYER_MANGOHUD_overlay         Vulkan Hud Overlay           1.2.135  version 1
VK_LAYER_VALVE_steam_fossilize_32 Steam Pipeline Caching Layer 1.2.136  version 1
VK_LAYER_VALVE_steam_fossilize_64 Steam Pipeline Caching Layer 1.2.136  version 1
VK_LAYER_VALVE_steam_overlay_32   Steam Overlay Layer          1.2.136  version 1
VK_LAYER_VALVE_steam_overlay_64   Steam Overlay Layer          1.2.136  version 1

Devices:
========
GPU0:
        apiVersion         = 4202678 (1.2.182)
        driverVersion      = 88088581 (0x5402005)
        vendorID           = 0x1002
        deviceID           = 0x15d8
        deviceType         = PHYSICAL_DEVICE_TYPE_INTEGRATED_GPU
        deviceName         = AMD RADV RAVEN
        driverID           = DRIVER_ID_MESA_RADV
        driverName         = radv
        driverInfo         = Mesa 21.2.5
        conformanceVersion = 1.2.3.0
GPU1:
        apiVersion         = 4202678 (1.2.182)
        driverVersion      = 88088581 (0x5402005)
        vendorID           = 0x1002
        deviceID           = 0x67ef
        deviceType         = PHYSICAL_DEVICE_TYPE_DISCRETE_GPU
        deviceName         = AMD RADV POLARIS11
        driverID           = DRIVER_ID_MESA_RADV
        driverName         = radv
        driverInfo         = Mesa 21.2.5
        conformanceVersion = 1.2.3.0

@V1del
Aight, sorry about the pic.
Regarding PRIME, same result, and I mean it's not that it's not using the GPU, checked with radeontop and it turns up when I start retro (should have mentioned this on the OP tho)

Offline

#5 2021-11-14 12:43:51

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,583

Re: Retroarch issues on vulkan under wayland but only on dedicated AMD GPU

Instance Layers: count = 6
--------------------------
VK_LAYER_AEJS_DeviceChooserLayer  Device chooser layer         1.2.131  version 1
VK_LAYER_MANGOHUD_overlay         Vulkan Hud Overlay           1.2.135  version 1
VK_LAYER_VALVE_steam_fossilize_32 Steam Pipeline Caching Layer 1.2.136  version 1
VK_LAYER_VALVE_steam_fossilize_64 Steam Pipeline Caching Layer 1.2.136  version 1
VK_LAYER_VALVE_steam_overlay_32   Steam Overlay Layer          1.2.136  version 1
VK_LAYER_VALVE_steam_overlay_64   Steam Overlay Layer          1.2.136  version 1

Those look weird.
The valve ones are from steam, mangohud is probably from the aur package, but I've never seen VK_LAYER_AEJS_DeviceChooserLayer.
For a system using radv I also expect to see VK_LAYER_MESA_device_select and VK_LAYER_MESA_overlay .

You may have multiple vulkan implementations installed that don't work well together.

post the output of

$ pacman -Qi vulkan-radeon
$ pacman -Qs vulkan

Edit : optional deps for repo mesa re not important for vulkan, optdeps for vulkan-radeon are.

Last edited by Lone_Wolf (2021-11-14 12:55:31)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#6 2021-11-14 13:44:21

Megarock90
Member
Registered: 2012-01-18
Posts: 22

Re: Retroarch issues on vulkan under wayland but only on dedicated AMD GPU

Lone_Wolf wrote:

I've never seen VK_LAYER_AEJS_DeviceChooserLayer.

Most likely this
Is/was a dirty implementation of PRIME for vulkan back when PRIME would have trouble working sometimes.

pacman -Qi vulkan-radeon
Name            : vulkan-radeon
Version         : 21.2.5-1
Description     : Radeon's Vulkan mesa driver
Architecture    : x86_64
URL             : https://www.mesa3d.org/
Licenses        : custom
Groups          : None
Provides        : vulkan-driver
Depends On      : wayland  libx11  libxshmfence  libelf  libdrm  llvm-libs
Optional Deps   : vulkan-mesa-layers: additional vulkan layers
Required By     : steam
Optional For    : vulkan-icd-loader
Conflicts With  : None
Replaces        : None
Installed Size  : 7.50 MiB
Packager        : Laurent Carlier <lordheavym@gmail.com>
Build Date      : Fri 29 Oct 2021 04:05:59 PM JST
Install Date    : Sat 13 Nov 2021 07:05:55 PM JST
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature
pacman -Qs vulkan
local/dxvk-bin 1.9.2-1
    A Vulkan-based compatibility layer for Direct3D 9/10/11 which allows running 3D
    applications on Linux using Wine (Windows DLL binary files)
local/lib32-vkd3d 1.2-2
    Direct3D 12 to Vulkan translation library By WineHQ
local/lib32-vulkan-icd-loader 1.2.194-1
    Vulkan Installable Client Driver (ICD) Loader (32-bit)
local/lib32-vulkan-radeon 21.2.5-1
    Radeon's Vulkan mesa driver (32-bit)
local/mangohud 0.6.6.1-1
    A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more
local/spirv-tools 2021.3-1 (vulkan-devel)
    API and commands for processing SPIR-V modules
local/vkd3d 1.2-1
    Direct3D 12 to Vulkan translation library By WineHQ
local/vulkan-headers 1:1.2.194-1 (vulkan-devel)
    Vulkan header files
local/vulkan-icd-loader 1.2.194-1
    Vulkan Installable Client Driver (ICD) Loader
local/vulkan-mesa-layers 21.2.5-1
    Mesa's Vulkan layers
local/vulkan-radeon 21.2.5-1
    Radeon's Vulkan mesa driver
local/vulkan-tools 1.2.194-1 (vulkan-devel)
    Vulkan Utilities and Tools

Last edited by Megarock90 (2021-11-14 13:48:06)

Offline

#7 2021-11-14 14:00:15

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,583

Re: Retroarch issues on vulkan under wayland but only on dedicated AMD GPU

install vulkan-mesa-layers , then check vulkaninfo summary again .

If it now shows those 2 mesa layers, try running retroarch again .
Incase the issue still persists, remove  aejsmith / vkdevicechooser and try again.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#8 2021-11-14 15:45:29

Megarock90
Member
Registered: 2012-01-18
Posts: 22

Re: Retroarch issues on vulkan under wayland but only on dedicated AMD GPU

Lone_Wolf wrote:

Incase the issue still persists, remove  aejsmith / vkdevicechooser and try again.

Done and done and still same result, garbled output.

Instance Layers: count = 8
--------------------------
VK_LAYER_INTEL_nullhw             INTEL NULL HW                1.1.73   version 1
VK_LAYER_MANGOHUD_overlay         Vulkan Hud Overlay           1.2.135  version 1
VK_LAYER_MESA_device_select       Linux device selection layer 1.2.73   version 1
VK_LAYER_MESA_overlay             Mesa Overlay layer           1.1.73   version 1
VK_LAYER_VALVE_steam_fossilize_32 Steam Pipeline Caching Layer 1.2.136  version 1
VK_LAYER_VALVE_steam_fossilize_64 Steam Pipeline Caching Layer 1.2.136  version 1
VK_LAYER_VALVE_steam_overlay_32   Steam Overlay Layer          1.2.136  version 1
VK_LAYER_VALVE_steam_overlay_64   Steam Overlay Layer          1.2.136  version 1

Last edited by Megarock90 (2021-11-14 15:46:04)

Offline

#9 2021-11-15 10:04:47

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,583

Re: Retroarch issues on vulkan under wayland but only on dedicated AMD GPU

[INFO] RetroArch 1.9.13 (Git 1280151d13)
[INFO] === Build =======================================
[INFO] CPU Model Name: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx  
[INFO] Capabilities:  MMX MMXEXT SSE SSE2 SSE3 SSSE3 SSE4 SSE4.2 AES AVX AVX2
[INFO] Built: Nov 11 2021
[INFO] Version: 1.9.13
[INFO] Git: 1280151d13

current version of retroarch on archlinux uses _tag=fca72f67d19eea58939f0123d2e91a5cec9120ee and has version number 1.9.13.2
Your version of retroarch appears to be older, is your system fully uptodate ?


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#10 2021-11-16 06:54:18

Megarock90
Member
Registered: 2012-01-18
Posts: 22

Re: Retroarch issues on vulkan under wayland but only on dedicated AMD GPU

Lone_Wolf wrote:

Your version of retroarch appears to be older, is your system fully uptodate ?

That was the up to date version at the time, updated it before that last test.

pacman -Qi retroarch
Name            : retroarch
Version         : 1.9.13.2-1
retroarch -v
[INFO] [Config]: Loading default config.
[INFO] [Config]: Looking for config in: "/home/cfsa/.config/retroarch/retroarch.cfg".
[INFO] RetroArch 1.9.13 (Git fca72f67d1)
[INFO] === Build =======================================
[INFO] CPU Model Name: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx  
[INFO] Capabilities:  MMX MMXEXT SSE SSE2 SSE3 SSSE3 SSE4 SSE4.2 AES AVX AVX2
[INFO] Built: Nov 13 2021
[INFO] Version: 1.9.13
[INFO] Git: fca72f67d1

Offline

#11 2021-11-16 10:40:59

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,583

Re: Retroarch issues on vulkan under wayland but only on dedicated AMD GPU

I'm beginning to think this may need help from retroarch devs/comunity to investigate, but there are some things we haven't looked at yet.

Does the issue still occur under X and wayland ?

post full dmesg and journalctl -b (both as root) as well as lspci -k output


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#12 2021-11-17 06:11:17

Megarock90
Member
Registered: 2012-01-18
Posts: 22

Re: Retroarch issues on vulkan under wayland but only on dedicated AMD GPU

It is only on wayland, X was working fine.
dmesg output
journalctl

lspci -k
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Root Complex
        Subsystem: ASUSTeK Computer Inc. Device 17c1
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 IOMMU
        Subsystem: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 IOMMU
00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
00:01.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 PCIe GPP Bridge [6:0]
        Kernel driver in use: pcieport
00:01.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 PCIe GPP Bridge [6:0]
        Kernel driver in use: pcieport
00:01.3 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 PCIe GPP Bridge [6:0]
        Kernel driver in use: pcieport
00:01.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 PCIe GPP Bridge [6:0]
        Kernel driver in use: pcieport
00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Internal PCIe GPP Bridge 0 to Bus A
        Kernel driver in use: pcieport
00:08.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Internal PCIe GPP Bridge 0 to Bus B
        Kernel driver in use: pcieport
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 61)
        Subsystem: ASUSTeK Computer Inc. Device 17c1
        Kernel driver in use: piix4_smbus
        Kernel modules: i2c_piix4, sp5100_tco
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51)
        Subsystem: ASUSTeK Computer Inc. Device 17c1
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 3
        Kernel driver in use: zenpower
        Kernel modules: k10temp, zenpower
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 5
00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 6
00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 7
01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] (rev e5)
        Subsystem: ASUSTeK Computer Inc. Device 17c1
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu
02:00.0 Non-Volatile memory controller: Sandisk Corp WD Blue SN500 / PC SN520 NVMe SSD (rev 01)
        Subsystem: Sandisk Corp WD Blue SN500 / PC SN520 NVMe SSD
        Kernel driver in use: nvme
03:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)
        Subsystem: Intel Corporation Wi-Fi 6 AX200NGW
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
        Subsystem: ASUSTeK Computer Inc. Device 208f
        Kernel driver in use: r8169
        Kernel modules: r8169, r8168
05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Picasso (rev c2)
        Subsystem: ASUSTeK Computer Inc. Device 17c1
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu
05:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller
        Subsystem: ASUSTeK Computer Inc. Device 17c1
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
05:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) Platform Security Processor
        Subsystem: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) Platform Security Processor
        Kernel driver in use: ccp
        Kernel modules: ccp
05:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Raven USB 3.1
        Subsystem: ASUSTeK Computer Inc. Device 201f
        Kernel driver in use: xhci_hcd
        Kernel modules: xhci_pci
05:00.4 USB controller: Advanced Micro Devices, Inc. [AMD] Raven USB 3.1
        Subsystem: ASUSTeK Computer Inc. Device 201f
        Kernel driver in use: xhci_hcd
        Kernel modules: xhci_pci
05:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller
        Subsystem: ASUSTeK Computer Inc. Device 17c1
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
06:00.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 61)
        Subsystem: ASUSTeK Computer Inc. Device 17c1
        Kernel driver in use: ahci

Offline

#13 2021-11-17 07:59:09

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,444

Re: Retroarch issues on vulkan under wayland but only on dedicated AMD GPU

Is this strictly limited to retroarch? can you e.g. play a proton game on steam or so? (though that does give me the idea, can you repro if you run retroarch via xwayland (not entirely 100 on which config to change that it will use X instead of wayland in the first place))

Offline

#14 2021-11-17 12:45:54

Megarock90
Member
Registered: 2012-01-18
Posts: 22

Re: Retroarch issues on vulkan under wayland but only on dedicated AMD GPU

V1del wrote:

Is this strictly limited to retroarch?

So far it is, native and proton games in steam work + windows binaries on regular wine. Google is not showing anything regarding xwayland either.
I'll do what Wolf said and try to get their attention on their github

Offline

#15 2021-11-18 10:49:02

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,583

Re: Retroarch issues on vulkan under wayland but only on dedicated AMD GPU

    0.000000] Command line: initrd=\amd-ucode.img initrd=\initramfs-linux-zen.img root=UUID=8ff9d024-72b1-4c95-b2c7-4b7f81951c1d rw nvme_core.default_ps_max_latency_us=5500 iommu=pt acpi_backlight=vendor radeon.audio=1 quiet udev.log_priority=3

You're using linux-zen , have you tested with other kernels like linux & linux-lts ?

radeon.audio should not be applicable to your system, probably a remnant of previous hardware ?


[    0.259429] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.GPP0.SWUS], AE_NOT_FOUND (20210730/dswload2-162)
[    0.259435] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20210730/psobject-220)
[    0.259437] ACPI: Skipping parse of AML opcode: Scope (0x0010)
[    0.259440] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.GPP0.SWUS.SWDS], AE_NOT_FOUND (20210730/dswload2-162)
[    0.259442] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20210730/psobject-220)
[    0.259444] ACPI: Skipping parse of AML opcode: Scope (0x0010)
<snip>

[    1.166216] ACPI BIOS Error (bug): Attempt to CreateField of length zero (20210730/dsopcode-133)
[    1.166221] ACPI Error: Aborting method \_SB.PCI0.GP17.VGA.ATRM due to previous error (AE_AML_OPERAND_VALUE) (20210730/psparse-529)
[    1.166226] failed to evaluate ATRM got AE_AML_OPERAND_VALUE

No idea whether they matter, but those errors are  related to graphics .

Other then that journal has sddm warnings and steam warnings but nothing else that looks related to the issue.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

Board footer

Powered by FluxBB