You are not logged in.

#76 2021-11-18 10:51:08

dybdeskarphet
Member
Registered: 2021-11-17
Posts: 7

Re: nvidia-390xx AUR package discussion thread

oh :P i didn't know if it was sensitive or not so i just censored it. thanks for the info, i'll try to fix it accordingly.

Offline

#77 2021-11-18 18:47:37

DAC324
Member
Registered: 2020-03-12
Posts: 70

Re: nvidia-390xx AUR package discussion thread

Hello all,

just curious: V1Del recently stated:

nvidia will eventually fix 390xx, they've stated it is supported and receives compat fixes until the end of 2022.

Does anybody already know if there are activities ongoing? Reason for asking: The 390.144 driver even runs with kernel 5.16-RC1 so it would be great if it was possible to continue using it smile

Offline

#78 2021-12-18 15:11:26

jonathon
Member
Registered: 2016-09-19
Posts: 115

Re: nvidia-390xx AUR package discussion thread

I've updated again for 390.147, and included some changes from the nvidia 495xx packaging files.

Please let me know if there are any problems!

Offline

#79 2021-12-19 16:26:03

madox
Member
Registered: 2021-12-19
Posts: 2

Re: nvidia-390xx AUR package discussion thread

jonathon wrote:

I've updated again for 390.147, and included some changes from the nvidia 495xx packaging files.

Please let me know if there are any problems!

Hi Jonathon, thanks for maintaining the package. I encountered a problem updating to version 390.147 yesterday (using yay -Syu). The update fails to install. Output from yay -S nvidia-390xx included the following error:

:: installing nvidia-390xx-utils (390.147-1) breaks dependency 'nvidia-390xx-utils=390.144' required by nvidia-390xx

I'm not an expert user, though I assume this relates to a dependency carried from 390.144, which should not longer apply.

I have tried to log the command output using:

yay -S nvidia-390xx | tee ./log.txt

though the output is not quite equivalent to the standard out in the console. I'm not sure what other logs to provide, for assistance.

:: [1mChecking for conflicts...[0m
:: [1mChecking for inner conflicts...[0m
[Aur:2]  nvidia-390xx-utils-390.147-1 (nvidia-390xx-utils)  nvidia-390xx-390.147-1
[Aur Make:1]  nvidia-390xx-utils-390.147-1 (nvidia-390xx-dkms)

==> Remove make dependencies after install? [y/N]   2 nvidia-390xx-utils (nvidia-390xx-utils nvidia-390xx-dkms) (Installed) (Build Files Exist)
  1 nvidia-390xx                             (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> :: [1mDeleting (1/2): /home/uid1/.cache/yay/nvidia-390xx-utils[0m
:: [1mDeleting (2/2): /home/uid1/.cache/yay/nvidia-390xx[0m
:: [1m(1/2) Downloaded PKGBUILD: nvidia-390xx-utils[0m
:: [1m(2/2) Downloaded PKGBUILD: nvidia-390xx[0m
  2 nvidia-390xx-utils (nvidia-390xx-utils nvidia-390xx-dkms) (Installed) (Build Files Exist)
  1 nvidia-390xx                             (Installed) (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> :: [1m(1/2) Parsing SRCINFO: nvidia-390xx-utils (nvidia-390xx-utils nvidia-390xx-dkms)[0m
:: [1m(2/2) Parsing SRCINFO: nvidia-390xx[0m
[1m[32m==>[m[1m Making package: nvidia-390xx 390.147-1 (Sun 19 Dec 2021 23:54:48)[m
[1m[32m==>[m[1m Retrieving sources...[m
[1m[32m==>[m[1m Making package: nvidia-390xx-utils 390.147-1 (Sun 19 Dec 2021 23:54:51)[m
[1m[32m==>[m[1m Retrieving sources...[m
[1m[34m  ->[m[1m Found nvidia-drm-outputclass.conf[m
[1m[34m  ->[m[1m Found nvidia-390xx-utils.sysusers[m
[1m[34m  ->[m[1m Found nvidia-390xx.rules[m
[1m[34m  ->[m[1m Downloading NVIDIA-Linux-x86_64-390.147.run...[m
[1m[34m  ->[m[1m Found kernel-4.16.patch[m
[1m[32m==>[m[1m Validating source files with b2sums...[m
 -> nvidia-390xx-utils=390.147 not satisfied, flushing install queue
[1m[32m==>[m[1m Making package: nvidia-390xx-utils 390.147-1 (Sun 19 Dec 2021 23:55:25)[m
[1m[32m==>[m[1m Checking runtime dependencies...[m
[1m[32m==>[m[1m Checking buildtime dependencies...[m
[1m[32m==>[m[1m Retrieving sources...[m
[1m[34m  ->[m[1m Found nvidia-drm-outputclass.conf[m
[1m[34m  ->[m[1m Found nvidia-390xx-utils.sysusers[m
[1m[34m  ->[m[1m Found nvidia-390xx.rules[m
[1m[34m  ->[m[1m Found NVIDIA-Linux-x86_64-390.147.run[m
[1m[34m  ->[m[1m Found kernel-4.16.patch[m
[1m[32m==>[m[1m Validating source files with b2sums...[m
[1m[32m==>[m[1m Removing existing $srcdir/ directory...[m
[1m[32m==>[m[1m Extracting sources...[m
[1m[32m==>[m[1m Starting prepare()...[m
Creating directory NVIDIA-Linux-x86_64-390.147
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 390.147....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
patching file kernel/common/inc/nv-linux.h
patching file kernel/conftest.sh
Hunk #1 succeeded at 2057 (offset 1 line).
[1m[32m==>[m[1m Sources are ready.[m
[1m[32m==>[m[1m Making package: nvidia-390xx-utils 390.147-1 (Sun 19 Dec 2021 23:55:40)[m
[1m[32m==>[m[1m Checking runtime dependencies...[m
[1m[32m==>[m[1m Checking buildtime dependencies...[m
[1m[32m==>[m[1m Entering fakeroot environment...[m
[1m[32m==>[m[1m Starting package_nvidia-390xx-utils()...[m
[1m[32m==>[m[1m Tidying install...[m
[1m[34m  ->[m[1m Removing libtool files...[m
[1m[34m  ->[m[1m Purging unwanted files...[m
[1m[34m  ->[m[1m Removing static library files...[m
[1m[34m  ->[m[1m Compressing man and info pages...[m
[1m[32m==>[m[1m Checking for packaging issues...[m
[1m[32m==>[m[1m Creating package "nvidia-390xx-utils"...[m
[1m[34m  ->[m[1m Generating .PKGINFO file...[m
[1m[34m  ->[m[1m Generating .BUILDINFO file...[m
[1m[34m  ->[m[1m Adding install file...[m
[1m[34m  ->[m[1m Generating .MTREE file...[m
[1m[34m  ->[m[1m Compressing package...[m
[1m[32m==>[m[1m Starting package_opencl-nvidia-390xx()...[m
[1m[32m==>[m[1m Tidying install...[m
[1m[34m  ->[m[1m Removing libtool files...[m
[1m[34m  ->[m[1m Purging unwanted files...[m
[1m[34m  ->[m[1m Removing static library files...[m
[1m[34m  ->[m[1m Compressing man and info pages...[m
[1m[32m==>[m[1m Checking for packaging issues...[m
[1m[32m==>[m[1m Creating package "opencl-nvidia-390xx"...[m
[1m[34m  ->[m[1m Generating .PKGINFO file...[m
[1m[34m  ->[m[1m Generating .BUILDINFO file...[m
[1m[34m  ->[m[1m Generating .MTREE file...[m
[1m[34m  ->[m[1m Compressing package...[m
[1m[32m==>[m[1m Starting package_nvidia-390xx-dkms()...[m
[1m[32m==>[m[1m Tidying install...[m
[1m[34m  ->[m[1m Removing libtool files...[m
[1m[34m  ->[m[1m Purging unwanted files...[m
[1m[34m  ->[m[1m Removing static library files...[m
[1m[34m  ->[m[1m Compressing man and info pages...[m
[1m[32m==>[m[1m Checking for packaging issues...[m
[1m[32m==>[m[1m Creating package "nvidia-390xx-dkms"...[m
[1m[34m  ->[m[1m Generating .PKGINFO file...[m
[1m[34m  ->[m[1m Generating .BUILDINFO file...[m
[1m[34m  ->[m[1m Generating .MTREE file...[m
[1m[34m  ->[m[1m Compressing package...[m
[1m[32m==>[m[1m Leaving fakeroot environment.[m
[1m[32m==>[m[1m Finished making: nvidia-390xx-utils 390.147-1 (Sun 19 Dec 2021 23:55:50)[m
[1m[32m==>[m[1m Cleaning up...[m
 -> nvidia-390xx-utils=390.147 not satisfied, flushing install queue
loading packages...
resolving dependencies...
looking for conflicting packages...
:: installing nvidia-390xx-utils (390.147-1) breaks dependency 'nvidia-390xx-utils=390.144' required by nvidia-390xx

Last edited by madox (2021-12-19 16:28:59)

Offline

#80 2021-12-19 19:30:13

DAC324
Member
Registered: 2020-03-12
Posts: 70

Re: nvidia-390xx AUR package discussion thread

Good news is that version 390.147 of the Nvidia driver does not require disabling the ABI check anymore.
That means

Section "ServerFlags"
    Option        "IgnoreABI" "1"
EndSection

can be removed from the Xorg config files when using 390.147.

Last edited by DAC324 (2021-12-19 19:33:07)

Offline

#81 2021-12-20 10:09:05

thommen
Member
Registered: 2017-12-30
Posts: 141

Re: nvidia-390xx AUR package discussion thread

Today's update 390.144-3 → 390.147.1 causes errors

NVIDIA failed to initialize the nvidia kernel module

Packets loosening helps

pacaur -U nvidia-390xx-dkms-390.144-3-x86_64.pkg.tar.zst nvidia-390xx-utils-390.144-3-x86_64.pkg.tar.zst

Does anyone know if I have to wait for a correction or if I have a complication

Last edited by thommen (2021-12-20 10:11:20)

Offline

#82 2021-12-20 10:20:56

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,983

Re: nvidia-390xx AUR package discussion thread

Where do you see that? If you've set up early KMS you also need to rebuild your initramfs with mkinitcpio -P and/or properly set up the KMS rebuild pacman hook (note, if you blindly copy paste that hook while being in this thread you didn't properly set it up)

Offline

#83 2021-12-20 13:19:48

DAC324
Member
Registered: 2020-03-12
Posts: 70

Re: nvidia-390xx AUR package discussion thread

thommen wrote:

Today's update 390.144-3 → 390.147.1 causes errors

NVIDIA failed to initialize the nvidia kernel module

Packets loosening helps

pacaur -U nvidia-390xx-dkms-390.144-3-x86_64.pkg.tar.zst nvidia-390xx-utils-390.144-3-x86_64.pkg.tar.zst

Does anyone know if I have to wait for a correction or if I have a complication

You will have to install all of the following packages:

nvidia-390xx-utils=390.147
nvidia-390xx-dkms=390.147
nvidia-390xx 390.147-1

If any of these three packages has a different version, you will get the error you described.

Offline

#84 2021-12-20 13:40:59

thommen
Member
Registered: 2017-12-30
Posts: 141

Re: nvidia-390xx AUR package discussion thread

V1del wrote:

Where do you see that? If you've set up early KMS you also need to rebuild your initramfs with mkinitcpio -P and/or properly set up the KMS rebuild pacman hook (note, if you blindly copy paste that hook while being in this thread you didn't properly set it up)

I forgot to execute

sudo mkinitcpio -P linux

I didn't know it at all → https://wiki.archlinux.org/title/NVIDIA#pacman_hook

Last edited by thommen (2021-12-20 13:41:19)

Offline

#85 2021-12-21 00:13:36

jonathon
Member
Registered: 2016-09-19
Posts: 115

Re: nvidia-390xx AUR package discussion thread

madox wrote:
:: installing nvidia-390xx-utils (390.147-1) breaks dependency 'nvidia-390xx-utils=390.144' required by nvidia-390xx

Build the packages, then install the packages together. I think this same dependency issue was detailed earlier in the thread... hmm

Last edited by jonathon (2021-12-21 00:14:24)

Offline

#86 2022-01-11 03:50:34

madox
Member
Registered: 2021-12-19
Posts: 2

Re: nvidia-390xx AUR package discussion thread

jonathon wrote:
madox wrote:
:: installing nvidia-390xx-utils (390.147-1) breaks dependency 'nvidia-390xx-utils=390.144' required by nvidia-390xx

Build the packages, then install the packages together. I think this same dependency issue was detailed earlier in the thread... hmm

Thanks you so much for the advice, and sorry for the late response. The advice helped, and I was able to manually install the current package versions. I've probably been a bit complacent using yay (thinking its a fault with the package) and forgot to investigate further.

I did encounter one issue trying to manually download and install the AUR packages, which I did not fully understand. I had error messages such as source dir not found, but was able to manually build and install the packages from the ~/.cache/yay/nvidia-390xx... directories without issue.

Offline

Board footer

Powered by FluxBB