You are not logged in.

#1 2021-11-22 07:23:11

Linux-Addict
Member
Registered: 2021-11-22
Posts: 3

Xorg Stopped Working After Update

Good moment of the day to all of you , the first thing i must to say is that my english is not my mother languaje, so please excuseme if i make an error.

I had a very very bad week , and i really have no idea about how to solve it, please help me to solve it, Xorg just stopped working since the last update.

Here is the cat /var/log/Xorg.0.log

[  2554.583] (--) Log file renamed from "/var/log/Xorg.pid-4287.log" to "/var/log/Xorg.0.log"
[  2554.584]
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.
[  2554.584]
X.Org X Server 1.21.1.1
X Protocol Version 11, Revision 0
[  2554.584] Current Operating System: Linux archfan 5.15.2-arch1-1 #1 SMP PREEMPT Fri, 12 Nov 2021 19:22:10 +0000 x86_64
[  2554.584] Kernel command line: initrd=\intel-ucode.img initrd=\initramfs-linux.img cryptdevice=PARTUUID=f4ccb736-4c78-4fb1-9707-8420ad82db0c:luksdev root=/dev/mapper/luksdev rw intel_pstate=no_hwp
[  2554.584]
[  2554.584] Current version of pixman: 0.40.0
[  2554.584]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[  2554.584] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2554.584] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov 16 07:36:47 2021
[  2554.584] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  2554.584] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2554.584] (==) No Layout section.  Using the first Screen section.
[  2554.584] (**) |-->Screen "Screen0" (0)
[  2554.584] (**) |   |-->Monitor "<default monitor>"
[  2554.584] (==) No monitor specified for screen "Screen0".
    Using a default monitor configuration.
[  2554.584] (==) Automatically adding devices
[  2554.584] (==) Automatically enabling devices
[  2554.584] (==) Automatically adding GPU devices
[  2554.584] (==) Automatically binding GPU devices
[  2554.584] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  2554.584] (WW) The directory "/usr/share/fonts/misc" does not exist.
[  2554.584]     Entry deleted from font path.
[  2554.584] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[  2554.584]     Entry deleted from font path.
[  2554.584] (==) FontPath set to:
    /usr/share/fonts/TTF,
    /usr/share/fonts/OTF,
    /usr/share/fonts/100dpi,
    /usr/share/fonts/75dpi
[  2554.584] (==) ModulePath set to "/usr/lib/xorg/modules"
[  2554.584] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[  2554.584] (II) Module ABI versions:
[  2554.584]     X.Org ANSI C Emulation: 0.4
[  2554.584]     X.Org Video Driver: 25.2
[  2554.584]     X.Org XInput driver : 24.4
[  2554.584]     X.Org Server Extension : 10.0
[  2554.585] (++) using VT number 1

[  2554.585] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[  2554.586] (II) xfree86: Adding drm device (/dev/dri/card0)
[  2554.586] (II) Platform probe for /sys/devices/pci0000:00/0000:00:02.0/drm/card0
[  2554.588] (--) PCI:*(0@0:2:0) 8086:5916:103c:831e rev 2, Mem @ 0xb0000000/16777216, 0xa0000000/268435456, I/O @ 0x00005000/64, BIOS @ 0x????????/131072
[  2554.588] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  2554.588] (II) "glx" will be loaded by default.
[  2554.588] (II) LoadModule: "vnc"
[  2554.588] (II) Loading /usr/lib/xorg/modules/extensions/libvnc.so
[  2554.596] (II) Module vnc: vendor="TigerVNC Project"
[  2554.596]     compiled for 1.20.9, module version = 1.0.0
[  2554.596]     Module class: X.Org Server Extension
[  2554.596]     ABI class: X.Org Server Extension, version 10.0
[  2554.596] (II) LoadModule: "glx"
[  2554.596] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  2554.597] (II) Module glx: vendor="X.Org Foundation"
[  2554.597]     compiled for 1.21.1.1, module version = 1.0.0
[  2554.597]     ABI class: X.Org Server Extension, version 10.0
[  2554.597] (==) Matched intel as autoconfigured driver 0
[  2554.597] (==) Matched modesetting as autoconfigured driver 1
[  2554.597] (==) Matched fbdev as autoconfigured driver 2
[  2554.597] (==) Matched vesa as autoconfigured driver 3
[  2554.597] (==) Assigned the driver to the xf86ConfigLayout
[  2554.597] (II) LoadModule: "intel"
[  2554.597] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[  2554.598] (II) Module intel: vendor="X.Org Foundation"
[  2554.598]     compiled for 1.21.1.1, module version = 2.99.917
[  2554.598]     Module class: X.Org Video Driver
[  2554.598]     ABI class: X.Org Video Driver, version 25.2
[  2554.598] (II) LoadModule: "modesetting"
[  2554.598] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  2554.598] (II) Module modesetting: vendor="X.Org Foundation"
[  2554.598]     compiled for 1.21.1.1, module version = 1.21.1
[  2554.598]     Module class: X.Org Video Driver
[  2554.598]     ABI class: X.Org Video Driver, version 25.2
[  2554.598] (II) LoadModule: "fbdev"
[  2554.598] (WW) Warning, couldn't open module fbdev
[  2554.598] (EE) Failed to load module "fbdev" (module does not exist, 0)
[  2554.598] (II) LoadModule: "vesa"
[  2554.598] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[  2554.598] (II) Module vesa: vendor="X.Org Foundation"
[  2554.598]     compiled for 1.21.1.1, module version = 2.5.0
[  2554.598]     Module class: X.Org Video Driver
[  2554.598]     ABI class: X.Org Video Driver, version 25.2
[  2554.598] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
    i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
    915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
    Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
    GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[  2554.599] (II) intel: Driver for Intel(R) HD Graphics
[  2554.599] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[  2554.599] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[  2554.599] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  2554.599] (II) VESA: driver for VESA chipsets: vesa
[  2554.599] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20201103
[  2554.599] (II) intel(0): SNA compiled from 2.99.917-916-g31486f40
[  2554.616] (WW) Falling back to old probe method for modesetting
[  2554.616] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 620
[  2554.616] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 2 threads
[  2554.616] (II) intel(0): Creating default Display subsection in Screen section
    "Screen0" for depth/fbbpp 24/32
[  2554.616] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[  2554.616] (==) intel(0): RGB weight 888
[  2554.616] (==) intel(0): Default visual is TrueColor
[  2554.617] (II) intel(0): Output eDP1 has no monitor section
[  2554.617] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[  2554.617] (II) intel(0): Enabled output eDP1
[  2554.617] (II) intel(0): Output HDMI1 has no monitor section
[  2554.617] (II) intel(0): Enabled output HDMI1
[  2554.617] (II) intel(0): Output DP1 has no monitor section
[  2554.617] (II) intel(0): Enabled output DP1
[  2554.617] (II) intel(0): Output HDMI2 has no monitor section
[  2554.617] (II) intel(0): Enabled output HDMI2
[  2554.617] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[  2554.617] (II) intel(0): Output VIRTUAL1 has no monitor section
[  2554.617] (II) intel(0): Enabled output VIRTUAL1
[  2554.617] (--) intel(0): Output eDP1 using initial mode 1366x768 on pipe 0
[  2554.617] (==) intel(0): TearFree enabled
[  2554.617] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[  2554.617] (==) intel(0): DPI set to (96, 96)
[  2554.617] (II) Loading sub module "dri3"
[  2554.617] (II) LoadModule: "dri3"
[  2554.617] (II) Module "dri3" already built-in
[  2554.617] (II) Loading sub module "dri2"
[  2554.617] (II) LoadModule: "dri2"
[  2554.617] (II) Module "dri2" already built-in
[  2554.617] (II) Loading sub module "present"
[  2554.617] (II) LoadModule: "present"
[  2554.617] (II) Module "present" already built-in
[  2554.617] (II) UnloadModule: "modesetting"
[  2554.617] (II) Unloading modesetting
[  2554.618] (II) UnloadModule: "vesa"
[  2554.618] (II) Unloading vesa
[  2554.618] (II) intel(0): SNA initialized with Kabylake (gen9) backend
[  2554.618] (==) intel(0): Backing store enabled
[  2554.618] (==) intel(0): Silken mouse enabled
[  2554.618] (II) intel(0): HW Cursor enabled
[  2554.618] (==) intel(0): DPMS enabled
[  2554.618] (==) intel(0): Display hotplug detection enabled
[  2554.618] (II) intel(0): [DRI2] Setup complete
[  2554.618] (II) intel(0): [DRI2]   DRI driver: i965
[  2554.618] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[  2554.618] (II) intel(0): direct rendering: DRI2 DRI3 enabled
[  2554.618] (II) intel(0): hardware support for Present enabled
[  2554.618] (WW) intel(0): Option "UserPasswdVerifier" is not used
[  2554.618] (WW) intel(0): Option "PasswordFile" is not used
[  2554.618] (II) Initializing extension Generic Event Extension
[  2554.618] (II) Initializing extension SHAPE
[  2554.618] (II) Initializing extension MIT-SHM
[  2554.618] (II) Initializing extension XInputExtension
[  2554.619] (II) Initializing extension XTEST
[  2554.619] (II) Initializing extension BIG-REQUESTS
[  2554.619] (II) Initializing extension SYNC
[  2554.619] (II) Initializing extension XKEYBOARD
[  2554.619] (II) Initializing extension XC-MISC
[  2554.619] (II) Initializing extension SECURITY
[  2554.619] (II) Initializing extension XFIXES
[  2554.619] (II) Initializing extension RENDER
[  2554.619] (II) Initializing extension RANDR
[  2554.619] (II) Initializing extension COMPOSITE
[  2554.620] (II) Initializing extension DAMAGE
[  2554.620] (II) Initializing extension MIT-SCREEN-SAVER
[  2554.620] (II) Initializing extension DOUBLE-BUFFER
[  2554.620] (II) Initializing extension RECORD
[  2554.620] (II) Initializing extension DPMS
[  2554.620] (II) Initializing extension Present
[  2554.620] (II) Initializing extension DRI3
[  2554.620] (II) Initializing extension X-Resource
[  2554.620] (II) Initializing extension XVideo
[  2554.620] (II) Initializing extension XVideo-MotionCompensation
[  2554.620] (II) Initializing extension GLX
[  2554.624] (II) AIGLX: Loaded and initialized i965
[  2554.624] (II) GLX: Initialized DRI2 GL provider for screen 0
[  2554.624] (II) Initializing extension XFree86-VidModeExtension
[  2554.624] (II) Initializing extension XFree86-DGA
[  2554.624] (II) Initializing extension XFree86-DRI
[  2554.624] (II) Initializing extension DRI2
[  2554.624] (II) Initializing extension VNC
[  2554.624] (EE)
[  2554.624] (EE) Backtrace:
[  2554.624] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x5b) [0x55c482f57ddb]
[  2554.624] (EE) 1: /usr/lib/Xorg (0x55c482e0c000+0x156a15) [0x55c482f62a15]
[  2554.624] (EE) 2: /usr/lib/libpthread.so.0 (0x7f51d7361000+0x13870) [0x7f51d7374870]
[  2554.624] (EE) 3: /usr/lib/Xorg (xf86OptionValue+0x7) [0x55c482f6ed37]
[  2554.624] (EE) 4: /usr/lib/xorg/modules/extensions/libvnc.so (0x7f51d67e7000+0x34c11) [0x7f51d681bc11]
[  2554.624] (EE) 5: /usr/lib/Xorg (InitExtensions+0x89) [0x55c482e52a39]
[  2554.624] (EE) 6: /usr/lib/Xorg (0x55c482e0c000+0x3a0d7) [0x55c482e460d7]
[  2554.624] (EE) 7: /usr/lib/libc.so.6 (__libc_start_main+0xd5) [0x7f51d71b7b25]
[  2554.624] (EE) 8: /usr/lib/Xorg (_start+0x2e) [0x55c482e474ce]
[  2554.624] (EE)
[  2554.624] (EE) Segmentation fault at address 0x100000011
[  2554.624] (EE)
Fatal server error:
[  2554.624] (EE) Caught signal 11 (Segmentation fault). Server aborting
[  2554.624] (EE)
[  2554.624] (EE)
Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.
[  2554.624] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  2554.624] (EE)
[  2554.624] (II) AIGLX: Suspending AIGLX clients for VT switch
[  2554.645] (EE) Server terminated with error (1). Closing log file.


And the cat ~/.xinitrc

#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then







    xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then







    xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
done
unset f
fi

twm &
xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
exec xterm -geometry 80x66+0+0 -name login


I sincerely do not remember why i set that config in .xinitrc , so it was related with use xinit as window manager or something related.
I am on wayland now and my problem is that i am a student an i need to share screen and now i can not do it because the web browser throws an error.
I had a very heavy week without sleep , and may be this why i was unable to find any solution in the forum or the arch wiki, so forgiveness in advance.

Offline

#2 2021-11-22 09:43:16

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,487

Re: Xorg Stopped Working After Update

Please wrap outputs in code tags.

TigerVNC's xorg module is crashing If you don't actively use it I suggest removing it or changing your config so that it doesn't unconditionally load tigerVnc. Maybe also see this thread that's dealing with a similar issue: https://bbs.archlinux.org/viewtopic.php?id=271343

FWIW if I'm reading this correctly tigervnc should've received an update for the new xorg compat you might want to check whether updating fixes things. If this doesn't help post the config files in /{etc,usr/share}/X11/xorg.conf.d check both the etc and usr/share paths

Online

#3 2021-11-22 16:03:47

Linux-Addict
Member
Registered: 2021-11-22
Posts: 3

Re: Xorg Stopped Working After Update

Thank you very much for your answer , i'm so sorry by don't use the tags, i will change it.
I remember that i was developing a script what made the startup and config of tigerVnc more easy and upload it to Github, but i just got a lot of university homework and stopped use it , i update my Arch daily and is by this reason what my head exploded when i saw the error : reaching graphical environment (or something like this). I will uninstall tigerVnc and report here if the problem is solved.

Seriously thank you very much for answer my question.

Offline

#4 2021-11-22 16:12:48

Linux-Addict
Member
Registered: 2021-11-22
Posts: 3

Re: Xorg Stopped Working After Update

Thank you very much for your answer , i'm so sorry by don't use the tags, i will change it.
I remember that i was developing a script what made the startup and config of tigerVnc more easy and upload it to Github, but i just got a lot of university homework and stopped use it , i update my Arch daily and is by this reason what my head exploded when i saw the error : reaching graphical environment (or something like this). I will uninstall tigerVnc and report here if the problem is solved.

Seriously thank you very much for answer my question.

Offline

Board footer

Powered by FluxBB