You are not logged in.

#1 2021-11-20 18:06:16

Registered: 2021-11-20
Posts: 2

[SOLVED] User account can't access XFCE DE with LXDM

So i created a user account via

# useradd -m username

but when i try to access my XFCE DE with LXDM via "XFCE-Session" it gives me the following error text:

"Unable to contact settings server

could not connect: connection refused"

so i tried to see if xinit is running and it gave me the following Xorg.0.log

Currently using my root account to write this, hope you guys can help because i couldn't find any solutions for this.

EDIT : So let me better explain the issue, the tried sollutions to the problem and how i solved it:
I installed Arch Linux via "#archinstall" and when prompted by my desired profile i chose "XORG Install" and added the following programs:
- lxdm
- xfdesktop
- xfce4-whiskermenu-plugin
- xfce4-session
- xfce4-settings
- xfce4-panel
- thunar
- awesome

I DID NOT CREATE A USER PROFILE AT INSTALL and used my root account for setting up the desktop as my liking (I had full access to it with root via LXDM). When i was satisfied i created a user account with "#useradd -m username", added a password with "#passwd username #password" and logged in on LXDM with it. It was then that i was introduced to the first error above.

1st try: I tried to run the DE with #xinit after configuring the copied .xinitrc file to have the argument "startxfce4" but i had the following error:
"(EE) Server terminated with error (1). Closing log" for additional information.
xinit: unable to connect to X server: Connection refused
xinit: server error"

2nd try: posted this and added the line "vt$XDG_VTNR" to my ".xserverrc" file as instructed by the user "seth" and the error above persisted.

3rd try: Downloaded "LightDM" and had the same problem. "SDDM" same problem. "GDM" Worked ! PS: it seems that i forgot to run "#startx" as well in the beginning, because that works as well

So in the end i had no idea why "LXDM", "LightDM" and "SDDM" don't work with "xfce session" in a user account out of the box like the others... but then i thought about what i did different with "GDM", i enabled the unit with "#systemctl enable unit" since i couldn't run them from the initial terminal like i was doing with the others, so i did that and they all worked.

FIX: Enable "LXDM" or "LightDM" to run on boot with "#systemctl enable unit".  (easy right ? well, in my defense i didn't knew that i needed to do this, since i could start "LXDM" from the terminal and still use my root account. I expected to have the same result when using an user account.

Last edited by QueenZz (2021-11-23 01:13:03)


#2 2021-11-20 20:00:24

Registered: 2012-09-03
Posts: 26,538

Re: [SOLVED] User account can't access XFCE DE with LXDM

[   296.591] (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied) - specify vt$XDG_VTNR
Not sure whther that's in any way related to your lxdm/xfce issues, though. (We'd ideally need to see a full system journal, logging into xfce via lxdm as root does work?)


#3 2021-11-20 20:13:52

From: Hoosiertucky
Registered: 2019-03-10
Posts: 511

Re: [SOLVED] User account can't access XFCE DE with LXDM

I don't see any indication that the new users password was set.


#4 2021-11-23 01:14:24

Registered: 2021-11-20
Posts: 2

Re: [SOLVED] User account can't access XFCE DE with LXDM

Solved it by enabling the DM at boot. i explain it better on my edit to the main question but thanks for the help big_smile


Board footer

Powered by FluxBB