You are not logged in.

#1 2021-11-16 06:52:53

jens1108
Member
Registered: 2021-11-16
Posts: 3

Flickering in KDE Plasma

Hello everyone,

since some updates in the last days (properly on Sunday evening), KDE Plasma isn't rendering windows correctly. Several application windows, for example, Firefox (also happens with Chrome) flicker extremely. Parts of the window disappear and reappear. It looks like this happens when the window is redrawn. Disabling the Compositor helps, but does not remove the problem completely. The problem doesn't occur in Xfce, therefore I think I can rule out the XServer (I'm using X11), and also the graphics driver (Nouveau in my case). Most settings in Plasma are default (theme is Breeze, Window decorations are also Breeze).

Any ideas what the problem here might be?

Best

Jens

Offline

#2 2021-11-16 08:02:50

seth
Member
Registered: 2012-09-03
Posts: 25,086

Re: Flickering in KDE Plasma

Sounds eerily like https://bbs.archlinux.org/viewtopic.php?id=271316 - FF & chromium are probably GL accelerated, so is the kwin compositor and the plasma desktop etcetc… and you're also using nouveau.
=> Does the LTS kernel have the same problem?

Offline

#3 2021-11-16 11:57:46

jens1108
Member
Registered: 2021-11-16
Posts: 3

Re: Flickering in KDE Plasma

Hello Seth,

seth wrote:

Sounds eerily like https://bbs.archlinux.org/viewtopic.php?id=271316 - FF & chromium are probably GL accelerated, so is the kwin compositor and the plasma desktop etcetc… and you're also using nouveau.
=> Does the LTS kernel have the same problem?

Thanks for the hint with the LTS kernel. The LTS kernel does not have the same problem, so it looks like there is some problem in the interaction between the kernel and the Nouveau driver.

Should I file a bug for this problem?

Best

Jens

Offline

#4 2021-11-16 12:02:34

seth
Member
Registered: 2012-09-03
Posts: 25,086

Re: Flickering in KDE Plasma

It looks like there's a problem in the nouveau kernel module?
Or do you use xf86-video-nouveau and if so: does the problem remain if you remove that (and use the modesetting driver)?

Offline

#5 2021-11-17 20:38:58

Goffi
Member
Registered: 2017-11-12
Posts: 5

Re: Flickering in KDE Plasma

Hello, I have similar issues with Intel GPU (Intel Corporation TigerLake-LP GT2 [Iris Xe Graphics] (rev 01)) and I'm not the only one: https://bugs.kde.org/show_bug.cgi?id=445456 . As for you, switching to linux-lts fixes the issue, so there is something wrong with Linux 5.15.2 and it's not only affecting NVIDIA cards.

Offline

#6 2021-11-17 21:07:22

seth
Member
Registered: 2012-09-03
Posts: 25,086

Re: Flickering in KDE Plasma

The kde bugs describes a stalled GPU - please check the video in the thread I linked in #2 (and that concerns a game) - does your problem look like that?

Offline

#7 2021-11-18 11:19:47

Goffi
Member
Registered: 2017-11-12
Posts: 5

Re: Flickering in KDE Plasma

I've no tried games, but I had windows not displayed, sometimes flickering, freeze (in particular with notifications or if I wan to check network manager). I happens a lot on KDE and LXQt, the problem is there but far less often with XFCE or Gnome. Overall, the desktops were unusable.

Offline

#8 2021-11-18 16:01:36

seth
Member
Registered: 2012-09-03
Posts: 25,086

Re: Flickering in KDE Plasma

Will you please watch the video in the other thread and check whether you experience *THAT* kind of artifact?

"I have issue w/ my GPU, hence it must be same" is kindergarten level.
It could be the xf86-video-intel driver or the iris GL implementation or whatnot colliding w/ the i915 module - also there's prominently https://wiki.archlinux.org/title/Intel_ … flickering and https://wiki.archlinux.org/title/Intel_ … ete_freeze etcetcetc.

Edit also see https://bbs.archlinux.org/viewtopic.php?id=271403

Last edited by seth (2021-11-18 16:10:49)

Offline

#9 2021-11-18 16:58:35

jens1108
Member
Registered: 2021-11-16
Posts: 3

Re: Flickering in KDE Plasma

Hello Seth,

seth wrote:

It looks like there's a problem in the nouveau kernel module?
Or do you use xf86-video-nouveau and if so: does the problem remain if you remove that (and use the modesetting driver)?

at the moment I using the xf86-video-nouveau driver. I will try without at the weekend.

Best

Jens

Offline

#10 2021-11-20 04:38:47

diogobaeder
Member
Registered: 2012-01-02
Posts: 48

Re: Flickering in KDE Plasma

I'm not sure if this is the same issue as you're facing, but I've been having flickering issues since a recent upgrade of my packages, and after some searching at this forum I tried removing xf86-video-nouveau and xf86-video-vesa and it seems to have fixed the issue for me - at least so far I haven't seen any flickers in the programs I was having them after removing those packages. (Disclaimer: I use Wayland here, which is why it was OK for me to remove those packages.)

[EDIT] I forgot to say, I use GNOME here, not KDE. But it seems that the issues were happening with Qt-based programs I think (I'm not sure of this though), so this might be relevant for your case.

Last edited by diogobaeder (2021-11-20 04:39:56)

Offline

#11 2021-11-20 07:58:59

seth
Member
Registered: 2012-09-03
Posts: 25,086

Re: Flickering in KDE Plasma

On wayland xf86-video-nouveau would only matter on xwayland (ie. nested X11 clients) - can you name some affected programs?

Offline

#12 2021-11-20 12:55:37

diogobaeder
Member
Registered: 2012-01-02
Posts: 48

Re: Flickering in KDE Plasma

Hi!

seth wrote:

On wayland xf86-video-nouveau would only matter on xwayland (ie. nested X11 clients) - can you name some affected programs?

Sure! It's mostly Zoom, Slack, Rambox and I think Spotify as well if I remember correctly.

Offline

#13 2021-11-20 13:13:14

seth
Member
Registered: 2012-09-03
Posts: 25,086

Re: Flickering in KDE Plasma

Aka "electron" - yeah, fits.
Virtually the same client all the time and I'm pretty sure it only runs on xwayland by default.

Offline

#14 2021-11-23 01:09:58

diogobaeder
Member
Registered: 2012-01-02
Posts: 48

Re: Flickering in KDE Plasma

Got it. So XWayland is probably to blame then?

Offline

#15 2021-11-23 07:07:46

seth
Member
Registered: 2012-09-03
Posts: 25,086

Re: Flickering in KDE Plasma

No, the common element seems to be xf86-video-nouveau (xwayland just explains why it hits you despite superficially running a wayland. You're still running X11 for those clients and so xf86-video-nouveau matters again)

Offline

#16 2021-11-23 11:31:36

diogobaeder
Member
Registered: 2012-01-02
Posts: 48

Re: Flickering in KDE Plasma

Yeah, that makes sense. Thanks! :-)

Offline

Board footer

Powered by FluxBB