You are not logged in.

#1 2021-11-24 07:41:15

weltio
Member
From: Germany
Registered: 2009-04-05
Posts: 86

gitlab always: http 503 Deploy in progress (despite supposed wiki fix)

After upgrading I only get: Deploy in progress
The supposed fix is:

cd /usr/share/webapps/gitlab
sudo -u gitlab $(cat environment | xargs) bundle-2.7 exec rake db:migrate
sudo -u gitlab $(cat environment | xargs) bundle-2.7 exec rake gitlab:assets:clean gitlab:assets:compile cache:clear
systemctl restart gitlab-puma gitlab-sidekiq gitlab-workhorse

For me it results in:

warning Resolution field "chokidar@3.4.0" is incompatible with requested version "webpack-dev-server#chokidar@^2.1.8"
warning Resolution field "chokidar@3.4.0" is incompatible with requested version "webpack#watchpack#chokidar@^3.4.1"
warning Resolution field "chokidar@3.4.0" is incompatible with requested version "watchpack#watchpack-chokidar2#chokidar@^2.1.8"
`yarn:check` finished in 17.949717778 seconds
rake aborted!
Errno::EACCES: Permission denied @ dir_s_mkdir - /usr/share/webapps/gitlab/app/assets
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/gettext_i18n_rails_js-1.3.0/lib/gettext_i18n_rails_js/task.rb:45:in `destination'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/gettext_i18n_rails_js-1.3.0/lib/gettext_i18n_rails_js/task.rb:84:in `block in files_iterate'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/gettext_i18n_rails_js-1.3.0/lib/gettext_i18n_rails_js/task.rb:77:in `each'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/gettext_i18n_rails_js-1.3.0/lib/gettext_i18n_rails_js/task.rb:77:in `files_iterate'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/gettext_i18n_rails_js-1.3.0/lib/gettext_i18n_rails_js/task.rb:36:in `po_to_json'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/gettext_i18n_rails_js-1.3.0/lib/tasks/gettext_i18n_rails_js_tasks.rake:32:in `block (2 levels) in <top (required)>'
/usr/share/webapps/gitlab/lib/gitlab/task_helpers.rb:18:in `invoke_and_time_task'
/usr/share/webapps/gitlab/lib/tasks/gitlab/assets.rake:59:in `each'
/usr/share/webapps/gitlab/lib/tasks/gitlab/assets.rake:59:in `block (3 levels) in <top (required)>'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/exe/rake:27:in `<top (required)>'

So trying it as root:

RAILS_ENV=production EXECJS_RUNTIME=Disabled RUBYOPT=-W:no-deprecated bundle-2.7 exec rake gitlab:assets:clean gitlab:assets:compile cache:clear --trace
...
yarn install v1.22.17
[1/4] Resolving packages...
success Already up-to-date.
$ node ./scripts/frontend/postinstall.js
success Dependency postinstall check passed.
Done in 3.51s.
/usr/lib/ruby/2.7.0/bundler/spec_set.rb:86:in `block in materialize': Could not find rake-13.0.6 in any of the sources (Bundler::GemNotFound)
        from /usr/lib/ruby/2.7.0/bundler/spec_set.rb:80:in `map!'
        from /usr/lib/ruby/2.7.0/bundler/spec_set.rb:80:in `materialize'
        from /usr/lib/ruby/2.7.0/bundler/definition.rb:170:in `specs'
        from /usr/lib/ruby/2.7.0/bundler/definition.rb:237:in `specs_for'
        from /usr/lib/ruby/2.7.0/bundler/definition.rb:226:in `requested_specs'
        from /usr/lib/ruby/2.7.0/bundler/runtime.rb:101:in `block in definition_method'
        from /usr/lib/ruby/2.7.0/bundler/runtime.rb:20:in `setup'
        from /usr/lib/ruby/2.7.0/bundler.rb:149:in `setup'
        from /usr/lib/ruby/2.7.0/bundler/setup.rb:20:in `block in <top (required)>'
        from /usr/lib/ruby/2.7.0/bundler/ui/shell.rb:136:in `with_level'
        from /usr/lib/ruby/2.7.0/bundler/ui/shell.rb:88:in `silence'
        from /usr/lib/ruby/2.7.0/bundler/setup.rb:20:in `<top (required)>'
        from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require'
        from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require'
Could not find rake-13.0.6 in any of the sources
Run `bundle install` to install missing gems.
** Execute assets:precompile
rake aborted!
ExecJS::Error: ExecJS disabled
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/execjs-2.8.1/lib/execjs/disabled_runtime.rb:18:in `compile'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/execjs-2.8.1/lib/execjs/module.rb:27:in `compile'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/autoprefixer-rails-10.2.5.1/lib/autoprefixer-rails/processor.rb:133:in `runtime'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/autoprefixer-rails-10.2.5.1/lib/autoprefixer-rails/processor.rb:35:in `process'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/autoprefixer-rails-10.2.5.1/lib/autoprefixer-rails/sprockets.rb:22:in `run'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/autoprefixer-rails-10.2.5.1/lib/autoprefixer-rails/sprockets.rb:16:in `call'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/processor_utils.rb:75:in `call_processor'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/processor_utils.rb:57:in `block in call_processors'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/processor_utils.rb:56:in `reverse_each'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/processor_utils.rb:56:in `call_processors'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/loader.rb:134:in `load_from_unloaded'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/loader.rb:60:in `block in load'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/loader.rb:317:in `fetch_asset_from_dependency_cache'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/loader.rb:44:in `load'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/cached_environment.rb:20:in `block in initialize'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/cached_environment.rb:47:in `load'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/bundle.rb:23:in `block in call'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/utils.rb:200:in `dfs'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/bundle.rb:24:in `call'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/processor_utils.rb:75:in `call_processor'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/processor_utils.rb:57:in `block in call_processors'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/processor_utils.rb:56:in `reverse_each'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/processor_utils.rb:56:in `call_processors'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/loader.rb:134:in `load_from_unloaded'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/loader.rb:60:in `block in load'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/loader.rb:317:in `fetch_asset_from_dependency_cache'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/loader.rb:44:in `load'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/cached_environment.rb:20:in `block in initialize'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/cached_environment.rb:47:in `load'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/base.rb:66:in `find_asset'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/base.rb:73:in `find_all_linked_assets'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/manifest.rb:134:in `block in find'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/manifest.rb:133:in `each'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/manifest.rb:133:in `find'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/sprockets/manifest.rb:186:in `compile'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-rails-3.2.2/lib/sprockets/rails/task.rb:67:in `block (3 levels) in define'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-3.7.2/lib/rake/sprocketstask.rb:147:in `with_logger'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sprockets-rails-3.2.2/lib/sprockets/rails/task.rb:66:in `block (2 levels) in define'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/task.rb:281:in `block in execute'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/task.rb:281:in `each'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/task.rb:281:in `execute'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/task.rb:219:in `block in invoke_with_call_chain'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/task.rb:199:in `synchronize'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/task.rb:199:in `invoke_with_call_chain'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/task.rb:188:in `invoke'
/usr/share/webapps/gitlab/lib/gitlab/task_helpers.rb:18:in `invoke_and_time_task'
/usr/share/webapps/gitlab/lib/tasks/gitlab/assets.rake:59:in `each'
/usr/share/webapps/gitlab/lib/tasks/gitlab/assets.rake:59:in `block (3 levels) in <top (required)>'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/task.rb:281:in `block in execute'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/task.rb:281:in `each'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/task.rb:281:in `execute'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/task.rb:219:in `block in invoke_with_call_chain'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/task.rb:199:in `synchronize'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/task.rb:199:in `invoke_with_call_chain'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/task.rb:188:in `invoke'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/application.rb:160:in `invoke_task'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/application.rb:116:in `block (2 levels) in top_level'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/application.rb:116:in `each'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/application.rb:116:in `block in top_level'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/application.rb:125:in `run_with_threads'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/application.rb:110:in `top_level'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/application.rb:83:in `block in run'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/application.rb:186:in `standard_exception_handling'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/lib/rake/application.rb:80:in `run'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/exe/rake:27:in `<top (required)>'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/bin/rake:23:in `load'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/bin/rake:23:in `<main>'
Tasks: TOP => assets:precompile

So trying to install:

RAILS_ENV=production EXECJS_RUNTIME=Disabled RUBYOPT=-W:no-deprecated bundle-2.7 install
...
Using rake 13.0.6
...
Bundle complete! 278 Gemfile dependencies, 449 gems now installed.
Gems in the groups development, test, aws and kerberos were not installed.
Bundled gems are installed into `./vendor/bundle`

What can I do?

Offline

Board footer

Powered by FluxBB