You are not logged in.

#1 2021-09-25 00:21:38

Rommy
Member
Registered: 2014-10-17
Posts: 35

[SOLVED] Pipewire: bluetooth disconnect on TTY change

Hi,

Pipewire works for me without any flaws (speaker and bluetooth), as long as I dont change the TTY.
When changing the TTY (from tty1 to tty2), the bluetooth device disconnects. I think this happens, because the audio device is switched to tty2 (like it happens with the speakers), but on tty2 is no pipewire running, just a console.
This switch (the disconnect) did not happen to me on pulseaudio.
I like the feature to be able to listen to bluetooth sound when changing the tty. Is there a solution how I can keep/restore the behavior from pulseaudio with pipewire?

Last edited by Rommy (2021-10-19 16:18:19)

Offline

#2 2021-10-19 16:19:42

Rommy
Member
Registered: 2014-10-17
Posts: 35

Re: [SOLVED] Pipewire: bluetooth disconnect on TTY change

I solved it by copying `/usr/share/pipewire/media-session.d/media-session.conf` to `~/.config/pipewire/media-session.d/media-session.conf`
Then I removed the line logind from with-pulseaudio.
I would prefer a lighter solution (like just overriding the with-pulseaudio section instead of everything.)

Offline

#3 2021-11-24 16:09:43

piper
Member
Registered: 2021-11-24
Posts: 1

Re: [SOLVED] Pipewire: bluetooth disconnect on TTY change

Another solution: add your 'music' user to 'audio' group - this works for headless operation as well (pipewire + pipewire-pulse + Bluetooth speaker/headphones).

Offline

Board footer

Powered by FluxBB