You are not logged in.

#1 2021-11-25 02:46:56

tsuibin
Member
Registered: 2018-05-19
Posts: 2

ERROR: '/var/lib/archbuild/extra-loongarch64/root' does not appear to

[tsuibin@archlinux trunk]$ sudo extra-loongarch64-build
==> ERROR: '/var/lib/archbuild/extra-loongarch64/root' does not appear to be an Arch chroot.
==> ERROR: Aborting...


why ?

Offline

#2 2021-11-25 02:58:56

tsuibin
Member
Registered: 2018-05-19
Posts: 2

Re: ERROR: '/var/lib/archbuild/extra-loongarch64/root' does not appear to

[tsuibin@archlinux trunk]$ sudo rm -rf /var/lib/archbuild/extra-loongarch64
[tsuibin@archlinux trunk]$ sudo extra-loongarch64-build 
==> Creating chroot for [extra] (loongarch64)...
==> Creating install root at /var/lib/archbuild/extra-loongarch64/root
==> Installing packages to /var/lib/archbuild/extra-loongarch64/root
:: Synchronizing package databases...
 core                        51.3 KiB   570 KiB/s 00:00 [#############################] 100%
 core.sig                   438.0   B  0.00   B/s 00:00 [#############################] 100%
 extra                      372.6 KiB  3.01 MiB/s 00:00 [#############################] 100%
 extra.sig                  438.0   B  0.00   B/s 00:00 [#############################] 100%
 community                  233.1 KiB  2.45 MiB/s 00:00 [#############################] 100%
 community.sig              438.0   B  0.00   B/s 00:00 [#############################] 100%
:: There are 24 members in group base-devel:
:: Repository core
   1) autoconf  2) automake  3) binutils  4) bison  5) fakeroot  6) file  7) findutils
   8) flex  9) gawk  10) gcc  11) gettext  12) grep  13) groff  14) gzip  15) libtool
   16) m4  17) make  18) pacman  19) patch  20) pkgconf  21) sed  22) sudo  23) texinfo
   24) which

Enter a selection (default=all): 
resolving dependencies...
looking for conflicting packages...

Packages (107) acl-2.2.53-3  archlinux-keyring-20210110-1  attr-2.4.48-3  audit-2.8.5-7
               bash-5.0.018-1  bzip2-1.0.8-3  ca-certificates-20181109-4
               ca-certificates-mozilla-3.57-1  ca-certificates-utils-20181109-4
               coreutils-8.32-1  curl-7.72.0-2  db-5.3.28-5  diffutils-3.7-3
               e2fsprogs-1.45.6-3  elfutils-0.181-1  expat-2.2.9-3  filesystem-2020.09.03-1
               gc-8.0.4-4  gcc-libs-8.4.1-4  gdbm-1.18.1-3  glib2-2.66.1-2  glibc-2.28-8
               gmp-6.2.0-1  gnupg-2.2.23-1  gnutls-3.6.15-1  gpgme-1.14.0-1  guile-2.2.6-2
               iana-etc-20200905-1  icu-67.1-1  keyutils-1.6.3-1  krb5-1.18.2-1  less-563-1
               libarchive-3.4.3-1  libassuan-2.5.4-1  libcap-2.44-1  libcap-ng-0.8-1
               libcroco-0.6.13-2  libelf-0.181-1  libffi-3.3-3  libgcrypt-1.8.7-1
               libgpg-error-1.39-1  libidn2-2.3.0-1  libksba-1.4.0-2  libldap-2.4.53-3
               libmicrohttpd-0.9.71-1  libmpc-1.1.0-2  libnghttp2-1.41.0-1
               libp11-kit-0.23.21-1  libpsl-0.21.1-1  libsasl-2.1.27-3  libseccomp-2.5.0-2
               libsecret-0.20.4-1  libssh2-1.9.0-2  libtasn1-4.16.0-1  libtirpc-1.2.6-1
               libunistring-0.9.10-3  libxcrypt-4.4.17-1  libxml2-2.9.10-2
               linux-api-headers-5.10.32-1  lz4-1:1.9.2-2  mpfr-4.1.0-1  ncurses-6.2-1
               nettle-3.6-1  npth-1.6-2  openssl-1.1.1.h-1  p11-kit-0.23.21-1
               pacman-mirrorlist-20200920-1  pam-1.4.0-3  pambase-20200721.1-2  pcre-8.44-1
               perl-5.32.0-3  pinentry-1.1.0-5  readline-8.0.004-1  shadow-4.8.1-4
               sqlite-3.33.0-2  systemd-libs-246.6-2  tar-1.32-3  tzdata-2020b-2
               util-linux-2.36-4  util-linux-libs-2.36-4  xz-5.2.5-1  zlib-1:1.2.11-4
               zstd-1.4.5-1  autoconf-2.69-7  automake-1.16.2-3  binutils-2.31.1-5
               bison-3.7.2-1  fakeroot-1.25.3-1  file-5.39-1  findutils-4.7.0-2
               flex-2.6.4-3  gawk-5.1.0-1  gcc-8.4.1-4  gettext-0.21-1  grep-3.4-1
               groff-1.22.4-4  gzip-1.10-3  libtool-2.4.6+42+gb88cebd5-14  m4-1.4.18-3
               make-4.3-3  pacman-5.2.2-1  patch-2.7.6-9  pkgconf-1.7.3-1  sed-4.8-1
               sudo-1.9.3.p1-1  texinfo-6.7-3  which-2.21-5

Total Installed Size:  685.93 MiB

:: Proceed with installation? [Y/n] 
(107/107) checking keys in keyring                      [#############################] 100%
(107/107) checking package integrity                    [#############################] 100%
error: linux-api-headers: missing required signature
error: tzdata: missing required signature
error: iana-etc: missing required signature
error: filesystem: missing required signature
error: glibc: missing required signature
error: gcc-libs: missing required signature
error: ncurses: missing required signature
error: readline: missing required signature
error: bash: missing required signature
error: gmp: missing required signature
error: mpfr: missing required signature
error: gawk: missing required signature
error: m4: missing required signature
error: diffutils: missing required signature
error: gdbm: missing required signature
error: db: missing required signature
error: libxcrypt: missing required signature
error: perl: missing required signature
error: autoconf: missing required signature
error: automake: missing required signature
error: zlib: missing required signature
error: bzip2: missing required signature
error: xz: missing required signature
error: libtasn1: missing required signature
error: nettle: missing required signature
error: libffi: missing required signature
error: libp11-kit: missing required signature
error: attr: missing required signature
error: acl: missing required signature
error: libcap: missing required signature
error: openssl: missing required signature
error: coreutils: missing required signature
error: libgpg-error: missing required signature
error: libgcrypt: missing required signature
error: lz4: missing required signature
error: zstd: missing required signature
error: systemd-libs: missing required signature
error: p11-kit: missing required signature
error: libunistring: missing required signature
error: libidn2: missing required signature
error: gnutls: missing required signature
error: libmicrohttpd: missing required signature
error: sqlite: missing required signature
error: expat: missing required signature
error: libarchive: missing required signature
error: findutils: missing required signature
error: ca-certificates-utils: missing required signature
error: ca-certificates-mozilla: missing required signature
error: ca-certificates: missing required signature
error: util-linux-libs: missing required signature
error: e2fsprogs: missing required signature
error: libsasl: missing required signature
error: libldap: missing required signature
error: keyutils: missing required signature
error: krb5: missing required signature
error: libssh2: missing required signature
error: libpsl: missing required signature
error: libnghttp2: missing required signature
error: curl: missing required signature
error: libelf: missing required signature
error: elfutils: missing required signature
error: binutils: missing required signature
error: bison: missing required signature
error: sed: missing required signature
error: libtirpc: missing required signature
error: pambase: missing required signature
error: libcap-ng: missing required signature
error: audit: missing required signature
error: pam: missing required signature
error: shadow: missing required signature
error: libseccomp: missing required signature
error: file: missing required signature
error: util-linux: missing required signature
error: fakeroot: missing required signature
error: flex: missing required signature
error: libmpc: missing required signature
error: gcc: missing required signature
error: pcre: missing required signature
error: glib2: missing required signature
error: icu: missing required signature
error: libxml2: missing required signature
error: libcroco: missing required signature
error: gettext: missing required signature
error: grep: missing required signature
error: groff: missing required signature
error: less: missing required signature
error: gzip: missing required signature
error: tar: missing required signature
error: libtool: missing required signature
error: texinfo: missing required signature
error: gc: missing required signature
error: guile: missing required signature
error: make: missing required signature
error: npth: missing required signature
error: libksba: missing required signature
error: libassuan: missing required signature
error: libsecret: missing required signature
error: pinentry: missing required signature
error: gnupg: missing required signature
error: gpgme: missing required signature
error: pacman-mirrorlist: missing required signature
error: archlinux-keyring: missing required signature
error: pacman: missing required signature
error: patch: missing required signature
error: pkgconf: missing required signature
error: sudo: missing required signature
error: which: missing required signature
error: failed to commit transaction (package missing required signature)
Errors occurred, no packages were upgraded.
==> ERROR: Failed to install packages to new root
==> ERROR: Failed to install all packages
==> ERROR: Aborting...

Last edited by tsuibin (2021-11-25 02:59:46)

Offline

#3 2021-11-25 03:11:46

Scimmia
Fellow
Registered: 2012-09-01
Posts: 8,751

Re: ERROR: '/var/lib/archbuild/extra-loongarch64/root' does not appear to

What in the world is extra-loongarch64?

Online

Board footer

Powered by FluxBB