You are not logged in.

#1 2021-11-16 14:43:51

joanmanel
Member
Registered: 2012-11-06
Posts: 174

Calibre doesn't open, error with sip module and API version

Hi, I cannot open the application "Calibre":

calibre
Traceback (most recent call last):
  File "/usr/bin/calibre", line 21, in <module>
    sys.exit(calibre())
  File "/usr/lib/calibre/calibre/gui_launch.py", line 64, in calibre
    main(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 533, in main
    app, opts, args = init_qt(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 124, in init_qt
    app = Application(args, override_program_name=override, windows_app_uid=MAIN_APP_UID)
  File "/usr/lib/calibre/calibre/gui2/__init__.py", line 894, in __init__
    from calibre_extensions import progress_indicator
RuntimeError: the sip module implements API v12.0 to v12.8 but the progress_indicator module requires API v12.9

I thought it was a bug but it seems it's an error I am having with some libraries?

Offline

#2 2021-11-16 14:56:41

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 25,905
Website

Re: Calibre doesn't open, error with sip module and API version

It looks like you are doing partial upgrades - you have an old version of python-pyqt5-sip.  Update your system.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2021-11-16 16:27:01

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,873

Re: Calibre doesn't open, error with sip module and API version

Either that or, more likely, you have pip-installed stuff which is interfering with system packages.

Offline

#4 2021-11-18 15:07:12

joanmanel
Member
Registered: 2012-11-06
Posts: 174

Re: Calibre doesn't open, error with sip module and API version

Trilby wrote:

It looks like you are doing partial upgrades - you have an old version of python-pyqt5-sip.  Update your system.

My version is 12.9.0-1 which is the last one.

arojas wrote:

Either that or, more likely, you have pip-installed stuff which is interfering with system packages.

How can I check this?

I have seen this similar error googling: https://www.mail-archive.com/debian-bug … 26887.html

No idea if it is related.

Last edited by joanmanel (2021-11-18 15:13:00)

Offline

#5 2021-11-18 15:32:07

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,873

Re: Calibre doesn't open, error with sip module and API version

python -c "import PyQt5.sip as ps; print(ps.__file__)"

Offline

#6 2021-11-18 15:52:24

joanmanel
Member
Registered: 2012-11-06
Posts: 174

Re: Calibre doesn't open, error with sip module and API version

arojas wrote:
python -c "import PyQt5.sip as ps; print(ps.__file__)"

Thank you, you are right. It was installed through pip, I pip uninstalled it and now it works.

Offline

#7 2021-11-25 17:28:14

ignami
Member
Registered: 2016-12-12
Posts: 3

Re: Calibre doesn't open, error with sip module and API version

Actually, I don't get it. I have the same error, which is:

calibre
Traceback (most recent call last):
  File "/usr/bin/calibre", line 21, in <module>
    sys.exit(calibre())
  File "/usr/lib/calibre/calibre/gui_launch.py", line 64, in calibre
    main(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 533, in main
    app, opts, args = init_qt(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 124, in init_qt
    app = Application(args, override_program_name=override, windows_app_uid=MAIN_APP_UID)
  File "/usr/lib/calibre/calibre/gui2/__init__.py", line 894, in __init__
    from calibre_extensions import progress_indicator
RuntimeError: the sip module implements API v12.0 to v12.8 but the progress_indicator module requires API v12.9

But the python-pyqt5-sip package version is:

pacman -Qi python-pyqt5-sip
Nom                      : python-pyqt5-sip
Version                  : 12.9.0-1
Description              : The sip module support for PyQt5
Architecture             : x86_64
URL                      : https://riverbankcomputing.com/software/pyqt/intro
Licences                 : GPL
Groupes                  : --
Fournit                  : --
Dépend de                : python
Dépendances opt.         : --
Requis par               : python-pyqt5
Optionnel pour           : --
Est en conflit avec      : --
Remplace                 : --
Taille installée         : 152.74 KiB
Paqueteur                : Antonio Rojas <arojas@archlinux.org>
Compilé le               : lun 17 mai 2021 08:48:09
Installé le              : lun 17 mai 2021 21:07:26
Motif d’installation     : Installé comme dépendance d’un autre paquet
Script d’installation    : Non
Validé par               : Signature

Which is the up to date archlinux version: https://archlinux.org/packages/extra/x8 … pyqt5-sip/

python -c "import PyQt5.sip as ps; print(ps.__file__)"
/home/igor/.local/lib/python3.9/site-packages/PyQt5/sip.cpython-39-x86_64-linux-gnu.so

Offline

#8 2021-11-25 17:40:29

ignami
Member
Registered: 2016-12-12
Posts: 3

Re: Calibre doesn't open, error with sip module and API version

Sorry, I was searching the wrong package name with pip (python-pyqt5-sip instead of pyqt5-sip). I could effectively uninstall the culprit through pip.

Offline

#9 2021-11-25 17:42:28

progandy
Member
Registered: 2012-05-17
Posts: 4,638

Re: Calibre doesn't open, error with sip module and API version

And your last command reveals that a user-local pip installation of pyqt5-sip is used instead of the system version.
Edit: You solved it.

Last edited by progandy (2021-11-25 17:43:02)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#10 2021-11-25 18:20:22

ignami
Member
Registered: 2016-12-12
Posts: 3

Re: Calibre doesn't open, error with sip module and API version

For the record:

python -c "import PyQt5.sip as ps; print(ps.__file__)"
/usr/lib/python3.9/site-packages/PyQt5/sip.cpython-39-x86_64-linux-gnu.so

Offline

Board footer

Powered by FluxBB