You are not logged in.

#1 2021-11-27 10:11:28

d1s12t
Member
Registered: 2021-09-15
Posts: 2

[SOLVED]Mounting ntfs partition by ntfs3 failed

My kernel version is:

❯ uname -r
5.15.5-arch1-1

I wanted to mount a ntfs partition using ntfs3 driver, so I entered:

❯ sudo mount -t ntfs3 /dev/sdb1 /mnt/Data
mount: /mnt/Data: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error.

I tried to confirm if the driver was loaded:

❯ lsmod | grep ntfs
ntfs3                 274432  0

Then I tried to fix the partition,but I got the same error:

❯ sudo ntfsfix /dev/sdb1
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sdb1 was processed successfully.

❯ sudo mount -t ntfs3 /dev/sdb1 /mnt/Data
mount: /mnt/Data: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error.

Then I mounted the partition without any option:

❯ sudo mount /dev/sdb1 /mnt/Data
❯ mount -l
......
/dev/sdb1 on /mnt/Data type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096) [数据]

As you can see,it drives by ntfs-3g not ntfs3. What can I do?

Last edited by d1s12t (2021-11-28 15:59:53)

Offline

#2 2021-11-27 10:21:34

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 15,031

Re: [SOLVED]Mounting ntfs partition by ntfs3 failed

Check your dmesg for errors with ntfs3. Chances are the volume is still marked dirty, and ntfs3 will not mount a partition where that is the case without the force option. ntfsfix without any arguments will actively set the dirty bit, so that a chkdsk from Windows can do a real check/analysis. If you don't have that handy and want to clear the dirty bit despite ntfsfix not being entirely a good checking tool you can pass the -d argument to ntfsfix.

Offline

#3 2021-11-28 15:50:14

d1s12t
Member
Registered: 2021-09-15
Posts: 2

Re: [SOLVED]Mounting ntfs partition by ntfs3 failed

Thanks! You are right! Just need to enter the follow comands:

sudo ntfsfix -d /dev/sdb1
sudo mount -t ntfs3 /dev/sdb1 /mnt/Data

Last edited by d1s12t (2021-11-28 15:51:01)

Offline

Board footer

Powered by FluxBB