You are not logged in.

#1 2021-11-28 23:08:46

Noki
Member
Registered: 2018-06-08
Posts: 94

[SOLVED] Fresh Install on XPS 15 has wrong keyboard layout in KDE

Hi All, returning to Arch after a while away.

Setting up my XPS 15 and everything is fine except when I am in KDE Plasma my keyboard layout is US not UK as I require.

If I goto the terminal via Ctrl+Alt+F4 and login the keyboard layout is correct.

I used the standard instructions in the Wiki and I am using SDDM and Wayland to load KDE. https://wiki.archlinux.org/title/Installation_guide

Output of: setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     gb
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+gb+inet(evdev)
geometry:   pc(pc105)
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+gb+inet(evdev)"     };
        xkb_geometry  { include "pc(pc105)"     };
};


The content of my /etc/vconsole.conf is just KEYMAP=uk

and the only language I have installed (and viewable in kde settings) is British English.

I don't recall this issue last time I installed and I can't see what step I might have missed that would cause this, especially since the main terminal uses the correct layout.

Any help appreciated.

Thanks,
Noki

SOLUTION

I was missing the layout in KDE under Settings > Input Devices > Keyboard then select the 'Layouts' tab and check the 'Configure layouts' option and then find the English British option. It was so obvious!

Last edited by Noki (2021-11-29 00:28:06)

Offline

Board footer

Powered by FluxBB