You are not logged in.

#1 2021-11-29 01:17:30

joaonunatings
Member
Registered: 2021-10-14
Posts: 22

[SOLVED] YAY - Changing dependency package

I have package mssql-server that needs libldap<=2.4.59.
Right now I have installed libldap 2.6.0-2 but can't downgrade because of other packages.
AUR has package libldap24 which is equivalent to libldap<=2.4.59.

How do I change dependency name of mssql-server from libldap<=2.4.59 to libldap24?

I already did yay --editmenu --save and when I try to install package mssql-server first thing it shows is:

 -> Could not find all required packages:
	mssql-server<=2.4.59 (Wanted by: mssql-server)

EDIT: I changed the packages A, B and C to its real names.

Last edited by joaonunatings (2021-11-29 13:24:25)


Sway on ASUS ZenBook UX434DA-UM433DA: AMD Ryzen 7 3700U with Radeon Vega Mobile Gfx, 16GB RAM, Samsung MZVLB1T0HALR-1TB SSD, Keychron K12 with Banana Switches Keyboard

Offline

#2 2021-11-29 02:57:25

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 26,195
Website

Re: [SOLVED] YAY - Changing dependency package

Why are you deliberately obscuring information?  What are A, B, and C?  Why do you think C is "equivalent" to Bv1?  If it is, it would list Bv1 in it's 'provides' array and you would not face this problem.

As for the solution, just edit the PKGBUILD, and stop relying on an aur helper.  Failing that, ask for help on the yay github page for yay-specific issues as is requested by the yay maintainer.

Last edited by Trilby (2021-11-29 02:57:45)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2021-11-29 13:23:30

joaonunatings
Member
Registered: 2021-10-14
Posts: 22

Re: [SOLVED] YAY - Changing dependency package

Solved by getting PKGBUILD.

yay -G mssql-server
cd mssql-server/

Edit PKGBUILD: change 'libldap<=2.4.59' to libldap24.

 makepkg -si

Don't forget to update mssql-server this way while it's dependency is not updated to recent one.

Last edited by joaonunatings (2021-11-29 13:23:58)


Sway on ASUS ZenBook UX434DA-UM433DA: AMD Ryzen 7 3700U with Radeon Vega Mobile Gfx, 16GB RAM, Samsung MZVLB1T0HALR-1TB SSD, Keychron K12 with Banana Switches Keyboard

Offline

#4 2021-11-29 14:11:54

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 26,195
Website

Re: [SOLVED] YAY - Changing dependency package

The proper long-term solution would be to request the maintainer of libldap24 to add a 'provides' line in their PKGBUILD.  As that AUR package is maintained by an active arch developer, I suspect they would respond to such a request ... either by implementing it, or providing good reason why it should not be done.

Last edited by Trilby (2021-11-29 14:14:22)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#5 2021-11-29 18:02:24

joaonunatings
Member
Registered: 2021-10-14
Posts: 22

Re: [SOLVED] YAY - Changing dependency package

I agree, I did your solution instead.
I also asked maintainer to add provides.
https://aur.archlinux.org/packages/libl … ent-838343

Last edited by joaonunatings (2021-11-29 18:04:30)


Sway on ASUS ZenBook UX434DA-UM433DA: AMD Ryzen 7 3700U with Radeon Vega Mobile Gfx, 16GB RAM, Samsung MZVLB1T0HALR-1TB SSD, Keychron K12 with Banana Switches Keyboard

Offline

Board footer

Powered by FluxBB