You are not logged in.

#1 2021-11-29 21:38:34

phraktal
Member
Registered: 2015-03-15
Posts: 13

[SOLVED] Unable to boot into OS after installation. nvme not visible.

I've installed the OS as I've done many times before, this time on a new computer (Dell XPS 9510).
The installation media booted fine and the process was fairly straight forward.
After installation, when I tried to boot into the OS I'm getting:

https://ibb.co/WVm3V1B
-----
Waiting 10 seconds for device /dev/nvme0n1p7
Error: Device '/dev/nvme0n1p7' not found. Skipping fsck.
:: mounting '/dev/nvme0n1p7' on real root
mount: /new_root: not filesystem type specified
You are now being dropped into emergency shell.
-----

Once I get dropped into emergency shell, I can see that the nvme stuff is missing from /dev

Installation media boots fine and sees the nvme devices.

Anyone has an idea how to correct this ?

Last edited by phraktal (2021-11-29 22:42:45)

Offline

#2 2021-11-29 21:47:05

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 4,866

Re: [SOLVED] Unable to boot into OS after installation. nvme not visible.

Known bug.

Try either making sure that your drive is set to AHCI mode in your firmware menu or adding the vmd hook to your initramfs.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#3 2021-11-29 22:41:52

phraktal
Member
Registered: 2015-03-15
Posts: 13

Re: [SOLVED] Unable to boot into OS after installation. nvme not visible.

Thank you Slithery,  your post led me to a solution.

Just for posterity, vdm is not a hook but a module, as you have stated in an older post here: https://bbs.archlinux.org/viewtopic.php?id=269731

FYI, I'm using the vmd solution as this machine is a dual boot with windows 11 on it. I've tried switching to AHCI mode but that prevents Windows 11 from booting.

Anyways, thank you for your support.

Offline

#4 2021-11-29 22:53:34

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 4,866

Re: [SOLVED] Unable to boot into OS after installation. nvme not visible.

phraktal wrote:

Just for posterity, vdm is not a hook but a module

Oops, my mistake. Am busy at work at the moment and was typing from memory.
You are correct smile


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

Board footer

Powered by FluxBB