You are not logged in.

#1 2021-12-20 20:17:16

jmandawg
Member
Registered: 2011-10-19
Posts: 36

[Solved] Gaming mouse no longer works after latest update

My gaming mouse "Holtek Semiconductor, Inc. USB Gaming Mouse" no longer works after the latest update, my generic HP mouse works fine though.

It's shows in lsusb

$ lsusb
Bus 002 Device 003: ID 0bda:0415 Realtek Semiconductor Corp. 2-Port USB 3.0 Hub
Bus 002 Device 004: ID 1058:25a3 Western Digital Technologies, Inc. Elements Desktop (WDBWLG)
Bus 002 Device 002: ID 0bda:0411 Realtek Semiconductor Corp. Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 03f0:2c24 HP, Inc Logitech M-UAL-96 Mouse
Bus 001 Device 004: ID 0bda:5415 Realtek Semiconductor Corp. 2-Port USB 2.0 Hub
Bus 001 Device 006: ID 0951:16d2 Kingston Technology HX-KB4BL1-US [HYPERX Alloy FPS Pro]
Bus 001 Device 005: ID 04d9:a070 Holtek Semiconductor, Inc. USB Gaming Mouse
Bus 001 Device 003: ID 05e3:0610 Genesys Logic, Inc. Hub
Bus 001 Device 002: ID 0bda:5411 Realtek Semiconductor Corp. RTS5411 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

xinput does not show it:

$ xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Kingston HyperX Alloy FPS Pro Mechanical Gaming Keyboard Consumer Control	id=10	[slave  pointer  (2)]
⎜   ↳ HP HP USB Laser Mouse                   	id=12	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Kingston HyperX Alloy FPS Pro Mechanical Gaming Keyboard	id=9	[slave  keyboard (3)]
    ↳ Kingston HyperX Alloy FPS Pro Mechanical Gaming Keyboard	id=11	[slave  keyboard (3)]
    ↳ Dell WMI hotkeys                        	id=13	[slave  keyboard (3)]
    ↳ Kingston HyperX Alloy FPS Pro Mechanical Gaming Keyboard Consumer Control	id=14	[slave  keyboard (3)]

Here's what was updated today:

[2021-12-20T14:17:58-0500] [PACMAN] Running 'pacman -Syu'¬
[2021-12-20T14:17:58-0500] [PACMAN] synchronizing package lists¬
[2021-12-20T14:17:59-0500] [PACMAN] starting full system upgrade¬
[2021-12-20T14:18:32-0500] [ALPM] running '60-mkinitcpio-remove.hook'...¬
[2021-12-20T14:18:32-0500] [ALPM] transaction started¬
[2021-12-20T14:18:32-0500] [ALPM] upgraded alsa-ucm-conf (1.2.6.2-2 -> 1.2.6.3-1)¬
[2021-12-20T14:18:32-0500] [ALPM] upgraded boost-libs (1.76.0-6 -> 1.78.0-1)¬
[2021-12-20T14:18:33-0500] [ALPM] upgraded openssl (1.1.1.l-1 -> 1.1.1.m-1)¬
[2021-12-20T14:18:33-0500] [ALPM] upgraded libxcrypt (4.4.26-1 -> 4.4.27-1)¬
[2021-12-20T14:18:33-0500] [ALPM] upgraded nspr (4.32-1 -> 4.33-1)¬
[2021-12-20T14:18:33-0500] [ALPM] upgraded ceph-libs (15.2.14-4 -> 15.2.14-5)¬
[2021-12-20T14:18:33-0500] [ALPM] upgraded fontconfig (2:2.13.94-1 -> 2:2.13.94-2)¬
[2021-12-20T14:18:33-0500] [ALPM-SCRIPTLET] Rebuilding fontconfig cache...¬
[2021-12-20T14:18:38-0500] [ALPM] upgraded librsvg (2:2.52.4-1 -> 2:2.52.5-1)¬
[2021-12-20T14:18:38-0500] [ALPM] upgraded sdl2 (2.0.18-1 -> 2.0.18-2)¬
[2021-12-20T14:18:39-0500] [ALPM] upgraded firefox (95.0.1-1 -> 95.0.2-1)¬
[2021-12-20T14:18:39-0500] [ALPM] upgraded imagemagick (7.1.0.17-1 -> 7.1.0.18-1)¬
[2021-12-20T14:18:40-0500] [ALPM] warning: directory permissions differ on /usr/share/hplip/base/pexpect/__pycache__/¬
filesystem: 777  package: 755¬
[2021-12-20T14:18:40-0500] [ALPM] warning: directory permissions differ on /usr/share/hplip/fax/__pycache__/¬
filesystem: 740  package: 755¬
[2021-12-20T14:18:40-0500] [ALPM] warning: directory permissions differ on /usr/share/hplip/installer/__pycache__/¬
filesystem: 740  package: 755¬
[2021-12-20T14:18:40-0500] [ALPM] warning: directory permissions differ on /usr/share/hplip/prnt/__pycache__/¬
filesystem: 777  package: 755¬
[2021-12-20T14:18:40-0500] [ALPM] upgraded hplip (1:3.21.10-2 -> 1:3.21.12-1)¬
[2021-12-20T14:18:40-0500] [ALPM] upgraded imath (3.1.3-3 -> 3.1.3-4)¬
[2021-12-20T14:18:40-0500] [ALPM] upgraded lib32-libxcrypt (4.4.26-1 -> 4.4.27-1)¬
[2021-12-20T14:18:40-0500] [ALPM] upgraded lib32-nspr (4.32-1 -> 4.33-1)¬
[2021-12-20T14:18:40-0500] [ALPM] upgraded lib32-openssl (1:1.1.1.l-1 -> 1:1.1.1.m-1)¬
[2021-12-20T14:18:42-0500] [ALPM] upgraded linux (5.15.8.arch1-1 -> 5.15.10.arch1-1)¬
[2021-12-20T14:18:47-0500] [ALPM] upgraded linux-headers (5.15.8.arch1-1 -> 5.15.10.arch1-1)¬
[2021-12-20T14:18:47-0500] [ALPM] upgraded nano (5.9-1 -> 6.0-1)¬
[2021-12-20T14:18:47-0500] [ALPM] upgraded ndctl (71.1-1 -> 72-1)¬
[2021-12-20T14:18:47-0500] [ALPM] upgraded nodejs (17.2.0-1 -> 17.3.0-1)¬                                                                  
[2021-12-20T14:18:47-0500] [ALPM] installed qt5-translations (5.15.2+kde+r20-2)¬
[2021-12-20T14:18:48-0500] [ALPM] upgraded qt5-base (5.15.2+kde+r263-1 -> 5.15.2+kde+r263-2)¬
[2021-12-20T14:18:48-0500] [ALPM] transaction completed¬

Udev does pick it up:

UDEV  [658.127869] bind     /devices/pci0000:00/0000:00:15.0/usb1/1-3/1-3.1 (usb)
ACTION=bind
DEVPATH=/devices/pci0000:00/0000:00:15.0/usb1/1-3/1-3.1
SUBSYSTEM=usb
DEVNAME=/dev/bus/usb/001/008
DEVTYPE=usb_device
DRIVER=usb
PRODUCT=4d9/a070/104
TYPE=0/0/0
BUSNUM=001
DEVNUM=008
SEQNUM=4588
USEC_INITIALIZED=658103569
ID_VENDOR=Sun_Sonny
ID_VENDOR_ENC=Sun\x20Sonny
ID_VENDOR_ID=04d9
ID_MODEL=USB_Gaming_Mouse
ID_MODEL_ENC=USB\x20Gaming\x20Mouse
ID_MODEL_ID=a070
ID_REVISION=0104
ID_SERIAL=Sun_Sonny_USB_Gaming_Mouse
ID_BUS=usb
ID_USB_INTERFACES=:030101:030002:030000:
ID_VENDOR_FROM_DATABASE=Holtek Semiconductor, Inc.
ID_PATH=pci-0000:00:15.0-usb-0:3.1
ID_PATH_TAG=pci-0000_00_15_0-usb-0_3_1
ID_FOR_SEAT=usb-pci-0000_00_15_0-usb-0_3_1
MAJOR=189
MINOR=7
TAGS=:seat:
CURRENT_TAGS=:seat:

Nothing about this mouse shows up in the xorg logs or dmesg.

Last edited by jmandawg (2021-12-20 21:16:28)

Offline

#2 2021-12-20 20:24:51

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,195

Re: [Solved] Gaming mouse no longer works after latest update

Does downgrading the kernel make it work again?

Offline

#3 2021-12-20 20:28:16

loqs
Member
Registered: 2014-03-06
Posts: 14,439

Re: [Solved] Gaming mouse no longer works after latest update

Offline

#4 2021-12-20 20:40:36

jmandawg
Member
Registered: 2011-10-19
Posts: 36

Re: [Solved] Gaming mouse no longer works after latest update

Thanks loqs, i just tested your patched kernel and it fixes the issue.

Offline

Board footer

Powered by FluxBB