You are not logged in.

#1 2021-12-20 23:26:58

ib
Member
Registered: 2021-12-11
Posts: 21

[SOLVED[ installing jsoncpp (1.9.5-1) breaks dependency 'libjsoncpp.so

i get error:

installing jsoncpp (1.9.5-1) breaks dependency 'libjsoncpp.so=24-64' required by libopenshot

I don't understand what I did wrong, because everything is from the official repositories

Last edited by ib (2021-12-22 23:21:05)

Offline

#2 2021-12-21 04:59:06

progandy
Member
Registered: 2012-05-17
Posts: 4,766

Re: [SOLVED[ installing jsoncpp (1.9.5-1) breaks dependency 'libjsoncpp.so

Maybe you tried to do a partial upgrade which is unsupported. In that case just perform a full system upgrade (pacman -Syu)

Otherwise maybe your mirror is not completely synchronized. In that case try it later or change the mirror.


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#3 2021-12-21 09:23:13

icar
Member
From: Catalunya
Registered: 2020-07-31
Posts: 264

Re: [SOLVED[ installing jsoncpp (1.9.5-1) breaks dependency 'libjsoncpp.so

That happened yesterday, and it wasn't because of a mirror not fully synced nor because of partial upgrades. I have the testing repositories enabled, and it happened as well.

This morning, I woke up and the issue was resolved.

Last edited by icar (2021-12-21 09:23:39)

Offline

#4 2021-12-21 10:15:35

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 1,081

Re: [SOLVED[ installing jsoncpp (1.9.5-1) breaks dependency 'libjsoncpp.so

It was because an soname bump was needed - and it was fixed with a new cmake version quite a short time after it was first reported - and fixed - just needed to wait for mirrors to update and all was fine.


Mike C

Offline

#5 2021-12-22 23:21:23

ib
Member
Registered: 2021-12-11
Posts: 21

Re: [SOLVED[ installing jsoncpp (1.9.5-1) breaks dependency 'libjsoncpp.so

Everything has already started working today

Offline

Board footer

Powered by FluxBB