You are not logged in.

#1 2021-12-28 01:09:34

James80
Member
Registered: 2021-01-11
Posts: 7

Problem with LANG (locale)

Hi,

when I build an image from openwrt firmware, everything is ok except I get an error about ''locale'' when I make the setup.

perl: warning: Please check that your locale settings: LANGUAGE = "", LC_ALL = (unset),

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "",
	LC_ALL = (unset),
	LANG = "fr_CA.UTF-8"

Here, I see that:

$ locale                                                           (12-27 19:36)
LANG=en_CA.UTF-8
LC_CTYPE="en_CA.UTF-8"
LC_NUMERIC="en_CA.UTF-8"
LC_TIME="en_CA.UTF-8"
LC_COLLATE="en_CA.UTF-8"
LC_MONETARY="en_CA.UTF-8"
LC_MESSAGES="en_CA.UTF-8"
LC_PAPER="en_CA.UTF-8"
LC_NAME="en_CA.UTF-8"
LC_ADDRESS="en_CA.UTF-8"
LC_TELEPHONE="en_CA.UTF-8"
LC_MEASUREMENT="en_CA.UTF-8"
LC_IDENTIFICATION="en_CA.UTF-8"
LC_ALL=

I guess the last one (LC_ALL=) is the problem, but I can't find where change it, I tried somethings but I really don't know now.
thanks

Offline

#2 2021-12-28 01:44:05

twobooks
Member
From: rainforest
Registered: 2020-06-23
Posts: 42

Re: Problem with LANG (locale)

I would insert a line below into /etc/environment,
LC_ALL=en_CA.UTF-8

Offline

#3 2021-12-28 01:48:28

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 15,069

Re: Problem with LANG (locale)

No. LC_ALL= is a debugging emergency option, do not set it globally. If it was just a one off issue then it looks like whatever script you actually ran set it's local environment incorrectly. Your locale output is fine and as it needs to be. What's the exact command/context under which you see that error message?

Online

Board footer

Powered by FluxBB