You are not logged in.

#1 2021-12-28 11:16:09

bearingtheseeds
Member
Registered: 2020-02-06
Posts: 1

System won't resume properly from suspend

My system won't respond from suspend. This hasn't been an issue in the past, I have switched between Arch and Fedora for about 2 years on the computer. Recently I switched from Fedora 35 to Arch, and it won't resume from suspend (kind of).

So from the logs it looks like it does actually resume, however the displays show nothing. They turn on and the backlight shows, however they remain black.

I have tried to switch to a TTY but nothing happens.

My GPU is an Nvidia 2080 Super, I'm using the nvidia-dkms driver (have also tried nvidia and nvidia-lts) and have tried the linux and linux-lts kernels.

Here are the logs from

journalctl -p3 -b-1

Ignore all the crap about logitech-djreceiver, that's something about my mouse that I haven't got around to sorting out. The system resumed Dec 28 at 10:50 (the last 4 lines of the log).

https://zerobin.net/?96188a6999f77ee0#p … MChjzScpw=

I wonder if this explains part of the issue, though it's not just GDM as I can't switch to a TTY:

gdm[1530]: GLib: Source ID 120 was not found when attempting to remove it

If anyone has any ideas on how to fix this it would be much appreciated!

Offline

#2 2021-12-28 13:50:54

seth
Member
Registered: 2012-09-03
Posts: 26,449

Re: System won't resume properly from suspend

https://download.nvidia.com/XFree86/Lin … ement.html

But it would be better to see the entire journal (or at least the unfiltered tail around the resume)

Offline

Board footer

Powered by FluxBB