You are not logged in.

#1 2021-12-30 03:07:43

Registered: 2021-12-18
Posts: 2

Motu M2 - Jack2 - Nvidia: Random robotic / distorted microphone input

Hello Arch Community,

TL;DR: Since October this year, a new problem appeared: The input of my microphone attached to the motu m2 audio interface is distorted at random throughout sessions. This did not happen before and I use the same audio setup for a whole year now (motu m2 with jack2 and pulseaudio-jack). Sometimes it is distorded for only a couple seconds, other times it lasts up to a couple of minutes. On some occasions I got Xruns but most of the time the robotic voice appears without any previous Xruns. I spent the last 3 weeks to narrow down the source of the problem and came to the conclusion, that it has something to do with the proprietary nvidia driver. Because I also use this computer to play video games, I still want to use the proprietary nvidia driver.

Here is a sample of the distortion:

Here are the steps I took to so far, in case someone else has another idea or has a similar issue:

What I tried so far:
  • Use direct hardware monitoring from the motu m2 -> no robotic voice noticeable

  • Use monitoring through jack2 (connecting input to output) -> This is how I identify the issue w/o help from peers

  • Update all packages to the most recent verisons -> same issue

  • Changed anything hardware related:
      + Microphone, XLR Cable/Port, USB-C Cable/Port -> same issue

  • Tried the interface on windows -> Issue did not arise on windows...

  • Switched kernel from linux to linux-zen (nvidia-dkms) -> same issue

  • Uninstalled all sound related packages:
      + jack2, pulseaudio, jack2-dbus, qjackctl, pulseaudia-jack, pulseaudio-alsa, ... and switched over to pipewire -> same issue

  • Reinstalled the jack2 setup -> same issue

  • Only used Firefox instead of qutebrowser (because it often happened when using webrtc in qutebrowser (qt-webengine)) -> same issue

  • Downgraded everything involved to versions bf. October -> same issue
      + jack2, jack2-dbus, pulseaudio, mumble

  • Reinstalled my whole system -> same issue

  • I used the interface on my laptop which has the same setup as my computer same kernel, versions of programs, etc. -> Issue did not arise on the laptop

Observations after clean install:
After the reinstall everything was fine till I opened jitsi inside of qutebrowser I instantly got the robo voice again... After that, it also appeared when I opened steam.

After I quit steam, it instantly stopped...

It seems to always start after I use jitsi...

While playing a demanding game, e.g. Rocket League (Proton), Deep Rock Galactic (Proton) the robotic voice is completely gone. After I stop playing, it starts appearing again.

Trying out nouveau driver instead of nvidia

-> Installed nouveau driver according to the wiki page.

Tested the setup with the nouveau driver for the whole day and the robotic voice did not appear at all.

It seems like that it was the proprietary nvidia driver... mad

Trying to downgrade the nvidia driver to another version

(It currently is 495.46)

Not working:

  • 470.74 # robotic voice again (dkms)

  • 455.28 # to old at least for dkms with the latest zen-kernel version

  • 455.45.01 # to old at least for dkms with the latest zen-kernel version

  • 460.39 # to old at least for dkms with the latest zen-kernel version

  • 465.31 # to old at least for dkms with the latest zen-kernel version

  • 470.57.02 # to old at least for dkms with the latest zen-kernel version


Testing with default kernel (linux) and default driver (nvidia)

Not working:
All versions except 495.46-5 (Older versions were incompatible with X Server ABI)

none (Without robotic voice)

The nvidia website even states, that the recommended driver for my card is:

Version:	470.94
Release Date:	2021.12.13
Operating System:	Linux 64-bit
Language:	English (US)
File Size:	259.65 MB … 4163/en-us

Can anyone help me find a solution, where I can still use the proprietary nvidia driver without having to deal with the robotic voice (which is super annoying for others in voicechat and meetings).

I primarily want to keep the nvidia driver because of the working power control and better gaming performance (since I solely use linux, I really want to be able to play some games there as well)

If I should post any logs or output of commands I am happy to provide anything that could help.

Thanks for reading through this!! smile

Last edited by phga (2021-12-30 17:08:15)


#2 2022-05-05 14:25:36

Registered: 2022-05-05
Posts: 1

Re: Motu M2 - Jack2 - Nvidia: Random robotic / distorted microphone input


I noticed recently that I have the same issue.
Motu m2 and prop nvidia driver.
I don' know when it started or what triggers it, but I  know that it happens only only video calls (zoom, teams, google meet)
and not when I record my self through audacity.

If you have found a solution please share!!

A potential fix that I found is going to the configuration tab on pavucontrol and changing the profile
for M2 from Digital Stereo Duplex to Analog Stereo Duplex. That seems to fix it... for now. I ll keep an eye on it.


#3 2022-05-05 21:52:21

Registered: 2021-12-18
Posts: 2

Re: Motu M2 - Jack2 - Nvidia: Random robotic / distorted microphone input

Hey mtsap,

a couple updates ago, it seems like, the issue resolved itself. At least the people I talk to online no longer complain about the robotic voice.
Since I did not even use pulse in one of the troubleshooting configurations and I also tried every pulse profile that was viable for the Motu M2 prior to posting, I don't think it would have worked for me.
Still great, that you shared another possible solution that might work for others though!!


Board footer

Powered by FluxBB