You are not logged in.

#1 2021-12-24 00:48:23

PrussianDoge
Member
Registered: 2021-11-26
Posts: 10

Cannot move mouse when pressing key

Don't know much that I can give at the moment but all I really know is that if i press a key i cannot move my mouse. If its an arrow key, I can move it only.
Model: Sony Vaio: VGN-FW560F
I guess its some software Sony implemented that isn't supported with linux(?)

Last edited by PrussianDoge (2021-12-24 00:49:36)

Offline

#2 2021-12-24 01:30:08

Lilitu-Blackstar
Member
Registered: 2021-12-23
Posts: 51

Re: Cannot move mouse when pressing key

i have same issue with dell g5 its a firmware thing on my side, on a design intention. can't change it here either

Offline

#3 2021-12-30 23:01:43

csmnn
Member
Registered: 2017-05-10
Posts: 5

Re: Cannot move mouse when pressing key

Are you talking about an external mouse or your touchpad?

For touchpads, this is a feature enabled by default in libinput, so you don't accidentally move your mouse while typing.
You might be able to change this behavior using xinput (assuming you are using Xorg):

$ xinput
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ SYNA2393:00 06CB:7A13 Touchpad          	id=15	[slave  pointer  (2)]

# List the props of the touchpad (using the device-ID (15 in my case)):
$ xinput list-props 15
Device 'SYNA2393:00 06CB:7A13 Touchpad':
	Device Enabled (183):	1
...
	libinput Disable While Typing Enabled (353):	1
	libinput Disable While Typing Enabled Default (354):	1
...

# Disable the feature (using the device ID and the prop ID):
$ xinput set-prop 15 353 0

This output is abbreviated. You'll see way more devices and props. Your IDs will most likely be different.
I'm sure, there is an alternative in wayland as well.

(Can't help if it is an external mouse though...)

Offline

#4 2021-12-31 10:43:51

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,195

Re: Cannot move mouse when pressing key

csmnn wrote:

I'm sure, there is an alternative in wayland as well.

Configuration under Wayland is dependent on the options offered by the compositor. For example sway uses the methods described in sway-input(5). Unfortunately it doesn't look like there's an option to keep the touchpad enabled while typing for that but it might be added if a feature request is opened upstream.

GNOME offers this option in the gnome-tweaks package under the "Keyboard & Mouse" tab. Or run

gsettings set org.gnome.desktop.peripherals.touchpad disable-while-typing false

Online

Board footer

Powered by FluxBB