You are not logged in.

#1 2022-01-11 16:57:01

case_gage
Member
Registered: 2021-12-12
Posts: 15

[SOLVED] packet tracer willnot build package

hey all,
I'm trying to build pakettracer, and it fails to build the package. I run the following comma

makepkg -sri

and return the following:

==> Making package: packettracer 8.1.0-1 (Tue 11 Jan 2022 10:48:23 AM EST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
==> ERROR: CiscoPacketTracer_810_Ubuntu_64bit.deb was not found in the build directory and is not a URL.

so I went ahead and updated the URL for ubuntu under the PKGBUILD file. I replaced the URL for the ubuntu file with the following:

https://www.netacad.com/portal/resource … 23d5771574

this is the current link provided for ubuntu that the line in the PKGBUILD file was calling for. This can be verified on: https://www.netacad.com/portal/resources/packet-tracer. I did have to log in with a cisco account though.

now when I make my makepklg -sri command i return the following lines for error:

==> Validating source files with sha512sums...
    71b29477-0abb-4a52-97eb-cc23d5771574 ... FAILED
    packettracer.sh ... Passed
==> ERROR: One or more files did not pass the validity check!

it appears as though i don't have the correct sha512sums. how can i get them? btw, I'm working with the 8.1.0 version.

Last edited by case_gage (2022-01-12 01:42:22)

Offline

#2 2022-01-11 16:59:03

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,222

Re: [SOLVED] packet tracer willnot build package

Did you read the instructions in the pinned comment on the AUR page?

Online

#3 2022-01-11 17:06:06

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,257

Re: [SOLVED] packet tracer willnot build package

Moving to 'AUR Issues'.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#4 2022-01-11 23:42:39

case_gage
Member
Registered: 2021-12-12
Posts: 15

Re: [SOLVED] packet tracer willnot build package

Scimmia wrote:

Did you read the instructions in the pinned comment on the AUR page?


Yes I have, but I didn't see a solution. I did find the following which cited similar issues:

panagiss commented on 2021-10-10 20:45   

Error when trying to build packettracer (10/10/2021)

Building packettracer...
==> Making package: packettracer 8.0.1-1 (Κυρ 10 Οκτ 2021 11:44:21 μμ EEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
==> ERROR: CiscoPacketTracer_801_Ubuntu_64bit.deb was not found in the build directory and is not a URL.
Failed to build packettracer

This looks like it might be a solution, but I don't run Gnome. I'm using xfce.
GraysonPeddie commented on 2021-07-25 22:55   

@erylflynn Add or modify the .desktop file for cisco-pt,desktop:

grayson@grayson-epcotcenter
  ~
$ cat .local/share/applications/cisco-pt.desktop
[Desktop Entry]
Type=Application
Exec=XDG_CURRENT_DESKTOP=GNOME /opt/packettracer/packettracer %f
Name=Packet Tracer 8.0.0
Icon=/opt/packettracer/art/app.png
Terminal=false
StartupNotify=true
MimeType=application/x-pkt;application/x-pka;application/x-pkz;

Categories=Application;Network;

Add XDG_CURRENT_DESKTOP=GNOME to ExecStart= before /opt/packettracer/packettracer %f and that should solve the problem unless you open Packet Tracer in GNOME desktop.

Can I just replace Gnome with whatever desktop I have? Also, and I am brand new to linux in general, but I haven't even gotten it to install. this doesn't seem to be the appropriate fix for validation issues.

Offline

#5 2022-01-11 23:56:55

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,222

Re: [SOLVED] packet tracer willnot build package

The pinned comment told you to download the source. This has nothing to do with the .desktop file, or GNOME or XFCE or anything.

Online

#6 2022-01-11 23:59:52

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,257

Re: [SOLVED] packet tracer willnot build package

case_gage wrote:

so I went ahead and updated the URL for ubuntu under the PKGBUILD file. I replaced the URL for the ubuntu file with the following:

https://www.netacad.com/portal/resource … 23d5771574

Where did you get that idea from? You need to actually download the CiscoPacketTracer_801_Ubuntu_64bit.deb file and place it in the build directory, just as the instructions on the AUR page you've supposedly read tells you to.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#7 2022-01-12 00:29:00

case_gage
Member
Registered: 2021-12-12
Posts: 15

Re: [SOLVED] packet tracer willnot build package

Slithery wrote:
case_gage wrote:

so I went ahead and updated the URL for ubuntu under the PKGBUILD file. I replaced the URL for the ubuntu file with the following:

https://www.netacad.com/portal/resource … 23d5771574

Where did you get that idea from? You need to actually download the CiscoPacketTracer_801_Ubuntu_64bit.deb file and place it in the build directory, just as the instructions on the AUR page you've supposedly read tells you to.

Well, I came up with this error:

==> ERROR: CiscoPacketTracer_801_Ubuntu_64bit.deb was not found in the build directory and is not a URL.

so, I went to the PKGBUILD file and I changes this line because the link for the download had this URL when I hovered over it. So I figured if I found this line and changed the URL I would resolve the issue. I did not try to change the line prior to the first installation.

Offline

#8 2022-01-12 00:54:18

loqs
Member
Registered: 2014-03-06
Posts: 14,714

Re: [SOLVED] packet tracer willnot build package

Can you reproduce this locally?

file 71b29477-0abb-4a52-97eb-cc23d5771574
HTML document, Unicode text, UTF-8 text, with very long lines (5819)

If you can the file downloaded was the web login / redirection page.  The PKGBUILD does not contain a download link because you are required to login.  After you obtained the .deb using your web browser and placed that in the same directory as the PKGBUILD,  makepkg will use that file without you having to make changes to the PKGBUILD.

Offline

#9 2022-01-12 01:41:49

case_gage
Member
Registered: 2021-12-12
Posts: 15

Re: [SOLVED] packet tracer willnot build package

loqs wrote:

Can you reproduce this locally?

file 71b29477-0abb-4a52-97eb-cc23d5771574
HTML document, Unicode text, UTF-8 text, with very long lines (5819)

If you can the file downloaded was the web login / redirection page.  The PKGBUILD does not contain a download link because you are required to login.  After you obtained the .deb using your web browser and placed that in the same directory as the PKGBUILD,  makepkg will use that file without you having to make changes to the PKGBUILD.

looking back over this thread I think it was referenced before, and it was in fact my problem. ArchWiki says to place the .deb file in the packettracer/ folder and i mistook the error as a reference to pointing to the wrong point of down load. thanks for all your help.

Offline

Board footer

Powered by FluxBB