You are not logged in.

#1 2022-01-10 04:50:22

kashishme
Member
Registered: 2021-01-08
Posts: 81

[SOLVED]Proton games crashing (again)

After long time i got back to gaming and apparantly proton games ain't working. I tried mirror's edge catalyst and warframe and both of them were working before now they won't. Last time it was due to no swap partition but now i have no clue, even

sudo dmesg

won't show anything although here is the log for mirror's edge catalyst: http://ix.io/3LJr

btw the games start running and suddenly just crash without any warning or errors.

Also i tried changing the proton version, but it doesn't work either.

Let me know if any other details are required.

p.s. i am using lts kernel

Last edited by kashishme (2022-01-12 05:35:14)

Online

#2 2022-01-10 08:26:19

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 15,069

Re: [SOLVED]Proton games crashing (again)

What's your actual hardware? Can you define "start running"? Do you actually get ingame and it eventually crashes during playing? If you already have to fall back to swap it's plain very likely you lack the general resources for this, how much RAM and which graphics card? Did you check how much RAM/VRAM was being used during runtime.

Offline

#3 2022-01-10 08:30:48

kashishme
Member
Registered: 2021-01-08
Posts: 81

Re: [SOLVED]Proton games crashing (again)

V1del wrote:

What's your actual hardware? Can you define "start running"? Do you actually get ingame and it eventually crashes during playing? If you already have to fall back to swap it's plain very likely you lack the general resources for this, how much RAM and which graphics card? Did you check how much RAM/VRAM was being used during runtime.

i have a dell g3 3590 with nvidia 1650ti.

by start running i mean that steam shows 'preaparing to launch' and then nothing happens it just stops even steam shows it not running. i mentioned in my post that everything was working fine before i just stopped gaming due to college work and now it won't work and i saw htop and the ram usage doesn't even flick, the game doesn't start at all

Online

#4 2022-01-10 08:39:43

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 15,069

Re: [SOLVED]Proton games crashing (again)

Does vulkan in general work?

pacman -Qs nvidia
glxinfo -B
glxinfo32 -B
vulkaninfo --summary

Offline

#5 2022-01-10 08:47:41

kashishme
Member
Registered: 2021-01-08
Posts: 81

Re: [SOLVED]Proton games crashing (again)

V1del wrote:

Does vulkan in general work?

pacman -Qs nvidia
glxinfo -B
glxinfo32 -B
vulkaninfo --summary
glxinfo32 -B 

somehow this command is invalid but everything else seems to work fine

Online

#6 2022-01-10 09:11:02

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 15,069

Re: [SOLVED]Proton games crashing (again)

that would be from lib32-mesa-utils. Can you actually post the outputs? If they are indeed correct then sometimes there is a problem with the shader cache especially after driver updates, you can try disabling/rebuilding that in the Steam Settings -> Shader Pre-Cache

Offline

#7 2022-01-10 09:18:03

kashishme
Member
Registered: 2021-01-08
Posts: 81

Re: [SOLVED]Proton games crashing (again)

V1del wrote:

that would be from lib32-mesa-utils. Can you actually post the outputs? If they are indeed correct then sometimes there is a problem with the shader cache especially after driver updates, you can try disabling/rebuilding that in the Steam Settings -> Shader Pre-Cache

here is 'glxinfo -B': http://ix.io/3LKj
glxinfo32 -B: http://ix.io/3LKj
pacman -Qs nvidia: http://ix.io/3LKk
vulkaninfo --summary: http://ix.io/3LKl

Online

#8 2022-01-10 09:25:52

kashishme
Member
Registered: 2021-01-08
Posts: 81

Re: [SOLVED]Proton games crashing (again)

V1del wrote:

that would be from lib32-mesa-utils. Can you actually post the outputs? If they are indeed correct then sometimes there is a problem with the shader cache especially after driver updates, you can try disabling/rebuilding that in the Steam Settings -> Shader Pre-Cache

also the shader precache rebuilding/disabling didn't work.

Online

#9 2022-01-10 12:07:45

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,795

Re: [SOLVED]Proton games crashing (again)

The glxinfo output indicates you have an intel gpu and a nvidia one.

VK_LAYER_AMD_switchable_graphics_32 AMD switchable graphics layer 1.2.201  version 1
VK_LAYER_NV_optimus                 NVIDIA Optimus layer          1.2.186  version 1

You also appear to have installed lib32-amdvlk

Looks like your graphics setup is messed up, let's start with basics.

please post lspci -k and xorg log.
If you're using startx also post ~/.xinitrc .


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#10 2022-01-10 13:04:12

kashishme
Member
Registered: 2021-01-08
Posts: 81

Re: [SOLVED]Proton games crashing (again)

Lone_Wolf wrote:

The glxinfo output indicates you have an intel gpu and a nvidia one.

VK_LAYER_AMD_switchable_graphics_32 AMD switchable graphics layer 1.2.201  version 1
VK_LAYER_NV_optimus                 NVIDIA Optimus layer          1.2.186  version 1

You also appear to have installed lib32-amdvlk

Looks like your graphics setup is messed up, let's start with basics.

please post lspci -k and xorg log.
If you're using startx also post ~/.xinitrc .

here is 'lspci -k' output: http://ix.io/3LLj
I am using light dm so, i don't think you will need xinitrc.
and do u mind reminding me how to get the xorg log?

Last edited by kashishme (2022-01-10 13:07:33)

Online

#11 2022-01-10 13:13:58

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 3,805

Re: [SOLVED]Proton games crashing (again)

kashishme wrote:

and do u mind reminding me how to get the xorg log?

https://wiki.archlinux.org/title/Xorg#General

Online

#12 2022-01-10 13:20:29

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,795

Re: [SOLVED]Proton games crashing (again)

lspci output confirms you have 2 videocard, an Intel(R) UHD Graphics CML GT2  and a Nivida GTX1650 Ti Mobile

xorg logs are probably at ~/.local/share/xorg ,  see https://wiki.archlinux.org/title/Xorg#General for details / alternative locations.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#13 2022-01-10 13:44:21

kashishme
Member
Registered: 2021-01-08
Posts: 81

Re: [SOLVED]Proton games crashing (again)

Lone_Wolf wrote:

lspci output confirms you have 2 videocard, an Intel(R) UHD Graphics CML GT2  and a Nivida GTX1650 Ti Mobile

xorg logs are probably at ~/.local/share/xorg ,  see https://wiki.archlinux.org/title/Xorg#General for details / alternative locations.

I used plocate and the file was under /var/log.

here it is: http://ix.io/3LLq

Online

#14 2022-01-10 14:42:11

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,795

Re: [SOLVED]Proton games crashing (again)

[     4.198] (==) Using config file: "/etc/X11/xorg.conf"

Post the contents of that file please

[     4.286] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so

You're using xf86-video-intel , which tends to be a bad idea for Intel gen 3+ systems, and yours is 10th gen.
Try removing xf86-video-intel.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#15 2022-01-11 04:43:14

kashishme
Member
Registered: 2021-01-08
Posts: 81

Re: [SOLVED]Proton games crashing (again)

Lone_Wolf wrote:
[     4.198] (==) Using config file: "/etc/X11/xorg.conf"

Post the contents of that file please

[     4.286] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so

You're using xf86-video-intel , which tends to be a bad idea for Intel gen 3+ systems, and yours is 10th gen.
Try removing xf86-video-intel.

removing xf86-video-intel won't break anything right?
Also i should mention i am using runtime d3 so that i can save battery, so hope intel gpu will still work after removing that package
and here is the xorg.conf file: http://ix.io/3LPX

edit: alright removing the intel package won't allow me to use the gui (had to reinstall it from the tty cli interface to edit this)

Last edited by kashishme (2022-01-11 07:34:33)

Online

#16 2022-01-11 09:09:05

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 15,069

Re: [SOLVED]Proton games crashing (again)

Can you try to remove that config and remove xf86-video-intel (you may also have an additional config somewhere explicitly enabling tearfree, the important thing is that you don't have any xorg configuration that requests or uses the "intel" driver). xorg didn't work because your config directly references it. You probably want to just install nvidia-prime and run applications via the nvidia card with

prime-run $application$

Also because this is likely relevant and probably the most important thing you should do. Make sure you don't have amdvlk/lib32-amdvlk installed.

Last edited by V1del (2022-01-11 11:36:08)

Offline

#17 2022-01-11 09:11:53

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,795

Re: [SOLVED]Proton games crashing (again)

There's a race condition that often occurs with display managers like lightdm where the videocard is not fully initialised when the DM tries to use it.

Have you configured early KMS start  for the intel card ?


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#18 2022-01-12 05:34:57

kashishme
Member
Registered: 2021-01-08
Posts: 81

Re: [SOLVED]Proton games crashing (again)

Apparently i had lib32-amdvlk installed and after i removed it, everything started working fine, I guess the driver interferes with the nvidia drivers.

Anyways, thank you guys for the help!!

Online

Board footer

Powered by FluxBB