You are not logged in.

#1 2022-01-14 03:45:43

mraf61-i6556
Member
Registered: 2022-01-14
Posts: 2
Website

[SOLVED] Can't get NVIDIA driver to load [GeForce 8400 GS]

After getting ArchLinux working on my PC (core i5 4GB of RAM,GPU Geforce 8400 GS ) I installed XFCE4 and everything works perfectly with Nouveau driver ,
but when I Installed nvidia-340xx-dkms driver, the X server won’t start , here is debug commands output :-

 
 lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation G98 [GeForce 8400 GS Rev. 2] (rev a1)

 inxi  -G --display
Graphics:
  Device-1: NVIDIA G98 [GeForce 8400 GS Rev. 2] driver: nvidia v: 340.108
  Display: server: X.org 1.21.1.3 driver: loaded: nvidia note: n/a (using device driver)
  failed: nvidia tty: 135x36
 

$ nvidia-smi

NVIDIA-SMI 340.108    Driver Version: 340.108  

sudo dmesg|grep nvidia

 
[    0.759106] nvidia: loading out-of-tree module taints kernel.
[    0.759116] nvidia: module license 'NVIDIA' taints kernel.
[    0.762565] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    0.783540] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=io+mem
[    0.783766] [drm] Initialized nvidia-drm 0.0.0 20150116 for 0000:01:00.0 on minor 0 

startx

(EE) NVIDIA: Use the -ignoreABI option to override this check.
(EE) 
Fatal server error:
(EE) no screens found(EE) 
(EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error  

sudo startxfce4

 
/usr/bin/startxfce4: X server already running on display :0.0
xrdb: Connection refused
xrdb: Can't open display ':0.0'
Failed to connect to bus: No medium found
dbus-update-activation-environment: error: unable to connect to D-Bus: Using X11 for dbus-daemon autolaunch was disabled at compile time, set your DBUS_SESSION_BUS_ADDRESS instead
xfce4-session: Cannot open display: . 

cat /var/log/Xorg.0.log |grep nvidia

 
[    42.535] (II) LoadModule: "nvidia"
[    42.535] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    42.632] (II) Module nvidia: vendor="NVIDIA Corporation"
http://www.nvidia.com/ for driver updates or downgrade to an X
[    42.632] (II) UnloadModule: "nvidia"
[    42.632] (II) Unloading nvidia
[    42.632] (EE) Failed to load module "nvidia" (unknown error, 0)

 cat  /usr/lib/modprobe.d/nvidia-340xx-dkms.conf
 blacklist nouveau 

$ cat /etc/X11/xorg.conf

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
  
 sudo xrandr --listmonitors Can't open display 

Last edited by mraf61-i6556 (2022-01-14 05:39:54)

Offline

#2 2022-01-14 04:04:56

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 15,083

Re: [SOLVED] Can't get NVIDIA driver to load [GeForce 8400 GS]

You are probably in general better off with nouveau with this kind of GPU to be frank. But what you need to do here is tell Xorg to ignore the potential ABI incompat.

Section "ServerFlags"
    Option        "IgnoreABI" "1" 
EndSection

add this to the xorg.conf

Offline

#3 2022-01-14 05:39:26

mraf61-i6556
Member
Registered: 2022-01-14
Posts: 2
Website

Re: [SOLVED] Can't get NVIDIA driver to load [GeForce 8400 GS]

V1del wrote:

You are probably in general better off with nouveau with this kind of GPU to be frank. But what you need to do here is tell Xorg to ignore the potential ABI incompat.

Section "ServerFlags"
    Option        "IgnoreABI" "1" 
EndSection

add this to the xorg.conf

Thanks a lot that's solved my problem the XFCE4 DE return to running again ,
I know it's weak GPU but I needed for other PC preparing to move my Arch Linux installation to it,
+ when I connect to `tigervnc` on (Local network) the GUI performance were terrible it XFCE4 desktop were like slideshow I suspected there's no GPU acceleration with `nouveau` driver .
=Update= I get back to `nouveau` driver since this card is well-supported .

Last edited by mraf61-i6556 (2022-01-18 04:01:08)

Offline

Board footer

Powered by FluxBB