You are not logged in.

#1 2021-10-31 19:04:06

odror
Member
Registered: 2015-03-17
Posts: 66

Wayland is disabled by systemd with nvidia-495

I have installed nvidia-495. I was expecting wayland to be a choice on the gdm menu. It was not. Any way to fix that?

on journalctl -b0 I get the following:

Oct 31 11:45:41 arch systemd[467]: Starting GNOME Shell on Wayland...
Oct 31 11:45:41 arch systemd[467]: Starting GNOME Shell on X11...
Oct 31 11:45:41 arch systemd[467]: Started Application launched by gnome-session-binary.
Oct 31 11:45:41 arch systemd[467]: Started Application launched by gnome-session-binary.
Oct 31 11:45:41 arch systemd[467]: org.gnome.Shell@wayland.service: Skipped due to 'exec-condition'.
Oct 31 11:45:41 arch systemd[467]: Condition check resulted in GNOME Shell on Wayland being skipped.
Oct 31 11:45:41 arch gnome-shell[570]: Enabling experimental feature 'kms-modifiers'

less  /usr/lib/udev/rules.d/61-gdm.rules:
# disable Wayland on Hi1710 chipsets
#ATTR{vendor}=="0x19e5", ATTR{device}=="0x1711", RUN+="/usr/lib/gdm-runtime-config set daemon WaylandEnable false"
# disable Wayland when using the proprietary nvidia driver
#DRIVER=="nvidia", RUN+="/usr/lib/gdm-runtime-config set daemon WaylandEnable false"
# disable Wayland if modesetting is disabled
#IMPORT{cmdline}="nomodeset", RUN+="/usr/lib/gdm-runtime-config set daemon WaylandEnable false"

/etc/gdm/custom.conf:
[daemon]
# Uncoment the line below to force the login screen to use Xorg
#WaylandEnable=false

Offline

#2 2021-10-31 19:25:32

Ammako
Member
Registered: 2021-07-16
Posts: 266

Re: Wayland is disabled by systemd with nvidia-495

You need early KMS (`nvidia nvidia_modeset nvidia_uvm nvidia_drm` under modules, in mkinitcpio.conf) and nvidia-drm.modeset=1 kernel parameter.

Offline

#3 2021-10-31 20:31:57

odror
Member
Registered: 2015-03-17
Posts: 66

Re: Wayland is disabled by systemd with nvidia-495

Ammako wrote:

You need early KMS (`nvidia nvidia_modeset nvidia_uvm nvidia_drm` under modules, in mkinitcpio.conf) and nvidia-drm.modeset=1 kernel parameter.


I have all of that set. I have ubuntu that runs with wayland on the same machine

Offline

#4 2021-11-02 16:13:53

MetalGearDaner
Member
Registered: 2021-11-02
Posts: 3

Re: Wayland is disabled by systemd with nvidia-495

odror wrote:
Ammako wrote:

You need early KMS (`nvidia nvidia_modeset nvidia_uvm nvidia_drm` under modules, in mkinitcpio.conf) and nvidia-drm.modeset=1 kernel parameter.


I have all of that set. I have ubuntu that runs with wayland on the same machine

Have you managed to fix this? I'm having the same issue.

Offline

#5 2021-11-02 16:45:49

odror
Member
Registered: 2015-03-17
Posts: 66

Re: Wayland is disabled by systemd with nvidia-495

MetalGearDaner wrote:

Have you managed to fix this? I'm having the same issue.

No I have not. I am surprised that there was no answers  to this issue. Now that NVIDIA users can have Wayland, I expected more people to have the issues. I am sure that It is systemd related. I just do not know enough about systemd.

Offline

#6 2021-11-02 21:53:48

OrakMoya
Member
Registered: 2019-09-22
Posts: 40

Re: Wayland is disabled by systemd with nvidia-495

odror wrote:
MetalGearDaner wrote:

Have you managed to fix this? I'm having the same issue.

No I have not. I am surprised that there was no answers  to this issue. Now that NVIDIA users can have Wayland, I expected more people to have the issues. I am sure that It is systemd related. I just do not know enough about systemd.

May be dumb question, but did you

mkinitcpio -P

Offline

#7 2021-11-03 11:23:01

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,800

Re: Wayland is disabled by systemd with nvidia-495

$ pkgfile /usr/lib/udev/rules.d/61-gdm.rules
extra/gdm
$ 

Also the logentries appear to be from gdm, not systemd itself[1] .

I suggest you boot to multi-user.target[2] and try start gnome on wayland directly.
IF that works you can then try to get gdm to do what you want.


[1] gdm doesn't keep its own log , but uses systemd-journal to log things
[2] https://wiki.archlinux.org/title/System … _boot_into


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#8 2021-11-03 18:02:24

MetalGearDaner
Member
Registered: 2021-11-02
Posts: 3

Re: Wayland is disabled by systemd with nvidia-495

I switched to a TTY and from there, started Wayland by using the command

dbus-run-session -- gnome-shell --display-server --wayland

It works weird, starting apps is very slow and when I try to log out, power off, reboot or press any button from the top-rigth menu they simply doesn't work.

@odror do you have the same issues?

Offline

#9 2021-11-03 23:14:06

odror
Member
Registered: 2015-03-17
Posts: 66

Re: Wayland is disabled by systemd with nvidia-495

dbus-run-session -- gnome-shell --display-server --wayland

I tried to do it. Did not work. It is probably because of the way my system is setup. I even put this line in my .xsession file.

So How can I force gdm to start a wayland session.

Offline

#10 2021-11-04 01:14:45

CarbonChauvinist
Member
Registered: 2012-06-16
Posts: 384
Website

Re: Wayland is disabled by systemd with nvidia-495


"the wind-blown way, wanna win? don't play"

Offline

#11 2021-11-04 11:22:27

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,800

Re: Wayland is disabled by systemd with nvidia-495

odror wrote:
dbus-run-session -- gnome-shell --display-server --wayland

I tried to do it. Did not work. It is probably because of the way my system is setup. I even put this line in my .xsession file.

So How can I force gdm to start a wayland session.

First, make sure you boot up without starting gdm (to prevent gdm from interfering).
2nd, login to console as your normal user.

3rd try the methods described in https://wiki.archlinux.org/title/GNOME#Wayland_sessions


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#12 2021-11-04 22:48:46

MetalGearDaner
Member
Registered: 2021-11-02
Posts: 3

Re: Wayland is disabled by systemd with nvidia-495

This fixed it for me, thanks. Just running

ln -s /dev/null /etc/udev/rules.d/61-gdm.rules

Offline

#13 2022-01-14 06:17:48

ding_aa
Member
Registered: 2022-01-14
Posts: 1

Re: Wayland is disabled by systemd with nvidia-495

I can refer to this udev code in upstream gdm repository.

If you look at this snippet of code, and given that loading nvidia-drm module triggers this section, you will see that the only possible outcomes are either Wayland is disabled, or X11 is preferred.

An issue has been raised. Let us hope it will be answered to.

Offline

Board footer

Powered by FluxBB