You are not logged in.

#1 2006-08-08 02:23:16

Rumor
Member
From: Albany, NY
Registered: 2006-07-07
Posts: 465

printer sharing question

The situation: I have three computers on my home network and one printer. The printer is connected to the computer running Arch. The other two computers are running windows XP pro.

The Arch computer has an internal ip address of 192.168.1.101

My family needs to be able to print to the this printer.

I've edited the cupsd.conf file to include

# Only listen for connections from the local machine.
Listen localhost:631
# Socket disabled by default it makes KDE fail on CUPS
# Listen /var/run/cups/cups.sock
# To allow remote connections add for example
Listen 192.168.1.*:631

but I am thinking that must not be right. When I go to one of the windows computers and put in the address http:192.168.1.102:631/printers/deskjet895c there is no connection.

So either my cupsd.conf file is incorrect, or I am putting in the incorrect url in windows, or both are incorrect.

Any help is appreciated.


Smarter than a speeding bullet
My Goodreads profile

Offline

#2 2006-08-08 03:46:33

battra
Member
From: Earth.US.Illinois.Chicago
Registered: 2006-05-12
Posts: 71

Re: printer sharing question

I have this same setup.  I think there are a few ways to do this.  I use Samba with CUPS.

I basically followed this wiki guide:

http://wiki.archlinux.org/index.php/CUP … s_to_Linux

Take a look at that...I think it'll help.


"I know nothing except the fact of my ignorance."
- Socrates

Offline

#3 2006-08-08 03:53:22

battra
Member
From: Earth.US.Illinois.Chicago
Registered: 2006-05-12
Posts: 71

Re: printer sharing question

You can also connect to CUPS directly from Windows XP.  The wiki covers this, too:

xp to linux


Also, if using CUPS directly, I think you have to specifically allow client IPs in this directive:

<Location>
  Order Deny,Allow
  Deny From All
  Allow From 127.0.0.1
  Allow From 10.0.0.*
</Location>

"I know nothing except the fact of my ignorance."
- Socrates

Offline

#4 2006-08-09 00:29:34

johnisevil
Member
From: Hamilton, ON Canada
Registered: 2003-08-07
Posts: 221
Website

Re: printer sharing question

battra wrote:

You can also connect to CUPS directly from Windows XP.  The wiki covers this, too:

xp to linux


Also, if using CUPS directly, I think you have to specifically allow client IPs in this directive:

<Location>
  Order Deny,Allow
  Deny From All
  Allow From 127.0.0.1
  Allow From 10.0.0.*
</Location>

Or you can just use Allow From $LOCAL instead.

Offline

#5 2006-10-16 04:52:31

davidwillis
Member
Registered: 2006-09-19
Posts: 49

Re: printer sharing question

I am trying to get this going too.  I have done it in gentoo using this guide http://www.gentoo-wiki.com/HOWTO_Linux_ … _with_CUPS

I have a few questions on Arch.
do you have to edit /etc/hosts, and if you do what do you put in?
and do you need to comment out this line in cupsd.conf ?
# Listen 127.0.0.1:631

Thanks

Offline

#6 2006-10-16 17:42:31

davidwillis
Member
Registered: 2006-09-19
Posts: 49

Re: printer sharing question

I have it working now, but I had to take out the line

Deny From All

And I had to add the line

port 631

here is my cupsd.conf file, at least the section I have changed.

LogLevel info

# Administrator user group...
SystemGroup sys root

port 631

# Only listen for connections from the local machine.
# Listen localhost:631

# Socket disabled by default it makes KDE fail on CUPS
# Listen /var/run/cups/cups.sock
# To allow remote connections add for example
# Listen <yourserverip>:631

# Show shared printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAllow @LOCAL

# Default authentication type, when authentication is required...
DefaultAuthType Basic

# Restrict access to the server...
# By default only localhost connections are possible
<Location>
  Order allow,deny
#  Deny From All
#  Allow localhost
  Allow From 127.0.0.1
  Allow From 192.168.0.*
</Location>


What will it do with the Deny From All commented out?  In gentoo I did not need to comment that out. 

Thanks

By the way, it didn't work until I edited /etc/hosts to this

#<ip>   <hostname>   <hostname>
127.0.0.1               localhost.localdomain   localhost
192.168.0.50     myhost.localdomain    myhost

where 192.168.0.50 is the ip of my computer connected to the printer

Offline

Board footer

Powered by FluxBB