You are not logged in.

#1 2022-01-20 08:40:37

Pezhman
Member
Registered: 2022-01-19
Posts: 63

[SOLVED]steam doesn't open

Hello
I am new to archlinux and I know I have to read the wiki first but I couldn't fix my problem
when I type steam in konsole it shows this error:

steam.sh[7791]: Running Steam on arch rolling 64-bit
steam.sh[7791]: STEAM_RUNTIME is enabled automatically
setup.sh[7864]: Steam runtime environment up-to-date!
steam.sh[7791]: Can't find 'steam-runtime-check-requirements', continuing anyway
[2022-01-20 12:08:20] Startup - updater built Nov 22 2021 22:06:59
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
Installing breakpad exception handler for appid(steam)/version(0)
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

It stucks at this point and I press Ctrl+C to cancel.
do you know how to fix this?

Last edited by Pezhman (2022-01-21 19:29:42)

Offline

#2 2022-01-20 08:52:46

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,138

Re: [SOLVED]steam doesn't open

Make sure that en_US is one of the generated locales regardless of whether you make active use of it, see the steam installation caveats

In case something else is broken, post about your locale setup

localectl
locale
locale -a

post these in code tags

Offline

#3 2022-01-20 09:13:21

Pezhman
Member
Registered: 2022-01-19
Posts: 63

Re: [SOLVED]steam doesn't open

thank you for code tags i edited my post.

localectl:

   System Locale: LANG=C
       VC Keymap: n/a
      X11 Layout: n/a

locale:

LANG=C
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=

locale -a:

C
POSIX
en_US.utf8
fa_IR
fa_IR.utf8

is this correct?

Offline

#4 2022-01-20 09:29:24

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,138

Re: [SOLVED]steam doesn't open

locale -a is correct your locale in general isn't.

https://wiki.archlinux.org/title/Locale … the_locale

Offline

#5 2022-01-20 10:34:30

Pezhman
Member
Registered: 2022-01-19
Posts: 63

Re: [SOLVED]steam doesn't open

I ran

localectl set-locale LANG=en_US.UTF-8

and now the error is shorter

steam.sh[1853]: Running Steam on arch rolling 64-bit
steam.sh[1853]: STEAM_RUNTIME is enabled automatically
setup.sh[1925]: Steam runtime environment up-to-date!
steam.sh[1853]: Can't find 'steam-runtime-check-requirements', continuing anyway

it exits from command and nothing happens

Offline

#6 2022-01-20 10:38:03

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,138

Re: [SOLVED]steam doesn't open

Nothing of that is an error. What's your general environment Wayland or Xorg? Xwayland installed if the former?

Offline

#7 2022-01-20 11:23:54

Pezhman
Member
Registered: 2022-01-19
Posts: 63

Re: [SOLVED]steam doesn't open

I use Xorg because my gpu is Nvidia.
My driver version is 390.xx(aur)
I didn't install Wayland.
I ran

pacman - Q

And i couldn't find Xwayland package
I found these packages

wayland 1.20.0-1
wayland-protocols 1.24-1
wayland-utils 1.0.0-2

Offline

#8 2022-01-20 13:13:22

seth
Member
Registered: 2012-09-03
Posts: 53,477

Re: [SOLVED]steam doesn't open

pacman -Qs nvidia

Edit, on a limb: https://aur.archlinux.org/packages/lib3 … 0xx-utils/

Last edited by seth (2022-01-20 13:14:07)

Online

#9 2022-01-20 13:24:31

Pezhman
Member
Registered: 2022-01-19
Posts: 63

Re: [SOLVED]steam doesn't open

this is the result

pacman -Qs nvidia

local/egl-wayland 2:1.1.9+r3+g582b2d3-1
    EGLStream-based Wayland external platform
local/lib32-nvidia-utils 495.46-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.4-1
    Nvidia VDPAU library
local/libxnvctrl 495.46-2
    NVIDIA NV-CONTROL X extension
local/nvidia-390xx-dkms 390.147-1
    NVIDIA drivers - module sources
local/nvidia-390xx-utils 390.147-1
    NVIDIA drivers utilities
local/nvidia-settings 495.46-2
    Tool for configuring the NVIDIA graphics driver
local/opencl-nvidia-390xx 390.147-1
    OpenCL implemention for NVIDIA
local/xf86-video-nouveau 1.0.17-2 (xorg-drivers)
    Open Source 3D acceleration driver for nVidia cards

Offline

#10 2022-01-20 13:29:20

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,138

Re: [SOLVED]steam doesn't open

seth was on the correct limb and I'd probably have started to suspect that as well, your lib32-nvidia-utils is the wrong version, you need to install the matching 390xx set (... also nvidia-390xx-settings but that is generally not as relevant)

Last edited by V1del (2022-01-20 13:31:07)

Offline

#11 2022-01-20 13:32:27

Pezhman
Member
Registered: 2022-01-19
Posts: 63

Re: [SOLVED]steam doesn't open

I've installed arch yesterday and I do not know how to downgrade that.
can you please help me how to do it?

Offline

#12 2022-01-20 13:39:13

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,138

Re: [SOLVED]steam doesn't open

There's nothing to downgrade you just need to install lib32-nvidia-390xx-utils the same way you installed all of the other 390xx packages.

How did you install those in the first place, which instructions did you follow to install these/ Arch?

Last edited by V1del (2022-01-20 13:40:09)

Offline

#13 2022-01-20 13:48:27

Pezhman
Member
Registered: 2022-01-19
Posts: 63

Re: [SOLVED]steam doesn't open

I installed lib32-nvidia-390xx-utils and now steam opens without any error.
Thank you so much everyone who helped me to fix my problem

Offline

#14 2022-01-20 14:06:46

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,138

Re: [SOLVED]steam doesn't open

Great, please mark as [SOLVED] by editing the title in your first post: https://wiki.archlinux.org/title/Genera … ow_to_post

Offline

Board footer

Powered by FluxBB