You are not logged in.

#1 2022-02-11 09:45:45

programmador
Member
Registered: 2020-04-19
Posts: 13

Xmobar is built in wrong environment (wrong glibc version)

~> xmobar
xmobar: /usr/lib/libc.so.6: version `GLIBC_2.34' not found (required by xmobar)

Glibc 2.35 is currently in Testing repo.
Actual Arch version is 2.33.
As for exactly 2.34 - there is no such repo in Arch at all.

Offline

#2 2022-02-11 10:02:18

Arctesian
Member
Registered: 2022-02-11
Posts: 7

Re: Xmobar is built in wrong environment (wrong glibc version)

I just set up arch on my brothers gaming computer after he left for college so this is a semi fresh install. I am trying to set up my xmobar and I run into this issue,

xmobar: /usr/lib/libc.so.6: version `GLIBC_2.34' not found (required by xmobar)

I ran a

yay

and it said nothing was needed to upgrade, i didn't want to upgrade the single package cause it has destroyed my system before so i went through doing all the

pacman -S

and then

pacman -Sy

then

pacman -Su

Then

pacman -Suu

but all of them said "there is nothing to do" so I rebooted and still same problem I am now stuck and would really apr help

Offline

#3 2022-02-11 10:18:35

Alad
Wiki Admin/IRC Op
From: Bagelstan
Registered: 2014-05-04
Posts: 2,414
Website

Re: Xmobar is built in wrong environment (wrong glibc version)

If you haven't mixed packages from different repositories, the package is possibly built against glibc 2.35 in testing. And you don't need 4 commands, pacman -Syu suffices.


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby

Offline

#4 2022-02-11 10:18:54

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 11,956
Website

Re: Xmobar is built in wrong environment (wrong glibc version)

It looks like xmobar may have been accidentally rebuilt against the new toolchain before it has been tested thoroughly. Open a bug on the bug tracker and downgrade to the previous version using the Arch Linux Archive.

Mod note: Merged the two threads.

Last edited by WorMzy (2022-02-11 10:21:05)


Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#5 2022-02-11 11:11:14

BenniTec
Member
Registered: 2020-09-11
Posts: 24

Re: Xmobar is built in wrong environment (wrong glibc version)

I have found a bigger problem.
Many packages by Yan Felix (@felixonmars) are broken.
These include:
- shellcheck
- pandoc
- cabal-install
- xmobar

All of these packages fail with

usr/lib/libc.so.6: version `GLIBC_2.34' not found (required by ...)

Luckily xmonad (packaged by him on 2022-02-09) is not (yet) part of them.

I created a Bug Report: https://bugs.archlinux.org/task/73737

Mod edit: Removed auto vote URL.

Last edited by WorMzy (2022-02-11 15:44:26)

Offline

#6 2022-02-11 11:45:21

glub
Member
Registered: 2022-02-11
Posts: 1

Re: Xmobar is built in wrong environment (wrong glibc version)

I'm also experiencing this after updating xmobar this morning. Thanks for the heads up on the other packages.
I tried rolling back to a couple of older xmobar versions, but ran into other dependency issues. I've settled on using xmobar-git from AUR until this is resolved.

Offline

#7 2022-02-11 12:23:41

shyn
Member
Registered: 2009-09-23
Posts: 16

Re: Xmobar is built in wrong environment (wrong glibc version)

f*ck, not the best time I choose for an update. grrr

Offline

#8 2022-02-11 13:22:28

Alad
Wiki Admin/IRC Op
From: Bagelstan
Registered: 2014-05-04
Posts: 2,414
Website

Re: Xmobar is built in wrong environment (wrong glibc version)

BenniTec wrote:

Please don't add a link to something that adds a vote.

Mod edit: fix'd.

Last edited by WorMzy (2022-02-11 15:44:04)


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby

Offline

#9 2022-02-11 16:47:52

BenniTec
Member
Registered: 2020-09-11
Posts: 24

Re: Xmobar is built in wrong environment (wrong glibc version)

Alad wrote:
BenniTec wrote:

Please don't add a link to something that adds a vote.

Mod edit: fix'd.

Sorry my fault, didn't look at the URL.

Offline

#10 2022-02-11 17:44:39

joshskidmore
Member
Registered: 2022-02-11
Posts: 1

Re: Xmobar is built in wrong environment (wrong glibc version)

Not that it's a fix, but until there is one, `xmobar-git` does compile and work without any issues.

Offline

#11 2022-02-11 18:25:23

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,661

Re: Xmobar is built in wrong environment (wrong glibc version)

There's no need to go with a -git package, you would just need to rebuild the normal one.

Offline

#12 2022-02-11 22:08:59

rarsa
Member
Registered: 2020-11-03
Posts: 7

Re: Xmobar is built in wrong environment (wrong glibc version)

The bug report created by BenniTec was closed as duplicate.

you can go and upvote the open bug

https://bugs.archlinux.org/task/73730

Last edited by rarsa (2022-02-11 22:10:54)

Offline

#13 2022-02-11 22:19:36

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,776

Re: Xmobar is built in wrong environment (wrong glibc version)

rarsa wrote:

The bug report created by BenniTec was closed as duplicate.

you can go and upvote the open bug

https://bugs.archlinux.org/task/73730

Absolutely no need. It's already been picked up as high severity and assigned to the relevant dev.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

Board footer

Powered by FluxBB