You are not logged in.

#1 2022-02-17 19:39:59

orlfman
Member
Registered: 2007-11-20
Posts: 121

[solved]firefox can no longer play videos

i'm not sure what updates caused this, but suddenly, with both current firefox normal 97 and firefox developer edition - 98b5, neither can play most videos. both give me:

to play this video, you may need to install the required codecs

but mpv works just fine. including hardware acceleration with vaapi-copy.

edit:
installing the new, secondary ffmpeg package from the repo, ffmpeg 4.4 fixed the problem for me. you are able to have it and the normal ffmpeg installed together.

Last edited by orlfman (2022-02-17 20:44:34)

Offline

#2 2022-02-17 19:51:44

unaboomer
Member
Registered: 2022-02-17
Posts: 7

Re: [solved]firefox can no longer play videos

I'm having the same issue. The latest upgrades included ffmpg and H264. This is 100% the fault of the people who did the upgrade. The arch team needs to investigate this NOW.

I'll continue to investigate.

Offline

#3 2022-02-17 19:53:30

unaboomer
Member
Registered: 2022-02-17
Posts: 7

Re: [solved]firefox can no longer play videos

Attempts to downgrade ffmpeg and H264 fail owing to dependency issues. That's a MAJOR catch-22. So whoever maintains ffmpeg and H264 needs to get on this issue NOW.

Offline

#4 2022-02-17 20:09:23

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,770

Re: [solved]firefox can no longer play videos

No issues at all here, latest versions...
firefox 97.0-1
ffmpeg 2:4.4.1-1
h264 3:0.163.r3060.5db6aa6-1

Must be an issue specific to your setups. Do you get any errors in the terminal when trying to play a video?
And please calm down unaboomer.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Online

#5 2022-02-17 20:15:27

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 30,370
Website

Re: [solved]firefox can no longer play videos

unaboomer wrote:

The arch team needs to investigate this NOW.

giphy.gif


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#6 2022-02-17 20:20:07

unaboomer
Member
Registered: 2022-02-17
Posts: 7

Re: [solved]firefox can no longer play videos

ffplay and mpv work fine. So the CLI works.

I can play video from YouTube in the Firefox browser, but from other sites, the video won't play. The browser says, "To play the video, you may need to install the required video codecs," which is nonsense, because the codecs worked prior to today's ffmpeg and H264 "upgrades".

Offline

#7 2022-02-17 20:23:22

unaboomer
Member
Registered: 2022-02-17
Posts: 7

Re: [solved]firefox can no longer play videos

The [cough] "upgrades" broke the browser. Who else should I blame for the problem?

Where I come from, you take responsibility for the problems you cause.

Offline

#8 2022-02-17 20:27:56

archer108
Member
From: Zurich Switzerland
Registered: 2007-08-28
Posts: 59

Re: [solved]firefox can no longer play videos

Netflix does also get error code on Firefox, after today's update. Firefox requests to install additional video decoding.....

[2022-02-17T19:46:33+0100] [ALPM] upgraded alsa-card-profiles (1:0.3.45-1 -> 1:0.3.46-1)
[2022-02-17T19:46:33+0100] [ALPM] upgraded alsa-plugins (1:1.2.6-2 -> 1:1.2.6-3)
[2022-02-17T19:46:34+0100] [ALPM] upgraded x264 (3:0.163.r3060.5db6aa6-1 -> 3:0.164.r3081.19856cc-1)
[2022-02-17T19:46:34+0100] [ALPM] upgraded e2fsprogs (1.46.5-2 -> 1.46.5-3)
[2022-02-17T19:46:34+0100] [ALPM] upgraded ffmpeg (2:4.4.1-1 -> 2:5.0-3)
[2022-02-17T19:46:34+0100] [ALPM] upgraded chromaprint (1.5.1-1 -> 1.5.1-2)
[2022-02-17T19:46:34+0100] [ALPM] upgraded ffmpegthumbnailer (2.2.2-2 -> 2.2.2-3)
[2022-02-17T19:46:34+0100] [ALPM] upgraded gegl (0.4.34-1 -> 0.4.34-2)
[2022-02-17T19:46:34+0100] [ALPM] upgraded gstreamer (1.20.0-1 -> 1.20.0-2)
[2022-02-17T19:46:34+0100] [ALPM] upgraded gst-plugins-base-libs (1.20.0-1 -> 1.20.0-2)
[2022-02-17T19:46:34+0100] [ALPM] upgraded gst-libav (1.20.0-1 -> 1.20.0-2)
[2022-02-17T19:46:34+0100] [ALPM] upgraded gst-plugin-gtk (1.20.0-1 -> 1.20.0-2)
[2022-02-17T19:46:34+0100] [ALPM] upgraded pipewire (1:0.3.45-1 -> 1:0.3.46-1)
[2022-02-17T19:46:34+0100] [ALPM] upgraded gst-plugin-pipewire (1:0.3.45-1 -> 1:0.3.46-1)
[2022-02-17T19:46:34+0100] [ALPM] upgraded gst-plugins-bad-libs (1.20.0-1 -> 1.20.0-2)
[2022-02-17T19:46:34+0100] [ALPM] upgraded libde265 (1.0.8-1 -> 1.0.8-2)
[2022-02-17T19:46:34+0100] [ALPM] upgraded openal (1.21.1-2 -> 1.21.1-3)
[2022-02-17T19:46:34+0100] [ALPM] upgraded gst-plugins-bad (1.20.0-1 -> 1.20.0-2)
[2022-02-17T19:46:34+0100] [ALPM] upgraded gst-plugins-base (1.20.0-1 -> 1.20.0-2)
[2022-02-17T19:46:34+0100] [ALPM] upgraded gst-plugins-good (1.20.0-1 -> 1.20.0-2)
[2022-02-17T19:46:35+0100] [ALPM] upgraded gst-plugins-ugly (1.20.0-1 -> 1.20.0-2)
[2022-02-17T19:46:35+0100] [ALPM] upgraded mpv (1:0.34.1-2 -> 1:0.34.1-3)
[2022-02-17T19:46:35+0100] [ALPM] upgraded opencv (4.5.5-1 -> 4.5.5-2)
[2022-02-17T19:46:35+0100] [ALPM] upgraded pipewire-alsa (1:0.3.45-1 -> 1:0.3.46-1)
[2022-02-17T19:46:35+0100] [ALPM] upgraded pipewire-pulse (1:0.3.45-1 -> 1:0.3.46-1)
[2022-02-17T19:46:35+0100] [ALPM] upgraded pipewire-v4l2 (1:0.3.45-1 -> 1:0.3.46-1)
[2022-02-17T19:46:35+0100] [ALPM] upgraded pipewire-zeroconf (1:0.3.45-1 -> 1:0.3.46-1)

Offline

#9 2022-02-17 20:34:01

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,435

Re: [solved]firefox can no longer play videos

unaboomer wrote:

Where I come from, you take responsibility for the problems you cause.

But the rest of us don't have the problem. Videos work fine in Firefox in my setup both for my laptop and desktop both running on Archlinux.
So as already implied, there must be a problem with your setup so you should be the one to take responsibility.

Offline

#10 2022-02-17 20:35:51

orlfman
Member
Registered: 2007-11-20
Posts: 121

Re: [solved]firefox can no longer play videos

Slithery wrote:

No issues at all here, latest versions...
firefox 97.0-1
ffmpeg 2:4.4.1-1
h264 3:0.163.r3060.5db6aa6-1

Must be an issue specific to your setups. Do you get any errors in the terminal when trying to play a video?
And please calm down unaboomer.

did you not update? ffmpeg for me:

[agent@linux64 ~]$ pacman -Qs ffmpeg
local/ffmpeg 2:5.0-4
    Complete solution to record, convert and stream audio and video
local/ffmpegthumbnailer 2.2.2-3
    Lightweight video thumbnailer that can be used by file managers.
local/gst-libav 1.20.0-2
    Multimedia graph framework - libav plugin
[agent@linux64 ~]$

from doing a quick google, i see other people on reddit having a similar problem with ffmpeg 5 update on arch. apparently, ffmpeg 5 even affecting telegram desktop app. seems like ffmpeg isn't built with some codecs anymore.

Last edited by orlfman (2022-02-17 20:38:46)

Offline

#11 2022-02-17 20:37:58

unaboomer
Member
Registered: 2022-02-17
Posts: 7

Re: [solved]firefox can no longer play videos

d_fajardo wrote:
unaboomer wrote:

Where I come from, you take responsibility for the problems you cause.

But the rest of us don't have the problem. Videos work fine in Firefox in my setup both for my laptop and desktop both running on Archlinux.
So as already implied, there must be a problem with your setup so you should be the one to take responsibility.

False. I didn't change anything. The only change was the [cough] "upgrade". Prior to the upgrade EVERYTHING worked properly. So no, you're wrong.

Offline

#12 2022-02-17 20:40:31

I0F
Member
Registered: 2022-02-01
Posts: 1

Re: [solved]firefox can no longer play videos

Install the new ffmpeg4.4 package from the official repositories. You don't need to remove the regular ffmpeg package. Both can coexist and complement each other.

Edit: Just to clarify what the problem is: it seems ffmpeg 5.0 is not yet supported by some programs. As a workaround they added ffmpeg4.4, which was the previous version, to the official repositories today. It's no user error. I also added a note to the Firefox wiki entry (Firefox -> Multimedia playback).

Last edited by I0F (2022-02-17 20:48:47)

Offline

#13 2022-02-17 20:41:53

orlfman
Member
Registered: 2007-11-20
Posts: 121

Re: [solved]firefox can no longer play videos

I0F wrote:

Install the new ffmpeg4.4 package from the official repositories.

interesting. i see that in the repo's. i'll install it and see if that fixes it.
edit:
adding ffmpeg 4.4 from the repos along side ffmpeg 5 fixed it for me!

Last edited by orlfman (2022-02-17 20:42:56)

Offline

#14 2022-02-17 20:54:11

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,770

Re: [solved]firefox can no longer play videos

orlfman wrote:

did you not update? ffmpeg for me:

Just ran another update and got the new packages - it can take up to 24 hours for packages to propagate through the mirrors.
Still no issues though.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Online

#15 2022-02-17 20:59:13

unaboomer
Member
Registered: 2022-02-17
Posts: 7

Re: [solved]firefox can no longer play videos

Here's the SOLUTION:

Please install "ffmpeg-compat-58" from the AUR. It turns out that ffmpeg doesn't supply certain codecs or libraries any more. "ffmpeg-compat-58" supplies the missing codecs and libraries.

Offline

#16 2022-02-17 21:09:56

stanczew
Member
Registered: 2021-03-02
Posts: 46

Re: [solved]firefox can no longer play videos

Or just install ffmpeg4.4 from the official repos, as already described in previous posts and in the Wiki:
https://wiki.archlinux.org/title/Firefo … a_playback

Here is a bug report tracking this issue:
https://bugs.archlinux.org/task/73841

Offline

#17 2022-02-17 21:12:42

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,770

Re: [solved]firefox can no longer play videos

unaboomer wrote:

Here's the SOLUTION:

Please install "ffmpeg-compat-58" from the AUR. It turns out that ffmpeg doesn't supply certain codecs or libraries any more. "ffmpeg-compat-58" supplies the missing codecs and libraries.

So an upstream change then, not an Arch issue at all.
Thanks for confirming that.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Online

#18 2022-02-17 21:13:48

itaranto
Member
Registered: 2020-08-28
Posts: 7

Re: [solved]firefox can no longer play videos

d_fajardo wrote:
unaboomer wrote:

Where I come from, you take responsibility for the problems you cause.

But the rest of us don't have the problem. Videos work fine in Firefox in my setup both for my laptop and desktop both running on Archlinux.
So as already implied, there must be a problem with your setup so you should be the one to take responsibility.

Do not speak for "everyone", this is a problem affecting several users, not just him.

He was just rude, granted, but this is not a niche/weird configuration that only affects 1 or 2 users.

Offline

#19 2022-02-17 21:17:25

itaranto
Member
Registered: 2020-08-28
Posts: 7

Re: [solved]firefox can no longer play videos

I0F wrote:

Install the new ffmpeg4.4 package from the official repositories. You don't need to remove the regular ffmpeg package. Both can coexist and complement each other.

Edit: Just to clarify what the problem is: it seems ffmpeg 5.0 is not yet supported by some programs. As a workaround they added ffmpeg4.4, which was the previous version, to the official repositories today. It's no user error. I also added a note to the Firefox wiki entry (Firefox -> Multimedia playback).

That fixed it for me. Thanks!

Last edited by itaranto (2022-02-17 21:18:09)

Offline

#20 2022-02-17 21:21:41

unaboomer
Member
Registered: 2022-02-17
Posts: 7

Re: [solved]firefox can no longer play videos

itaranto wrote:
I0F wrote:

Install the new ffmpeg4.4 package from the official repositories. You don't need to remove the regular ffmpeg package. Both can coexist and complement each other.

Edit: Just to clarify what the problem is: it seems ffmpeg 5.0 is not yet supported by some programs. As a workaround they added ffmpeg4.4, which was the previous version, to the official repositories today. It's no user error. I also added a note to the Firefox wiki entry (Firefox -> Multimedia playback).

That fixed it for me. Thanks!

Absolutely! This is a much better solution, as it eliminates the dependency on AUR. So yes, installation of ffmpg4.4 is the right solution.

Offline

#21 2022-02-17 23:03:38

Nan123
Member
Registered: 2021-01-24
Posts: 76

Re: [solved]firefox can no longer play videos

Had the same issue on nightly, installing 4.4 fixed it for me too, thanks!

Offline

#22 2022-02-17 23:39:25

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 30,370
Website

Re: [solved]firefox can no longer play videos

No issues playing videos in Firefox:

┌─[Shiv ~]
└─╼ pacman -Q firefox ffmpeg ffmpeg4.4
firefox 97.0-1
ffmpeg 2:5.0-4
error: package 'ffmpeg4.4' was not found

Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#23 2022-02-17 23:59:32

stanczew
Member
Registered: 2021-03-02
Posts: 46

Re: [solved]firefox can no longer play videos

Did you test h264 videos? There is a test page linked in the Wiki for checking different codecs: http://demo.nimius.net/video_test/
As an example, without ffmpeg4.4 I can still play YouTube videos, but Twitch streams complain about missing codecs.

Offline

#24 2022-02-18 00:05:49

Nan123
Member
Registered: 2021-01-24
Posts: 76

Re: [solved]firefox can no longer play videos

stanczew wrote:

Did you test h264 videos? There is a test page linked in the Wiki for checking different codecs: http://demo.nimius.net/video_test/
As an example, without ffmpeg4.4 I can still play YouTube videos, but Twitch streams complain about missing codecs.

Hm, Reddit worked, thats all I checked. Going back to the page, MPEG4 still seems to be broken.

Offline

#25 2022-02-18 00:06:36

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 30,370
Website

Re: [solved]firefox can no longer play videos

No, no-one mentioned twitch, which I don't watch anyway. H264, WebM works fine without the additional package.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB