You are not logged in.

#1 2022-02-21 07:43:05

blum
Member
From: Plovdiv, Bulgaria
Registered: 2004-04-05
Posts: 77
Website

Problem with AUR update

Hello,

I'm using pacaur to automatcally update my AUR pachages, but for some time now, when I do:

$ pacaur -Syu -a

I get:

:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting AUR upgrade...
:: abootimg-git is not present in AUR -- skipping
:: anydesk-bin is not present in AUR -- skipping
:: auracle-git is not present in AUR -- skipping
:: aurget is not present in AUR -- skipping
:: cndrvcups-lb-bin is not present in AUR -- skipping
:: extract-dtb is not present in AUR -- skipping
:: google-chrome is not present in AUR -- skipping
:: google-earth-pro is not present in AUR -- skipping
:: kindd is not present in AUR -- skipping
:: libglade is not present in AUR -- skipping
:: libxdiff is not present in AUR -- skipping
.. and so on

it turns it says "not present in AUR" for each AUR package I have..
Tried to rebuild auracle-git, doesn't help. Also removed all pacaur cache ".cache/pacaur/*" - it doesn't help either.
Any ideas what could be wrong?

Thanks


..,

Offline

#2 2022-02-21 11:12:56

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,267

Re: Problem with AUR update

After rebuilding auracle-git you also did rebuild pacaur ?


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2022-02-21 11:27:00

blum
Member
From: Plovdiv, Bulgaria
Registered: 2004-04-05
Posts: 77
Website

Re: Problem with AUR update

Hmm, I just tried that too, same result.


..,

Offline

#4 2022-02-21 15:40:54

Alad
Wiki Admin/IRC Op
From: Bagelstan
Registered: 2014-05-04
Posts: 2,351
Website

Re: Problem with AUR update

pacaur is a shell script, rebuilding the package won't have an effect either way.

Check output from

pacman -Qmq
auracle sync -q

Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby

Offline

#5 2022-02-22 07:10:55

blum
Member
From: Plovdiv, Bulgaria
Registered: 2004-04-05
Posts: 77
Website

Re: Problem with AUR update

Hello,

pacman -Qmq lists foreign packages properly, everything looks fine there.
But $ auracle sync -q returns:

error: Too many package results.

and

$ auracle outdated

returns the same too
Hmm...


..,

Offline

#6 2022-02-22 13:14:45

Alad
Wiki Admin/IRC Op
From: Bagelstan
Registered: 2014-05-04
Posts: 2,351
Website

Re: Problem with AUR update

pacman -Qmq | wc -l

Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby

Offline

#7 2022-02-22 13:20:01

blum
Member
From: Plovdiv, Bulgaria
Registered: 2004-04-05
Posts: 77
Website

Re: Problem with AUR update

The AUR packages are not so huge number: 162


..,

Offline

#8 2022-02-22 16:20:37

InvisibleRasta
Member
Registered: 2017-04-12
Posts: 91

Re: Problem with AUR update

lol how did you end up with that insane amount of aur packages?

Offline

#9 2022-02-22 17:12:17

Alad
Wiki Admin/IRC Op
From: Bagelstan
Registered: 2014-05-04
Posts: 2,351
Website

Re: Problem with AUR update

lol how did you end up with that insane amount of aur packages?

That's not an insane amount, I would have something like 800 in my local repo. Anyway that remark is irrelevant. aurweb can (theoretically) return up to 5000 packages in a single multiinfo request. The limit in practice is about 500 in a POST request, and about 150 in a GET request.

162 packages is still fine, though:

curl "https://aur.archlinux.org/rpc?v=5&type=info&arg[]=010editor&arg[]=04b_21&arg[]=0ad-boongui&arg[]=0ad-community-maps-2&arg[]=0ad-delenda-est&arg[]=0ad-git&arg[]=0ad-data-git&arg[]=0ad-zh-lang&arg[]=0cc-famitracker&arg[]=0verkill-git&arg[]=0x0uploader&arg[]=0xdbe-eap&arg[]=0xffff&arg[]=10ff-git&arg[]=1337&arg[]=1oom-git&arg[]=1pass-autologin&arg[]=1pass-git&arg[]=1pass-hg&arg[]=1password&arg[]=1password-beta&arg[]=1password-cli&arg[]=1px-git&arg[]=2009scape&arg[]=2009scape-git&arg[]=2048-cli-git&arg[]=2048-curses&arg[]=2048-gui-git&arg[]=2048-puzzle-bash-git&arg[]=2048-py&arg[]=2048-qt&arg[]=2048-rs&arg[]=2048-vanced&arg[]=2048-vanced-git&arg[]=2048.c&arg[]=2048.c-git&arg[]=2048.cpp-git&arg[]=2048term-git&arg[]=20kly&arg[]=20kly-git&arg[]=2bwm&arg[]=2bwm-git&arg[]=2dtiler-bin&arg[]=2fa&arg[]=2gis&arg[]=2mandvd&arg[]=2p-kt&arg[]=2ping&arg[]=2plan-desktop&arg[]=3270-fonts&arg[]=35c3_char-dkms-git&arg[]=360cloud&arg[]=360player&arg[]=360zip&arg[]=389-admin&arg[]=389-admin-console&arg[]=389-adminutil&arg[]=389-console&arg[]=389-ds-console&arg[]=3delta-git&arg[]=3dfsb&arg[]=3dm2&arg[]=3dmeshmetric-bin&arg[]=3dsconv&arg[]=3dslicer&arg[]=3dslicer-bin&arg[]=3dslicer-nightly&arg[]=3dslicer-nightly-bin&arg[]=3dstool&arg[]=3dstool-git&arg[]=3dstools&arg[]=3mf2stl&arg[]=3mux&arg[]=3mux-git&arg[]=3ncode-git&arg[]=3proxy&arg[]=3to2&arg[]=4chan-downloader&arg[]=4dtris&arg[]=4kslideshowmaker&arg[]=4kstogram&arg[]=4ktokkit&arg[]=4kvideodownloader&arg[]=4kvideotomp3&arg[]=4kyoutubetomp3&arg[]=4l&arg[]=4nxci-bin&arg[]=4nxci-git&arg[]=4pane&arg[]=4scanner&arg[]=4store&arg[]=4suite&arg[]=4th&arg[]=555-boom&arg[]=5up&arg[]=602xmlfiller&arg[]=64gram-desktop&arg[]=64gram-desktop-bin&arg[]=6pm&arg[]=6sv11&arg[]=7-zip&arg[]=7-zip-bin&arg[]=7-zip-full&arg[]=7kaa&arg[]=7kaa-music&arg[]=8085-simulator&arg[]=8188eu-aircrack-dkms-git&arg[]=8188eu-dkms&arg[]=8188eu-dkms-git&arg[]=8188fu-dkms-git&arg[]=8188fu-kelebek333-dkms-git&arg[]=8189fs-git&arg[]=8192cu-dkms&arg[]=8192eu-dkms&arg[]=8192eu-dkms-git&arg[]=86box&arg[]=86box-appimage&arg[]=86box-git&arg[]=86box-roms&arg[]=86box-roms-git&arg[]=8723bs-git&arg[]=8723bs-git-dkms&arg[]=8cc-git&arg[]=915resolution&arg[]=9anime&arg[]=9base-git&arg[]=9front-drawterm-hg&arg[]=9menu&arg[]=9menu-git&arg[]=9mount&arg[]=9pfuse&arg[]=9wm&arg[]=a-git&arg[]=a-john-shots&arg[]=a2enmod-git&arg[]=a2ln&arg[]=a2pdf&arg[]=a2png&arg[]=a4tech-bloody-driver-git&arg[]=a7800&arg[]=a7xpg&arg[]=a850-fw&arg[]=aa3d&arg[]=aaaaxy&arg[]=aacgain-cvs&arg[]=aacplusenc&arg[]=aacskeys&arg[]=aaflib&arg[]=aafm-git&arg[]=aaphoto&arg[]=aarch64-binutils&arg[]=aarch64-elf-gcc-linaro-bin&arg[]=aarch64-elf-newlib-linaro-bin&arg[]=aarch64-gcc&arg[]=aarch64-gcc-bootstrap&arg[]=aarch64-glibc&arg[]=aarch64-linux-api-headers&arg[]=aarch64-linux-gnu-armcl-neon&arg[]=aarch64-linux-gnu-armcl-opencl%2Bneon&arg[]=aarch64-linux-gnu-gcc49-linaro-bin&arg[]=aarch64-linux-gnu-binutils224-linaro-bin&arg[]=aarch64-linux-gnu-eglibc219-linaro-bin"

gron results:

json = {};
json.resultcount = 162;
json.results = [];
json.results[0] = {};
json.results[0].Depends = [];
json.results[0].Depends[0] = "dvd+rw-tools";
json.results[0].Depends[1] = "dvdauthor";
json.results[0].Depends[2] = "exif";
json.results[0].Depends[3] = "ffmpeg";
json.results[0].Depends[4] = "ffmpegthumbnailer";
json.results[0].Depends[5] = "glu";
json.results[0].Depends[6] = "mencoder";
json.results[0].Depends[7] = "mjpegtools";
json.results[0].Depends[8] = "mplayer";
json.results[0].Depends[9] = "netpbm";
json.results[0].Depends[10] = "perl";
json.results[0].Depends[11] = "qt4";
json.results[0].Depends[12] = "sox";
...

Do you happen to have an AUR package with a two-letter name? The complete output of pacman -Qqm would be useful.

Last edited by Alad (2022-02-22 17:14:23)


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby

Offline

#10 2022-02-22 18:45:10

blum
Member
From: Plovdiv, Bulgaria
Registered: 2004-04-05
Posts: 77
Website

Re: Problem with AUR update

Hello,
Thank you Alad, here it is:

blum at Petra3 in [~]   
20:32:39 › pacman -Qqm
acestream-engine
acestream-launcher
android-sdk-build-tools
aspell-bg
attica-qt4
audio-recorder
auracle-git
aurget
automoc4
blackfire-agent
blackfire-cli
chemical-mime-data
cndrvcups-common-lb
cndrvcups-lb
dcadec
downgrade
espeak
ffmpeg-compat-54
flake
flashplugin
gamin
gimp-plugin-bimp
gnome-mime-data
google-chrome
google-earth-pro
hunspell-bg
icu67
idnkit
imagewriter
lash
lcms
lib32-libstdc++5
libavutil-52
libdbusmenu-qt4
libdvbpsi8
libechonest
libfprint-1
libglade
libpamac-aur
libquicktime
libtorrent-ps
libtxc_dxtn
libunicodenames
libx264-142
mailhog-bin
memtest86-efi
mozilla-common
openslp
otf-hasklig
pacaur
pamac-aur
pangox-compat
pepper-flash
php71
php72
php72-apache
php72-bcmath
php72-bz2
php72-calendar
php72-cgi
php72-cli
php72-ctype
php72-curl
php72-dba
php72-dblib
php72-dom
php72-embed
php72-enchant
php72-exif
php72-fileinfo
php72-firebird
php72-fpm
php72-ftp
php72-gd
php72-gettext
php72-gmp
php72-iconv
php72-imap
php72-interbase
php72-intl
php72-json
php72-ldap
php72-mbstring
php72-mcrypt
php72-mysql
php72-odbc
php72-opcache
php72-pcntl
php72-pdo
php72-pear
php72-pecl
php72-pgsql
php72-phar
php72-phpdbg
php72-posix
php72-pspell
php72-recode
php72-shmop
php72-simplexml
php72-snmp
php72-soap
php72-sockets
php72-sodium
php72-sqlite
php72-sysvmsg
php72-sysvsem
php72-sysvshm
php72-tidy
php72-tokenizer
php72-wddx
php72-xml
php72-xmlreader
php72-xmlrpc
php72-xmlwriter
php72-xsl
php72-zip
php73
php73-apache
php73-cgi
php73-dblib
php73-embed
php73-enchant
php73-fpm
php73-gd
php73-imagick
php73-imap
php73-intl
php73-odbc
php73-pgsql
php73-phpdbg
php73-pspell
php73-snmp
php73-sodium
php73-sqlite
php73-tidy
php73-xsl
qjson
redis-desktop-manager
rtorrent-ps
rttr
sbsms
sfnt2woff
skypeforlinux-stable-bin
slack-desktop
sopcast-player
sphinxbase
sublime-text-dev
subtitlecomposer-git
tcllib
ttf-google-fonts-git
ttf-jetbrains-mono-git
ttf-merriweather
ttf-merriweather-sans
ttf-ms-fonts
ttf-oswald
ttf-quintessential
ttf-signika
ttf-vista-fonts
viber
virtualbox-ext-oracle
wpa_actiond
xvkbd

I know some of these are obsolete, but it shouldn't be a problem.

Do you happen to have an AUR package with a two-letter name?

Mm.. no. hmm
And one more thing.. I also have another computer on Manjaro with quite similar app setup, and the same problem is present there as well.


..,

Offline

#11 2022-02-22 18:45:37

Alad
Wiki Admin/IRC Op
From: Bagelstan
Registered: 2014-05-04
Posts: 2,351
Website

Re: Problem with AUR update

Also, post output from

 AURACLE_DEBUG=1 auracle sync -q

Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby

Offline

#12 2022-02-22 18:49:33

blum
Member
From: Plovdiv, Bulgaria
Registered: 2004-04-05
Posts: 77
Website

Re: Problem with AUR update

And I also tried "$ pamac update -a" and it returns:

20:47:39 › pamac upgrade -a
Preparing...
Failed to query https://aur.archlinux.org/rpc/?v=5&type=info&arg[]=acestream-engine&arg[]=acestream-launcher&arg[]=android-sdk-build-tools&arg[]=aspell-bg&arg[]=attica-qt4&arg[]=audio-recorder&arg[]=auracle-git&arg[]=aurget&arg[]=automoc4&arg[]=blackfire-agent&arg[]=blackfire-cli&arg[]=chemical-mime-data&arg[]=cndrvcups-common-lb&arg[]=cndrvcups-lb&arg[]=dcadec&arg[]=downgrade&arg[]=espeak&arg[]=ffmpeg-compat-54&arg[]=flake&arg[]=flashplugin&arg[]=gamin&arg[]=gimp-plugin-bimp&arg[]=gnome-mime-data&arg[]=google-chrome&arg[]=google-earth-pro&arg[]=hunspell-bg&arg[]=icu67&arg[]=idnkit&arg[]=imagewriter&arg[]=lash&arg[]=lcms&arg[]=lib32-libstdc%2B%2B5&arg[]=libavutil-52&arg[]=libdbusmenu-qt4&arg[]=libdvbpsi8&arg[]=libechonest&arg[]=libfprint-1&arg[]=libglade&arg[]=libpamac-aur&arg[]=libquicktime&arg[]=libtorrent-ps&arg[]=libtxc_dxtn&arg[]=libunicodenames&arg[]=libx264-142&arg[]=mailhog-bin&arg[]=memtest86-efi&arg[]=mozilla-common&arg[]=openslp&arg[]=otf-hasklig&arg[]=pacaur&arg[]=pamac-aur&arg[]=pangox-compat&arg[]=pepper-flash&arg[]=php71&arg[]=php72&arg[]=php72-apache&arg[]=php72-bcmath&arg[]=php72-bz2&arg[]=php72-calendar&arg[]=php72-cgi&arg[]=php72-cli&arg[]=php72-ctype&arg[]=php72-curl&arg[]=php72-dba&arg[]=php72-dblib&arg[]=php72-dom&arg[]=php72-embed&arg[]=php72-enchant&arg[]=php72-exif&arg[]=php72-fileinfo&arg[]=php72-firebird&arg[]=php72-fpm&arg[]=php72-ftp&arg[]=php72-gd&arg[]=php72-gettext&arg[]=php72-gmp&arg[]=php72-iconv&arg[]=php72-imap&arg[]=php72-interbase&arg[]=php72-intl&arg[]=php72-json&arg[]=php72-ldap&arg[]=php72-mbstring&arg[]=php72-mcrypt&arg[]=php72-mysql&arg[]=php72-odbc&arg[]=php72-opcache&arg[]=php72-pcntl&arg[]=php72-pdo&arg[]=php72-pear&arg[]=php72-pecl&arg[]=php72-pgsql&arg[]=php72-phar&arg[]=php72-phpdbg&arg[]=php72-posix&arg[]=php72-pspell&arg[]=php72-recode&arg[]=php72-shmop&arg[]=php72-simplexml&arg[]=php72-snmp&arg[]=php72-soap&arg[]=php72-sockets&arg[]=php72-sodium&arg[]=php72-sqlite&arg[]=php72-sysvmsg&arg[]=php72-sysvsem&arg[]=php72-sysvshm&arg[]=php72-tidy&arg[]=php72-tokenizer&arg[]=php72-wddx&arg[]=php72-xml&arg[]=php72-xmlreader&arg[]=php72-xmlrpc&arg[]=php72-xmlwriter&arg[]=php72-xsl&arg[]=php72-zip&arg[]=php73&arg[]=php73-apache&arg[]=php73-cgi&arg[]=php73-dblib&arg[]=php73-embed&arg[]=php73-enchant&arg[]=php73-fpm&arg[]=php73-gd&arg[]=php73-imagick&arg[]=php73-imap&arg[]=php73-intl&arg[]=php73-odbc&arg[]=php73-pgsql&arg[]=php73-phpdbg&arg[]=php73-pspell&arg[]=php73-snmp&arg[]=php73-sodium&arg[]=php73-sqlite&arg[]=php73-tidy&arg[]=php73-xsl&arg[]=qjson&arg[]=redis-desktop-manager&arg[]=rtorrent-ps&arg[]=rttr&arg[]=sbsms&arg[]=sfnt2woff&arg[]=skypeforlinux-stable-bin&arg[]=slack-desktop&arg[]=sopcast-player&arg[]=sphinxbase&arg[]=sublime-text-dev&arg[]=subtitlecomposer-git&arg[]=tcllib&arg[]=ttf-google-fonts-git&arg[]=ttf-jetbrains-mono-git&arg[]=ttf-merriweather&arg[]=ttf-merriweather-sans&arg[]=ttf-ms-fonts&arg[]=ttf-oswald&arg[]=ttf-quintessential&arg[]=ttf-signika&arg[]=ttf-vista-fonts&arg[]=viber&arg[]=virtualbox-ext-oracle&arg[]=wpa_actiond&arg[]=xvkbd from AUR: Too many package results.


..,

Offline

#13 2022-02-22 18:53:14

blum
Member
From: Plovdiv, Bulgaria
Registered: 2004-04-05
Posts: 77
Website

Re: Problem with AUR update

Alad wrote:

Also, post output from

 AURACLE_DEBUG=1 auracle sync -q

Here it is: https://gist.github.com/Blum/d472690df5 … 84bb612c74


..,

Offline

#14 2022-02-22 18:57:32

Alad
Wiki Admin/IRC Op
From: Bagelstan
Registered: 2014-05-04
Posts: 2,351
Website

Re: Problem with AUR update

I did a bisection on your packages and got the following:

diff -u <(cat foo | head -130) <(cat foo | head -131)
--- /dev/fd/63  2022-02-22 19:58:15.210168738 +0100
+++ /dev/fd/62  2022-02-22 19:58:15.200168738 +0100
@@ -128,3 +128,4 @@
 php73-odbc
 php73-pgsql
 php73-phpdbg
+php73-pspell
$ cat foo | head -130 | aur query -t info - | jq .resultcount
130
$ cat foo | head -131 | aur query -t info - | jq .resultcount
{"error":"Too many package results.","resultcount":0,"results":[],"type":"error","version":5}

This sounds like something you should report with aurweb: https://gitlab.archlinux.org/archlinux/aurweb/-/issues

Last edited by Alad (2022-02-22 18:58:08)


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby

Offline

#15 2022-02-22 19:05:05

blum
Member
From: Plovdiv, Bulgaria
Registered: 2004-04-05
Posts: 77
Website

Re: Problem with AUR update

OK, right away. Thank you!


..,

Offline

#16 2022-02-23 22:11:44

kevr
Member
From: CA, USA
Registered: 2010-05-01
Posts: 23
Website

Re: Problem with AUR update

Prepare your pitchforks and molotov cocktails for kevr. Thanks for bringing this up in the repository, blum: https://gitlab.archlinux.org/archlinux/ … issues/314

Edit: Fix is merged and deployed out in the v6.0.19 hot-patch. Please verify that the issue is resolved when you can. And... apologies sad

Last edited by kevr (2022-02-23 22:48:53)


Kevin Morris <kevr@0cost.org>

Hangs out in #archlinux-aurweb. Loves the AUR.

Offline

#17 2022-02-24 00:04:08

Alad
Wiki Admin/IRC Op
From: Bagelstan
Registered: 2014-05-04
Posts: 2,351
Website

Re: Problem with AUR update

Very nice \o/


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby

Offline

#18 2022-02-24 07:51:27

blum
Member
From: Plovdiv, Bulgaria
Registered: 2004-04-05
Posts: 77
Website

Re: Problem with AUR update

Hello,
I can confirm it is all working fine for me now.
Thank you for your work and support!
Cheers


..,

Offline

Board footer

Powered by FluxBB