You are not logged in.

#1 2022-02-22 22:12:08

gitarthasarmac9
Member
Registered: 2020-08-02
Posts: 20

Downgrade boost to a specific version

For compiling a certain package I need `boost: 1.76.0-1`, however on my system I have `boost:1.78.0-1`. I tried to downgrade `boost` using the downgrade utility in AUR, but it fails with  `warning: cannot resolve "boost-libs=1.76.0", a dependency of "boost"`. I also tried to downgrade both `boost` and `boost-libs` but that also results in a dependency problem. Is there any way to resolve this?

Offline

#2 2022-02-22 22:18:01

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,310

Re: Downgrade boost to a specific version

Downgrading packaged libraries is bad. What you would need to do is build the version you need and install it alongside the regular packaged version.

Offline

#3 2022-02-22 22:30:28

loqs
Member
Registered: 2014-03-06
Posts: 14,910

Re: Downgrade boost to a specific version

What is this package that requires boost 1.76.0?

Offline

#4 2022-04-29 23:48:33

emmanuelgodwin_
Member
Registered: 2020-10-17
Posts: 2

Re: Downgrade boost to a specific version

Scimmia wrote:

Downgrading packaged libraries is bad. What you would need to do is build the version you need and install it alongside the regular packaged version.

gdb fails to start on my machine.

gdb: error while loading shared libraries: libboost_regex.so.1.76.0: cannot open shared object file: No such file or directory

what do i do in this case? Thanks.

Offline

#5 2022-04-30 02:06:09

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,310

Re: Downgrade boost to a specific version

You update the entire system.

Offline

#6 2022-05-23 00:16:05

emmanuelgodwin_
Member
Registered: 2020-10-17
Posts: 2

Re: Downgrade boost to a specific version

Updated the system and it worked. thanks!

Offline

Board footer

Powered by FluxBB