You are not logged in.

#1 2022-02-18 13:14:40

BottleNeck
Member
Registered: 2019-03-12
Posts: 32

[BUG] NFS stoped working after update

I'm having the hardest time getting my nfs to return to work. I have 2 systems at home. Let's just say sys A and sys B. I had trouble getting onto my NFS server with client A that i frequently update. After some fruitless messing about i found that system B does still get to the nfs. So i did the stupid thing and updated system B. Result: system B can also no longer get to the NFS server :)

I now qualify as idiot.

This does however preset me with a direction from the problem. It must have something to do with the packages that got updated in system B, pacman log:

[2022-02-18T13:23:23+0100] [PACMAN] Running 'pacman -Syu'
[2022-02-18T13:23:23+0100] [PACMAN] synchronizing package lists
[2022-02-18T13:23:25+0100] [PACMAN] starting full system upgrade
[2022-02-18T13:27:18+0100] [PACMAN] Running 'pacman -Syu'
[2022-02-18T13:27:18+0100] [PACMAN] synchronizing package lists
[2022-02-18T13:27:20+0100] [PACMAN] starting full system upgrade
[2022-02-18T13:31:53+0100] [PACMAN] Running 'pacman -Syu'
[2022-02-18T13:31:53+0100] [PACMAN] synchronizing package lists
[2022-02-18T13:31:54+0100] [PACMAN] starting full system upgrade
[2022-02-18T13:32:16+0100] [PACMAN] Running 'pacman -Syu'
[2022-02-18T13:32:16+0100] [PACMAN] synchronizing package lists
[2022-02-18T13:32:16+0100] [PACMAN] starting full system upgrade
[2022-02-18T13:34:19+0100] [PACMAN] Running 'pacman -Syu'
[2022-02-18T13:34:19+0100] [PACMAN] synchronizing package lists
[2022-02-18T13:34:19+0100] [PACMAN] starting full system upgrade
[2022-02-18T13:35:46+0100] [PACMAN] Running 'pacman -Syyu'
[2022-02-18T13:35:46+0100] [PACMAN] synchronizing package lists
[2022-02-18T13:35:49+0100] [PACMAN] starting full system upgrade
[2022-02-18T13:36:48+0100] [PACMAN] Running 'pacman -Syyu'
[2022-02-18T13:36:48+0100] [PACMAN] synchronizing package lists
[2022-02-18T13:36:53+0100] [PACMAN] starting full system upgrade
[2022-02-18T13:37:56+0100] [PACMAN] Running 'pacman -Sc'
[2022-02-18T13:38:14+0100] [PACMAN] Running 'pacman -Syyu'
[2022-02-18T13:38:14+0100] [PACMAN] synchronizing package lists
[2022-02-18T13:38:18+0100] [PACMAN] starting full system upgrade
[2022-02-18T13:41:30+0100] [PACMAN] Running 'pacman -Syyu'
[2022-02-18T13:41:30+0100] [PACMAN] synchronizing package lists
[2022-02-18T13:41:32+0100] [PACMAN] starting full system upgrade
[2022-02-18T13:42:17+0100] [PACMAN] Running 'pacman -Syyu'
[2022-02-18T13:42:17+0100] [PACMAN] synchronizing package lists
[2022-02-18T13:42:52+0100] [PACMAN] starting full system upgrade
[2022-02-18T13:44:47+0100] [ALPM] running '60-mkinitcpio-remove.hook'...
[2022-02-18T13:44:47+0100] [ALPM] transaction started
[2022-02-18T13:44:47+0100] [ALPM] upgraded linux-api-headers (5.12.3-1 -> 5.16.8-1)
[2022-02-18T13:44:47+0100] [ALPM] upgraded iana-etc (20220110-1 -> 20220205-1)
[2022-02-18T13:44:48+0100] [ALPM] warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
[2022-02-18T13:44:48+0100] [ALPM] upgraded glibc (2.33-5 -> 2.35-2)
[2022-02-18T13:44:48+0100] [ALPM-SCRIPTLET] Generating locales...
[2022-02-18T13:45:02+0100] [ALPM-SCRIPTLET]   en_US.UTF-8... done
[2022-02-18T13:45:21+0100] [ALPM-SCRIPTLET]   zh_CN.UTF-8... done
[2022-02-18T13:45:21+0100] [ALPM-SCRIPTLET] Generation complete.
[2022-02-18T13:45:21+0100] [ALPM] upgraded attr (2.5.1-1 -> 2.5.1-2)
[2022-02-18T13:45:21+0100] [ALPM] upgraded acl (2.3.1-1 -> 2.3.1-2)
[2022-02-18T13:45:21+0100] [ALPM] upgraded alsa-card-profiles (1:0.3.43-5 -> 1:0.3.47-1)
[2022-02-18T13:45:23+0100] [ALPM] upgraded gcc-libs (11.1.0-3 -> 11.2.0-3)
[2022-02-18T13:45:23+0100] [ALPM] upgraded aom (3.2.0-1 -> 3.3.0-1)
[2022-02-18T13:45:24+0100] [ALPM] upgraded archlinux-appstream-data (20220107-1 -> 20220211-1)
[2022-02-18T13:45:24+0100] [ALPM] upgraded archlinux-keyring (20220118-1 -> 20220125-1)
[2022-02-18T13:45:24+0100] [ALPM-SCRIPTLET] ==> Appending keys from archlinux.gpg...
[2022-02-18T13:45:32+0100] [ALPM-SCRIPTLET] ==> Updating trust database...
[2022-02-18T13:45:32+0100] [ALPM-SCRIPTLET] gpg: next trustdb check due at 2022-05-06
[2022-02-18T13:45:32+0100] [ALPM-SCRIPTLET] ==> Updating trust database...
[2022-02-18T13:45:32+0100] [ALPM-SCRIPTLET] gpg: next trustdb check due at 2022-05-06
[2022-02-18T13:45:32+0100] [ALPM] upgraded libcap-ng (0.8.2-6 -> 0.8.2-7)
[2022-02-18T13:45:32+0100] [ALPM] upgraded util-linux-libs (2.37.2-5 -> 2.37.4-1)
[2022-02-18T13:45:33+0100] [ALPM] upgraded ncurses (6.3-1 -> 6.3-2)
[2022-02-18T13:45:33+0100] [ALPM] upgraded readline (8.1.001-1 -> 8.1.002-1)
[2022-02-18T13:45:33+0100] [ALPM] upgraded e2fsprogs (1.46.5-1 -> 1.46.5-3)
[2022-02-18T13:45:33+0100] [ALPM] upgraded libldap (2.6.0-2 -> 2.6.1-1)
[2022-02-18T13:45:33+0100] [ALPM] upgraded audit (3.0.6-5 -> 3.0.7-1)
[2022-02-18T13:45:33+0100] [ALPM] upgraded zstd (1.5.1-2 -> 1.5.2-2)
[2022-02-18T13:45:33+0100] [ALPM] upgraded findutils (4.8.0-1 -> 4.9.0-1)
[2022-02-18T13:45:33+0100] [ALPM] upgraded libxcrypt (4.4.27-1 -> 4.4.28-1)
[2022-02-18T13:45:33+0100] [ALPM] upgraded libcap (2.62-1 -> 2.63-2)
[2022-02-18T13:45:33+0100] [ALPM] upgraded libp11-kit (0.24.0-2 -> 0.24.1-1)
[2022-02-18T13:45:33+0100] [ALPM] upgraded libgpg-error (1.43-1 -> 1.44-1)
[2022-02-18T13:45:33+0100] [ALPM] upgraded systemd-libs (250.3-1 -> 250.3-4)
[2022-02-18T13:45:33+0100] [ALPM] upgraded p11-kit (0.24.0-2 -> 0.24.1-1)
[2022-02-18T13:45:33+0100] [ALPM] upgraded ca-certificates-mozilla (3.74-1 -> 3.75-1)
[2022-02-18T13:45:34+0100] [ALPM] upgraded curl (7.81.0-1 -> 7.81.0-2)
[2022-02-18T13:45:34+0100] [ALPM] upgraded libelf (0.186-2 -> 0.186-5)
[2022-02-18T13:45:34+0100] [ALPM] upgraded binutils (2.36.1-3 -> 2.38-3)
[2022-02-18T13:45:34+0100] [ALPM] upgraded libsysprof-capture (3.42.1-2 -> 3.42.1-3)
[2022-02-18T13:45:34+0100] [ALPM] upgraded glib2 (2.70.2-2 -> 2.70.4-1)
[2022-02-18T13:45:35+0100] [ALPM] upgraded harfbuzz (3.2.0-1 -> 3.4.0-1)
[2022-02-18T13:45:35+0100] [ALPM] upgraded expat (2.4.3-1 -> 2.4.4-1)
[2022-02-18T13:45:35+0100] [ALPM] upgraded fontconfig (2:2.13.94-2 -> 2:2.13.96-1)
[2022-02-18T13:45:35+0100] [ALPM-SCRIPTLET] Rebuilding fontconfig cache...
[2022-02-18T13:45:37+0100] [ALPM] upgraded pango (1:1.50.3-1 -> 1:1.50.4-1)
[2022-02-18T13:45:38+0100] [ALPM] upgraded xkeyboard-config (2.34-1 -> 2.35.1-1)
[2022-02-18T13:45:38+0100] [ALPM] upgraded libxkbcommon (1.3.1-1 -> 1.4.0-1)
[2022-02-18T13:45:38+0100] [ALPM] upgraded librsvg (2:2.52.5-1 -> 2:2.52.6-1)
[2022-02-18T13:45:39+0100] [ALPM] upgraded llvm-libs (13.0.0-6 -> 13.0.1-1)
[2022-02-18T13:45:39+0100] [ALPM] upgraded vulkan-icd-loader (1.2.202-1 -> 1.2.203-1)
[2022-02-18T13:45:40+0100] [ALPM] upgraded mesa (21.3.4-1 -> 21.3.6-1)
[2022-02-18T13:45:40+0100] [ALPM] upgraded lcms2 (2.12-1 -> 2.13.1-1)
[2022-02-18T13:45:40+0100] [ALPM] upgraded device-mapper (2.03.14-2 -> 2.03.15-1)
[2022-02-18T13:45:40+0100] [ALPM] upgraded popt (1.18-2 -> 1.18-3)
[2022-02-18T13:45:40+0100] [ALPM] upgraded json-c (0.15-2 -> 0.15-3)
[2022-02-18T13:45:40+0100] [ALPM] upgraded cryptsetup (2.4.3-1 -> 2.4.3-2)
[2022-02-18T13:45:40+0100] [ALPM] upgraded kmod (29-1 -> 29-2)
[2022-02-18T13:45:40+0100] [ALPM] upgraded hwdata (0.355-1 -> 0.356-1)
[2022-02-18T13:45:40+0100] [ALPM] upgraded shadow (4.8.1-4 -> 4.11.1-1)
[2022-02-18T13:45:41+0100] [ALPM] upgraded util-linux (2.37.2-5 -> 2.37.4-1)
[2022-02-18T13:45:41+0100] [ALPM] upgraded libpcap (1.10.1-1 -> 1.10.1-2)
[2022-02-18T13:45:42+0100] [ALPM] upgraded systemd (250.3-1 -> 250.3-4)
[2022-02-18T13:45:42+0100] [ALPM] upgraded libcolord (1.4.5-4 -> 1.4.6-1)
[2022-02-18T13:45:42+0100] [ALPM] upgraded libusb (1.0.24-2 -> 1.0.25-2)
[2022-02-18T13:45:42+0100] [ALPM] upgraded gdbm (1.22-1 -> 1.23-1)
[2022-02-18T13:45:42+0100] [ALPM] upgraded libcups (1:2.4.0-4 -> 1:2.4.1-1)
[2022-02-18T13:45:42+0100] [ALPM] upgraded gtk-update-icon-cache (1:4.6.0-2 -> 1:4.6.1-2)
[2022-02-18T13:45:43+0100] [ALPM] upgraded gtk3 (1:3.24.31-1 -> 1:3.24.31-3)
[2022-02-18T13:45:43+0100] [ALPM] upgraded libical (3.0.13-1 -> 3.0.14-1)
[2022-02-18T13:45:43+0100] [ALPM] upgraded nss (3.74-1 -> 3.75-1)
[2022-02-18T13:45:43+0100] [ALPM] upgraded libnsl (2.0.0-1 -> 2.0.0-2)
[2022-02-18T13:45:45+0100] [ALPM] upgraded python (3.10.1-2 -> 3.10.2-1)
[2022-02-18T13:45:45+0100] [ALPM] upgraded blueman (2.2.3-2 -> 2.2.4-1)
[2022-02-18T13:45:45+0100] [ALPM] upgraded btop (1.2.0-1 -> 1.2.3-1)
[2022-02-18T13:45:45+0100] [ALPM] upgraded opus (1.3.1-2 -> 1.3.1-3)
[2022-02-18T13:45:45+0100] [ALPM] upgraded jack2 (1.9.20-3 -> 1.9.20-4)
[2022-02-18T13:45:45+0100] [ALPM] upgraded libwebp (1.2.1-2 -> 1.2.2-1)
[2022-02-18T13:45:45+0100] [ALPM] upgraded x264 (3:0.163.r3060.5db6aa6-1 -> 3:0.164.r3081.19856cc-1)
[2022-02-18T13:45:45+0100] [ALPM] upgraded svt-av1 (0.8.7-1 -> 0.9.0-1)
[2022-02-18T13:45:45+0100] [ALPM] upgraded vmaf (1.5.3-1 -> 2.3.0-1)
[2022-02-18T13:45:46+0100] [ALPM] upgraded ffmpeg (2:4.4.1-1 -> 2:5.0-4)
[2022-02-18T13:45:46+0100] [ALPM] upgraded chromaprint (1.5.1-1 -> 1.5.1-2)
[2022-02-18T13:45:46+0100] [ALPM] upgraded libarchive (3.5.2-2 -> 3.6.0-1)
[2022-02-18T13:45:48+0100] [ALPM] upgraded cmake (3.22.1-5 -> 3.22.2-1)
[2022-02-18T13:45:49+0100] [ALPM] upgraded js78 (78.15.0-2 -> 78.15.0-3)
[2022-02-18T13:45:50+0100] [ALPM] upgraded polkit (0.120-3 -> 0.120-4)
[2022-02-18T13:45:50+0100] [ALPM] upgraded colord (1.4.5-4 -> 1.4.6-1)
[2022-02-18T13:45:51+0100] [ALPM] upgraded containerd (1.5.9-2 -> 1.6.0-2)
[2022-02-18T13:45:51+0100] [ALPM] upgraded elfutils (0.186-2 -> 0.186-5)
[2022-02-18T13:45:51+0100] [ALPM] upgraded faac (1.30-2 -> 1.30-3)
[2022-02-18T13:45:51+0100] [ALPM] upgraded fakeroot (1.26-1 -> 1.27-1)
[2022-02-18T13:45:52+0100] [ALPM] upgraded libtool (2.4.6+42+gb88cebd5-16 -> 2.4.6+59+gb55b1cc8-2)
[2022-02-18T13:45:52+0100] [ALPM] upgraded fftw (3.3.10-1 -> 3.3.10-2)
[2022-02-18T13:45:52+0100] [ALPM] installed ffmpeg4.4 (4.4.1-3)
[2022-02-18T13:45:55+0100] [ALPM] upgraded firefox (96.0.1-1 -> 97.0.1-1)
[2022-02-18T13:45:55+0100] [ALPM] upgraded fluidsynth (2.2.4-1 -> 2.2.5-1)
[2022-02-18T13:45:55+0100] [ALPM] upgraded mpfr (4.1.0.p13-1 -> 4.1.0.p13-2)
[2022-02-18T13:45:55+0100] [ALPM] upgraded libmpc (1.2.1-1 -> 1.2.1-2)
[2022-02-18T13:45:58+0100] [ALPM] upgraded gcc (11.1.0-3 -> 11.2.0-3)
[2022-02-18T13:45:59+0100] [ALPM] upgraded ghostscript (9.55.0-3 -> 9.55.0-4)
[2022-02-18T13:45:59+0100] [ALPM] upgraded git (2.34.1-1 -> 2.35.1-1)
[2022-02-18T13:46:00+0100] [ALPM] upgraded glib2-docs (2.70.2-2 -> 2.70.4-1)
[2022-02-18T13:46:00+0100] [ALPM] upgraded gpgme (1.16.0-3 -> 1.17.0-2)
[2022-02-18T13:46:00+0100] [ALPM] upgraded gstreamer (1.18.5-1 -> 1.20.0-2)
[2022-02-18T13:46:00+0100] [ALPM] upgraded gst-plugins-base-libs (1.18.5-1 -> 1.20.0-2)
[2022-02-18T13:46:00+0100] [ALPM] upgraded gst-plugins-base (1.18.5-1 -> 1.20.0-2)
[2022-02-18T13:46:00+0100] [ALPM] upgraded libde265 (1.0.8-1 -> 1.0.8-2)
[2022-02-18T13:46:00+0100] [ALPM] upgraded imlib2 (1.7.5-1 -> 1.8.0-1)
[2022-02-18T13:46:00+0100] [ALPM] upgraded gst-plugins-good (1.18.5-2 -> 1.20.0-2)
[2022-02-18T13:46:00+0100] [ALPM] upgraded gst-plugins-ugly (1.18.5-2 -> 1.20.0-2)
[2022-02-18T13:46:00+0100] [ALPM] upgraded gst-python (1.18.5-3 -> 1.20.0-2)
[2022-02-18T13:46:00+0100] [ALPM] upgraded intel-ucode (20210608-1 -> 20220207-1)
[2022-02-18T13:46:00+0100] [ALPM] upgraded tdb (1.4.5-3 -> 1.4.6-1)
[2022-02-18T13:46:00+0100] [ALPM] upgraded ldb (2:2.4.1-4 -> 2:2.4.2-1)
[2022-02-18T13:46:01+0100] [ALPM] upgraded libbsd (0.11.3-1 -> 0.11.5-1)
[2022-02-18T13:46:01+0100] [ALPM] upgraded libgee (0.20.4-1 -> 0.20.5-1)
[2022-02-18T13:46:01+0100] [ALPM] upgraded libopenmpt (0.6.0-1 -> 0.6.1-1)
[2022-02-18T13:46:01+0100] [ALPM] upgraded spirv-tools (2021.3-1 -> 2021.4-1)
[2022-02-18T13:46:01+0100] [ALPM] upgraded libplacebo (4.157.0-1 -> 4.192.1-1)
[2022-02-18T13:46:01+0100] [ALPM] upgraded libraqm (0.8.0-1 -> 0.9.0-1)
[2022-02-18T13:46:01+0100] [ALPM] upgraded libsigc++ (2.10.7-2 -> 2.10.8-1)
[2022-02-18T13:46:01+0100] [ALPM] upgraded libwacom (2.0.0-2 -> 2.1.0-1)
[2022-02-18T13:46:01+0100] [ALPM] upgraded libwnck3 (40.0-1 -> 40.1-1)
[2022-02-18T13:46:01+0100] [ALPM] upgraded libxkbcommon-x11 (1.3.1-1 -> 1.4.0-1)
[2022-02-18T13:46:01+0100] [ALPM] upgraded libxslt (1.1.34-6 -> 1.1.35-1)
[2022-02-18T13:46:01+0100] [ALPM] upgraded licenses (20200427-1 -> 20220125-1)
[2022-02-18T13:46:01+0100] [ALPM] installed linux-firmware-whence (20220209.6342082-1)
[2022-02-18T13:46:07+0100] [ALPM] upgraded linux-firmware (20211216.f682ecb-1 -> 20220209.6342082-1)
[2022-02-18T13:46:07+0100] [ALPM] upgraded mkinitcpio-busybox (1.34.1-1 -> 1.35.0-1)
[2022-02-18T13:46:18+0100] [ALPM] upgraded linux-lts (5.15.15-1 -> 5.15.24-1)
[2022-02-18T13:46:19+0100] [ALPM] upgraded lirc (1:0.10.1-10 -> 1:0.10.1-12)
[2022-02-18T13:46:19+0100] [ALPM] upgraded luajit (2.0.5-3 -> 2.1.0.beta3.r384.g1d7b5029-1)
[2022-02-18T13:46:19+0100] [ALPM] upgraded mariadb-libs (10.6.5-2 -> 10.6.7-1)
[2022-02-18T13:46:19+0100] [ALPM] upgraded python-setuptools (1:59.1.1-1 -> 1:59.3.0-1)
[2022-02-18T13:46:19+0100] [ALPM] upgraded meson (0.61.1-1 -> 0.61.2-1)
[2022-02-18T13:46:19+0100] [ALPM] upgraded openal (1.21.1-2 -> 1.21.1-3)
[2022-02-18T13:46:20+0100] [ALPM] upgraded python-dnspython (1:2.1.0-3 -> 1:2.2.0-1)
[2022-02-18T13:46:20+0100] [ALPM] upgraded python-zipp (3.6.0-3 -> 3.7.0-1)
[2022-02-18T13:46:20+0100] [ALPM] upgraded smbclient (4.15.3-2 -> 4.15.5-1)
[2022-02-18T13:46:20+0100] [ALPM] upgraded pipewire (1:0.3.43-5 -> 1:0.3.47-1)
[2022-02-18T13:46:20+0100] [ALPM] upgraded mpd (0.23.5-1 -> 0.23.5-2)
[2022-02-18T13:46:20+0100] [ALPM] upgraded recode (3.7.9-1 -> 3.7.11-1)
[2022-02-18T13:46:20+0100] [ALPM] upgraded mplayer (38322-2 -> 38322-3)
[2022-02-18T13:46:20+0100] [ALPM] upgraded mujs (1.2.0-1 -> 1.2.0-2)
[2022-02-18T13:46:20+0100] [ALPM] upgraded rubberband (2.0.0-1 -> 2.0.2-1)
[2022-02-18T13:46:21+0100] [ALPM] upgraded mpv (1:0.34.1-1 -> 1:0.34.1-3)
[2022-02-18T13:46:21+0100] [ALPM] upgraded nano (6.0-1 -> 6.1-1)
[2022-02-18T13:46:21+0100] [ALPM] upgraded nfsidmap (2.5.4-2 -> 2.6.1-1)
[2022-02-18T13:46:21+0100] [ALPM] warning: /etc/nfsmount.conf installed as /etc/nfsmount.conf.pacnew
[2022-02-18T13:46:21+0100] [ALPM] upgraded nfs-utils (2.5.4-2 -> 2.6.1-1)
[2022-02-18T13:46:21+0100] [ALPM] upgraded protobuf (3.19.2-1 -> 3.19.4-1)
[2022-02-18T13:46:21+0100] [ALPM] upgraded python-idna (3.3-3 -> 3.3-4)
[2022-02-18T13:46:21+0100] [ALPM] upgraded python-lxml (4.6.5-1 -> 4.7.1-1)
[2022-02-18T13:46:21+0100] [ALPM] upgraded python-pillow (9.0.0-1 -> 9.0.1-1)
[2022-02-18T13:46:21+0100] [ALPM] upgraded python-urllib3 (1.26.7-5 -> 1.26.8-1)
[2022-02-18T13:46:21+0100] [ALPM] upgraded python-requests (2.26.0-5 -> 2.27.1-1)
[2022-02-18T13:46:21+0100] [ALPM] upgraded qt5-translations (5.15.2+kde+r20-2 -> 5.15.2+kde+r22-1)
[2022-02-18T13:46:23+0100] [ALPM] upgraded qt5-base (5.15.2+kde+r291-1 -> 5.15.2+kde+r301-1)
[2022-02-18T13:46:24+0100] [ALPM] upgraded qt5-declarative (5.15.2+kde+r43-1 -> 5.15.2+kde+r46-1)
[2022-02-18T13:46:24+0100] [ALPM] upgraded qt5-location (5.15.2-4 -> 5.15.2-5)
[2022-02-18T13:46:24+0100] [ALPM] upgraded qt5-quickcontrols (5.15.2-1 -> 5.15.2-2)
[2022-02-18T13:46:24+0100] [ALPM] upgraded qt5-svg (5.15.2+kde+r16-1 -> 5.15.2+kde+r16-2)
[2022-02-18T13:46:24+0100] [ALPM] upgraded qt5-webchannel (5.15.2+kde+r5-1 -> 5.15.2+kde+r5-2)
[2022-02-18T13:46:24+0100] [ALPM] upgraded re2 (1:20211101-1 -> 1:20220201-1)
[2022-02-18T13:46:26+0100] [ALPM] upgraded qt5-webengine (5.15.8-1 -> 5.15.8-8)
[2022-02-18T13:46:26+0100] [ALPM] upgraded qt5-x11extras (5.15.2-1 -> 5.15.2-2)
[2022-02-18T13:46:26+0100] [ALPM] upgraded screen (4.8.0-3 -> 4.9.0-1)
[2022-02-18T13:46:26+0100] [ALPM] warning: /etc/sudoers installed as /etc/sudoers.pacnew
[2022-02-18T13:46:26+0100] [ALPM] upgraded sudo (1.9.8.p2-3 -> 1.9.9-2)
[2022-02-18T13:46:26+0100] [ALPM] upgraded systemd-sysvcompat (250.3-1 -> 250.3-4)
[2022-02-18T13:46:26+0100] [ALPM] upgraded unzip (6.0-16 -> 6.0-18)
[2022-02-18T13:46:26+0100] [ALPM] upgraded upower (0.99.13-1 -> 0.99.15-1)
[2022-02-18T13:46:27+0100] [ALPM] upgraded vala (0.54.6-1 -> 0.54.7-1)
[2022-02-18T13:46:27+0100] [ALPM] upgraded wayland-protocols (1.24-1 -> 1.25-1)
[2022-02-18T13:46:28+0100] [ALPM] upgraded vlc (3.0.16-6 -> 3.0.16-8)
[2022-02-18T13:46:28+0100] [ALPM] upgraded waylandpp (0.2.8-1 -> 0.2.9-1)
[2022-02-18T13:46:28+0100] [ALPM] upgraded x11vnc (1:0.9.16-4 -> 1:0.9.16-5)
[2022-02-18T13:46:28+0100] [ALPM] upgraded xf86-input-libinput (1.2.0-2 -> 1.2.1-1)
[2022-02-18T13:46:28+0100] [ALPM] upgraded xfce4-cpufreq-plugin (1.2.5-1 -> 1.2.7-1)
[2022-02-18T13:46:28+0100] [ALPM] upgraded xfce4-cpugraph-plugin (1.2.5-1 -> 1.2.6-1)
[2022-02-18T13:46:28+0100] [ALPM] upgraded xfce4-notifyd (0.6.2-2 -> 0.6.3-1)
[2022-02-18T13:46:28+0100] [ALPM] upgraded xfce4-sensors-plugin (1.4.2-1 -> 1.4.3-1)
[2022-02-18T13:46:28+0100] [ALPM] upgraded xorg-server-common (21.1.3-1 -> 21.1.3-2)
[2022-02-18T13:46:28+0100] [ALPM] upgraded xorg-server (21.1.3-1 -> 21.1.3-2)
[2022-02-18T13:46:28+0100] [ALPM] transaction completed
[2022-02-18T13:46:31+0100] [ALPM] running '20-systemd-sysusers.hook'...
[2022-02-18T13:46:31+0100] [ALPM] running '30-systemd-catalog.hook'...
[2022-02-18T13:46:31+0100] [ALPM] running '30-systemd-daemon-reload.hook'...
[2022-02-18T13:46:32+0100] [ALPM] running '30-systemd-hwdb.hook'...
[2022-02-18T13:46:33+0100] [ALPM] running '30-systemd-sysctl.hook'...
[2022-02-18T13:46:33+0100] [ALPM] running '30-systemd-tmpfiles.hook'...
[2022-02-18T13:46:33+0100] [ALPM] running '30-systemd-udev-reload.hook'...
[2022-02-18T13:46:33+0100] [ALPM] running '30-systemd-update.hook'...
[2022-02-18T13:46:33+0100] [ALPM] running '30-update-mime-database.hook'...
[2022-02-18T13:46:36+0100] [ALPM] running '40-fontconfig-config.hook'...
[2022-02-18T13:46:36+0100] [ALPM] running '40-update-ca-trust.hook'...
[2022-02-18T13:46:40+0100] [ALPM] running '60-depmod.hook'...
[2022-02-18T13:46:46+0100] [ALPM] running '90-mkinitcpio-install.hook'...
[2022-02-18T13:46:46+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
[2022-02-18T13:46:46+0100] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
[2022-02-18T13:46:46+0100] [ALPM-SCRIPTLET] ==> Starting build: 5.15.24-1-lts
[2022-02-18T13:46:47+0100] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2022-02-18T13:46:47+0100] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2022-02-18T13:46:48+0100] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2022-02-18T13:46:49+0100] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2022-02-18T13:46:49+0100] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2022-02-18T13:46:49+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2022-02-18T13:46:50+0100] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2022-02-18T13:46:50+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2022-02-18T13:46:51+0100] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2022-02-18T13:46:51+0100] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2022-02-18T13:46:52+0100] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts.img
[2022-02-18T13:46:52+0100] [ALPM-SCRIPTLET] ==> Image generation successful
[2022-02-18T13:46:52+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
[2022-02-18T13:46:52+0100] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
[2022-02-18T13:46:52+0100] [ALPM-SCRIPTLET] ==> Starting build: 5.15.24-1-lts
[2022-02-18T13:46:53+0100] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2022-02-18T13:46:53+0100] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2022-02-18T13:46:54+0100] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2022-02-18T13:46:54+0100] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2022-02-18T13:46:56+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla1280
[2022-02-18T13:46:56+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2022-02-18T13:46:56+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: bfa
[2022-02-18T13:46:56+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qed
[2022-02-18T13:46:56+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla2xxx
[2022-02-18T13:46:57+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2022-02-18T13:46:59+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2022-02-18T13:47:01+0100] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2022-02-18T13:47:04+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2022-02-18T13:47:06+0100] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2022-02-18T13:47:08+0100] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2022-02-18T13:47:08+0100] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
[2022-02-18T13:47:11+0100] [ALPM-SCRIPTLET] ==> Image generation successful
[2022-02-18T13:47:11+0100] [ALPM] running 'dbus-reload.hook'...
[2022-02-18T13:47:11+0100] [ALPM] running 'fix-appstream-data.hook'...
[2022-02-18T13:47:11+0100] [ALPM-SCRIPTLET]       archive usr/share/app-info/xmls/community.xml.gz fixed
[2022-02-18T13:47:12+0100] [ALPM-SCRIPTLET]       archive usr/share/app-info/xmls/extra.xml.gz fixed
[2022-02-18T13:47:12+0100] [ALPM] running 'fontconfig.hook'...
[2022-02-18T13:47:12+0100] [ALPM] running 'gdk-pixbuf-query-loaders.hook'...
[2022-02-18T13:47:12+0100] [ALPM] running 'glib-compile-schemas.hook'...
[2022-02-18T13:47:12+0100] [ALPM] running 'gtk-query-immodules-3.0.hook'...
[2022-02-18T13:47:12+0100] [ALPM] running 'gtk-update-icon-cache.hook'...
[2022-02-18T13:47:13+0100] [ALPM] running 'texinfo-install.hook'...
[2022-02-18T13:47:18+0100] [ALPM] running 'update-desktop-database.hook'...
[2022-02-18T13:47:18+0100] [ALPM] running 'update-vlc-plugin-cache.hook'...
[2022-02-18T13:47:32+0100] [PACMAN] Running 'pacman -Syyu'
[2022-02-18T13:47:32+0100] [PACMAN] synchronizing package lists
[2022-02-18T13:48:05+0100] [PACMAN] starting full system upgrade

this is a bit to long, i _THINK_ (like 90% likely i would have noticed yesterday) the problem on my main machine started today. So checking yesterdays pacman.log:

[2022-02-17T02:08:59+0100] [PACMAN] synchronizing package lists
[2022-02-17T13:46:27+0100] [PACMAN] Running 'pacman -Syu'
[2022-02-17T13:46:27+0100] [PACMAN] synchronizing package lists
[2022-02-17T13:46:56+0100] [PACMAN] starting full system upgrade
[2022-02-17T13:52:00+0100] [ALPM] running '60-mkinitcpio-remove.hook'...
[2022-02-17T13:52:00+0100] [ALPM] running '71-dkms-remove.hook'...
[2022-02-17T13:52:00+0100] [ALPM] transaction started
[2022-02-17T13:52:00+0100] [ALPM] upgraded libcolord (1.4.5-4 -> 1.4.6-1)
[2022-02-17T13:52:00+0100] [ALPM] upgraded colord (1.4.5-4 -> 1.4.6-1)
[2022-02-17T13:52:00+0100] [ALPM] upgraded libxslt (1.1.34-6 -> 1.1.35-1)
[2022-02-17T13:52:01+0100] [ALPM] upgraded linux-lts (5.15.23-2 -> 5.15.24-1)
[2022-02-17T13:52:01+0100] [ALPM] upgraded nodejs (17.3.1-1 -> 17.4.0-1)
[2022-02-17T13:52:01+0100] [ALPM] upgraded nvidia-lts (1:510.54-1 -> 1:510.54-2)
[2022-02-17T13:52:01+0100] [ALPM] upgraded python-requests (2.27.0-1 -> 2.27.1-1)
[2022-02-17T13:52:01+0100] [ALPM] upgraded qpdf (10.6.1-1 -> 10.6.2-1)
[2022-02-17T13:52:01+0100] [ALPM] upgraded qt5-base (5.15.2+kde+r298-1 -> 5.15.2+kde+r300-1)
[2022-02-17T13:52:01+0100] [ALPM] upgraded thunderbird (91.6.0-1 -> 91.6.1-1)
[2022-02-17T13:52:01+0100] [ALPM] transaction completed
[2022-02-17T13:52:02+0100] [ALPM] running '20-systemd-sysusers.hook'...
[2022-02-17T13:52:02+0100] [ALPM] running '30-systemd-daemon-reload.hook'...
[2022-02-17T13:52:02+0100] [ALPM] running '30-systemd-tmpfiles.hook'...
[2022-02-17T13:52:02+0100] [ALPM] running '30-systemd-udev-reload.hook'...
[2022-02-17T13:52:02+0100] [ALPM] running '30-systemd-update.hook'...
[2022-02-17T13:52:02+0100] [ALPM] running '60-depmod.hook'...
[2022-02-17T13:52:03+0100] [ALPM] running '70-dkms-install.hook'...
[2022-02-17T13:52:03+0100] [ALPM-SCRIPTLET] ==> ERROR: Missing 5.15.24-1-lts kernel headers for module vboxhost/6.1.32_OSE.
[2022-02-17T13:52:03+0100] [ALPM-SCRIPTLET] ==> ERROR: Missing 5.15.24-1-lts kernel headers for module vhba-module/20211218.
[2022-02-17T13:52:03+0100] [ALPM] running '90-mkinitcpio-install.hook'...
[2022-02-17T13:52:03+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
[2022-02-17T13:52:03+0100] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
[2022-02-17T13:52:03+0100] [ALPM-SCRIPTLET] ==> Starting build: 5.15.24-1-lts
[2022-02-17T13:52:04+0100] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2022-02-17T13:52:04+0100] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2022-02-17T13:52:04+0100] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2022-02-17T13:52:04+0100] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2022-02-17T13:52:04+0100] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2022-02-17T13:52:04+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2022-02-17T13:52:04+0100] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2022-02-17T13:52:04+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2022-02-17T13:52:04+0100] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2022-02-17T13:52:06+0100] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2022-02-17T13:52:06+0100] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts.img
[2022-02-17T13:52:06+0100] [ALPM-SCRIPTLET] ==> Image generation successful
[2022-02-17T13:52:06+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
[2022-02-17T13:52:06+0100] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
[2022-02-17T13:52:06+0100] [ALPM-SCRIPTLET] ==> Starting build: 5.15.24-1-lts
[2022-02-17T13:52:06+0100] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2022-02-17T13:52:06+0100] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2022-02-17T13:52:06+0100] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2022-02-17T13:52:06+0100] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2022-02-17T13:52:06+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: bfa
[2022-02-17T13:52:06+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2022-02-17T13:52:06+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qed
[2022-02-17T13:52:06+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla1280
[2022-02-17T13:52:06+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2022-02-17T13:52:07+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla2xxx
[2022-02-17T13:52:07+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2022-02-17T13:52:07+0100] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2022-02-17T13:52:08+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2022-02-17T13:52:08+0100] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2022-02-17T13:52:10+0100] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2022-02-17T13:52:10+0100] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
[2022-02-17T13:52:11+0100] [ALPM-SCRIPTLET] ==> Image generation successful
[2022-02-17T13:52:11+0100] [ALPM] running 'clean_package_cache.hook'...
[2022-02-17T13:52:11+0100] [ALPM-SCRIPTLET]
[2022-02-17T13:52:11+0100] [ALPM-SCRIPTLET] ==> finished: 7 packages removed (disk space saved: 229.56 MiB)
[2022-02-17T13:52:11+0100] [ALPM] running 'dbus-reload.hook'...
[2022-02-17T13:52:11+0100] [ALPM] running 'glib-compile-schemas.hook'...
[2022-02-17T13:52:11+0100] [ALPM] running 'gtk-update-icon-cache.hook'...
[2022-02-17T13:52:11+0100] [ALPM] running 'nvidia-lts.hook'...
[2022-02-17T13:52:11+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
[2022-02-17T13:52:11+0100] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
[2022-02-17T13:52:11+0100] [ALPM-SCRIPTLET] ==> Starting build: 5.15.24-1-lts
[2022-02-17T13:52:11+0100] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2022-02-17T13:52:11+0100] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2022-02-17T13:52:11+0100] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2022-02-17T13:52:11+0100] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2022-02-17T13:52:11+0100] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2022-02-17T13:52:11+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2022-02-17T13:52:11+0100] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2022-02-17T13:52:11+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2022-02-17T13:52:11+0100] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2022-02-17T13:52:13+0100] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2022-02-17T13:52:13+0100] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts.img
[2022-02-17T13:52:13+0100] [ALPM-SCRIPTLET] ==> Image generation successful
[2022-02-17T13:52:13+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
[2022-02-17T13:52:13+0100] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
[2022-02-17T13:52:13+0100] [ALPM-SCRIPTLET] ==> Starting build: 5.15.24-1-lts
[2022-02-17T13:52:13+0100] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2022-02-17T13:52:13+0100] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2022-02-17T13:52:13+0100] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2022-02-17T13:52:13+0100] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2022-02-17T13:52:13+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: bfa
[2022-02-17T13:52:13+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2022-02-17T13:52:14+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qed
[2022-02-17T13:52:14+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla1280
[2022-02-17T13:52:14+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2022-02-17T13:52:14+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla2xxx
[2022-02-17T13:52:14+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2022-02-17T13:52:15+0100] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2022-02-17T13:52:15+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2022-02-17T13:52:16+0100] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2022-02-17T13:52:17+0100] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2022-02-17T13:52:17+0100] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
[2022-02-17T13:52:18+0100] [ALPM-SCRIPTLET] ==> Image generation successful
[2022-02-17T13:52:18+0100] [ALPM] running 'update-desktop-database.hook'...

so most noticably i think is:
[2022-02-17T13:52:01+0100] [ALPM] upgraded linux-lts (5.15.23-2 -> 5.15.24-1)

hoever if i start up with the non-lts kernel, i have seemingly the same isue. \

on top of this i have no way of troubleshooting, as the server is a restricting Qnap system. And the command on the client just hangs and hangs.

Also noteworthy, he client does return a proper list on the command
$showmount -e SERVERNAME

The firewall has been disabled for testing purposes.

I'm at a loss, how do i continue from this point? I have prayed to the linux gods but it seems they are out :) Perhaps one of you could function as a god for a bit?

Last edited by BottleNeck (2022-02-18 13:42:39)

Offline

#2 2022-02-18 13:28:06

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,828

Re: [BUG] NFS stoped working after update

https://bugs.archlinux.org/task/73860

So you're not the only one. Looks like something that got backported if it's affecting the -lts kernel as well.

Last edited by Scimmia (2022-02-18 13:34:10)

Offline

#3 2022-02-18 13:42:06

BottleNeck
Member
Registered: 2019-03-12
Posts: 32

Re: [BUG] NFS stoped working after update

that's so brave, opening a bugreport. I'd feel like i did not do enough research to open such a thing. Thanks for linking it. This noob did not find that yet.
is there anyway to report is also affects the -lts? Just so dev's have a better shot?

edit, i just went wild and added it as a comment to the bug report that lts is also affected. Now i will get banned and the angry dev team will come and knock down my door smile

Last edited by BottleNeck (2022-02-18 13:49:24)

Offline

#4 2022-02-18 13:58:40

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,828

Re: [BUG] NFS stoped working after update

A comment was the right way to do it, but being an upstream kernel issue, it's unlikely anything will happen with that bug report. Someone needs to bisect (there are more than a dozen NFS related commits in this release) and report it upstream.

Offline

#5 2022-02-18 14:09:46

BottleNeck
Member
Registered: 2019-03-12
Posts: 32

Re: [BUG] NFS stoped working after update

so going back to a previous kernel is the best option for now i guess. Thanks a bunch!

Offline

#6 2022-02-18 20:08:55

Vizitor
Member
Registered: 2015-01-05
Posts: 81

Re: [BUG] NFS stoped working after update

Recently I got some troubles with network mounts.
Anyway, here is mine WORKING nfs on kernel 5.16.10-arch1-1:

 $ showmount --exports 192.168.1.5 -e
Export list for 192.168.1.5:
/mnt/HD_a2 192.168.1.0/24
 $ sudo mount -o rw,vers=3 -t nfs 192.168.1.5:/mnt/HD_a2 /home/v/MNT/NFS/5
Created symlink /run/systemd/system/remote-fs.target.wants/rpc-statd.service → /usr/lib/systemd/system/rpc-statd.service.

As You can see I am using "vers=3"

Offline

#7 2022-02-19 05:25:09

BottleNeck
Member
Registered: 2019-03-12
Posts: 32

Re: [BUG] NFS stoped working after update

As You can see I am using "vers=3"

And you are so right! Changing the variable in /etc/nfsmount.conf into version 3 as preferred (and allowing v3 in server) it does work again. Thanks for this valuable addition!

Offline

#8 2022-02-20 22:42:31

garloff
Member
Registered: 2022-02-20
Posts: 4

Re: [BUG] NFS stoped working after update

Scimmia wrote:

A comment was the right way to do it, but being an upstream kernel issue, it's unlikely anything will happen with that bug report. Someone needs to bisect (there are more than a dozen NFS related commits in this release) and report it upstream.

Done. I have bisected this to be caused by commit 6f283634 (in 5.15.24).
I have sent an eMail to Olga (and copied linux-nfs@vger).
The problem here happens against Qnap (all exports, NFS v4.1, Qnap 4.3.4-XXX) but not 5.15 knfsd.

Last edited by garloff (2022-02-20 23:19:53)

Offline

#9 2022-02-21 07:19:18

seth
Member
Registered: 2012-09-03
Posts: 33,643

Re: [BUG] NFS stoped working after update

https://git.kernel.org/pub/scm/linux/ke … oc.c#n3859 clears a bunch of caps before parsing them - what if you keep the offending patch but first remove the cap there as well, ie.

server->caps &= ~(NFS_CAP_ACLS | NFS_CAP_HARDLINKS |
				  NFS_CAP_SYMLINKS| NFS_CAP_SECURITY_LABEL|NFS_CAP_FS_LOCATIONS);

?

Online

#10 2022-02-23 14:20:11

garloff
Member
Registered: 2022-02-20
Posts: 4

Re: [BUG] NFS stoped working after update

seth wrote:

https://git.kernel.org/pub/scm/linux/ke … oc.c#n3859 clears a bunch of caps before parsing them - what if you keep the offending patch but first remove the cap there as well, ie.

server->caps &= ~(NFS_CAP_ACLS | NFS_CAP_HARDLINKS |
				  NFS_CAP_SYMLINKS| NFS_CAP_SECURITY_LABEL|NFS_CAP_FS_LOCATIONS);

?

Good spotting, test compilation is running ...
Being at it, shouldn't we clear a bunch more fields?
I see at least: NFS_CAP_CASE_PRESERVING | NFS_CAP_CASE_INSENSITIVE
Or, to code this more defensively: Do we know of a finite, not evolving set of flags that might need to be preserved and just clear all other bits to be on the safe side when the set of caps is extended the next time?

Offline

#11 2022-02-23 14:26:32

seth
Member
Registered: 2012-09-03
Posts: 33,643

Re: [BUG] NFS stoped working after update

I guess if server->caps should just be "0", that would have been there all along.
idk whether or which caps need to go at this point, but this one's tested when the connection fails and since that's an error, I assume at least this capability must not bleed into the server caps.
First, let's see whether it's relevant at all smile

Online

#12 2022-02-23 17:05:31

garloff
Member
Registered: 2022-02-20
Posts: 4

Re: [BUG] NFS stoped working after update

seth wrote:

I guess if server->caps should just be "0", that would have been there all along.
idk whether or which caps need to go at this point, but this one's tested when the connection fails and since that's an error, I assume at least this capability must not bleed into the server caps.
First, let's see whether it's relevant at all smile

Yeah, unfortunately, it did not help ...
It seems that the knfsd from Qnap (kernel 3.4.6) does misreport support for FS_LOCATIONS.
Next attempt will be to disallow FS_LOCATIONS for NFS <= v4.1.

Offline

#13 2022-02-23 17:16:31

garloff
Member
Registered: 2022-02-20
Posts: 4

Re: [BUG] NFS stoped working after update

                /* Restrict FS_LOCATIONS to NFS v4.2+ to work around Qnap knfsd-3.4.6 bug */
                if (res.attr_bitmask[0] & FATTR4_WORD0_FS_LOCATIONS && minorversion >= 2)
                        server->caps |= NFS_CAP_FS_LOCATIONS;

in nfs4proc.c does the trick for me.

Offline

#14 2022-03-17 01:23:46

loqs
Member
Registered: 2014-03-06
Posts: 15,505

Re: [BUG] NFS stoped working after update

@garloff did you test if the issue is still present in 5.17 releases candidates?  If so could you CC linux-regressions mailing list or regzbot to the thread on the nfs mailing list?

Offline

#15 2022-04-03 18:26:59

enbQao
Member
Registered: 2018-05-10
Posts: 17

Re: [BUG] NFS stoped working after update

loqs wrote:

@garloff did you test if the issue is still present in 5.17 releases candidates?

I can confirm that this unfortunately still persists with kernel 5.17.1-arch1-1

Offline

#16 2022-04-07 20:21:19

markus_r
Member
From: Vienna
Registered: 2022-04-07
Posts: 1

Re: [BUG] NFS stoped working after update

I was just about to post the same .. happened on two of my computers after upgrading to 5.17.1-arch1-1.
On one machine (Intel Nuc) I additionally encountered  strange (more or less reproducible) issues with a 3rd party software (Roon - latest version installed - 1.8 build 923). A couple of minutes after starting playback to one end point, the computer rebooted out of a sudden. I could not find any hints/messages in the logs (both, system and application). Roon is not using NFS for playback (just for backups) though.
Initially I was wondering whether this might be some strange hardware issue (at that time, I wasn't aware of the NFS issue), but after I fixed the NFS issue (affecting three different QNAP boxes with NFS4 shares - all up-to-date) by manually downgrading the linux kernel package to the previous installed versions (5.16.8-arch1-1 and 5.16.16-arch1-1), both, the NFS  issue and the spontaneous resets after starting playback were gone. Might have been a change in a different part (as NFS was not working anyway), but I thought I let you know too


Available ;-)

Offline

#17 2022-04-09 06:16:33

enbQao
Member
Registered: 2018-05-10
Posts: 17

Re: [BUG] NFS stoped working after update

I have found a temporary workaround here: https://forum.qnap.com/viewtopic.php?t=165385

According to the manpage

$ man 5 nfs
nfsvers=n      The  NFS  protocol version number used to contact the server's NFS service.  If the server
               does not support the requested version, the mount request fails.  If this  option  is  not
               specified,  the client tries version 4.2 first, then negotiates down until it finds a ver‐
               sion supported by the server.

It seems that there are issues with  4.2 on the QNAP NAS and the processes of negotiating down to a working/supported version is stuck/does not work properly.
As a temporary workaround (until this is fixed), you can use

mount.nfs -o nfsvers=4.0

Last edited by enbQao (2022-04-09 06:18:30)

Offline

#18 2022-04-09 10:25:41

loqs
Member
Registered: 2014-03-06
Posts: 15,505

Re: [BUG] NFS stoped working after update

It is fixed in mainline [1] and is marked with a Fixes line so it will be picked up by the stable trees at some point.
Edit:
Applied locally to 5.17.4-arch1

[1] https://git.kernel.org/pub/scm/linux/ke … 65601c4fb2
[2] https://github.com/archlinux/linux/comm … b1df254a12

Last edited by loqs (2022-04-20 19:42:09)

Offline

Board footer

Powered by FluxBB