You are not logged in.

#51 2022-04-11 15:22:45

seth
Member
Registered: 2012-09-03
Posts: 30,906

Re: kodi segmentation fault [solved]

VDPAU is mostly an nvidia thing, you should configure kodi to use VAAPI.
Or remove https://archlinux.org/packages/communit … pau-va-gl/ or unset $VDPAU_DRIVER ?

Offline

#52 2022-04-12 08:40:02

alexela
Member
Registered: 2022-02-13
Posts: 23

Re: kodi segmentation fault [solved]

Ok. I cleaned most of these things but the libvdpau package itself is a dependy of both kodi and ffmpeg. I removed all the other stuff that i could and installed the intel-media-driver package. I removed the environment variable and just keep the simlinks (maybe a new mesa-amber (i think i should better stay with mesa-amber than trying to go back to mesa…) package will take care of that…).

Thanks for your help,
Alex

Offline

#53 2022-04-12 13:19:03

seth
Member
Registered: 2012-09-03
Posts: 30,906

Re: kodi segmentation fault [solved]

Your chip is covered by the crocus driver - if it actually works (since we've been chasing vdpau) you're probably better off w/ it - at least in the long run.
libvdpau is requierd by a lot of stuff because it's linked to the binary executables, but unless you *have* to use some VDPAU backend, you can just use VAAPI and therefore won't need the libvdpau-va-gl wrapper.

Offline

#54 2022-04-18 13:53:49

johnnyn
Member
Registered: 2015-10-26
Posts: 26

Re: kodi segmentation fault [solved]

Greetings,

hardware specific clarification for anyone seeking help here.

I can confirm that...

Intel Core i5-4200U CPU (Haswell architecture) with integrated Intel HD Graphics 4400 (released Q3 2013)

...will run Kodi, with nothing but the following environment variable set:

LD_PRELOAD=/usr/lib/dri/crocus_dri.so

crocus_dri.so is in mesa-22.x, so no new packages, extra symlinking, or any other hoop jumping is needed -- just the environment variable set to the correct value.

Best regards smile
Johnny smile

Offline

Board footer

Powered by FluxBB