You are not logged in.

#1 2022-04-25 13:12:17

linerman
Member
Registered: 2021-02-16
Posts: 63

[Solved] deepin-kwin switched me to pipewire?

Hi,

During installation of latest deepin-kwin I was asked for dependencies, i.a. wireplumber.
It was strange for me that window-decorator asked about multimedia framework...
Anyway, after installation, my external DAC is visible in system but I can hear no sound.
Apart from that, in firefox - Youtube and Twitch movies started to look like lagging thing (approx. 0,5fps?) with no sound also.

I am not sure if all of these are the symptoms of switching to pipewire or there is some other problem.

Where to start diagnose?

Last edited by linerman (2022-04-28 08:41:15)

Offline

#2 2022-04-25 13:58:51

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,718

Re: [Solved] deepin-kwin switched me to pipewire?

Kwin requires pipewire, pipewire's original purpose was to primarily to have a secure way of allowing screen sharing and the like on wayland which is what actual compositors require to provide that (... and for e.g. taskbar thumbnails). If you just want the pipewire dep without interfering with pulseaudio you should install pipewire-media-session instead which isn't as aggressive in claiming audio devices as wireplumber is. If you want to actually fully switch to pipewire make sure you actually switch by having pipewire-pulse and pipewire-alsa instead of pulseaudio-alsa

Offline

#3 2022-04-26 10:29:17

linerman
Member
Registered: 2021-02-16
Posts: 63

Re: [Solved] deepin-kwin switched me to pipewire?

V1del wrote:

. If you just want the pipewire dep without interfering with pulseaudio you should install pipewire-media-session instead which isn't as aggressive in claiming audio devices as wireplumber is.

Thank you for your help. Indeed, it was the problem with wireplumber.
I am not ready yet to switch completely for pipewire, so I removed all dependencies with wireplumber and the one itself.
Installing dependencies connected to pipewire-media-session instead of wireplumber solved the problem with lagging and no sound.

Offline

#4 2022-04-26 10:36:27

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,718

Re: [Solved] deepin-kwin switched me to pipewire?

Great please mark as [SOLVED] by editing the title in the first post (might have to shorten it a litle.).

Last edited by V1del (2022-04-26 10:43:04)

Offline

Board footer

Powered by FluxBB