You are not logged in.

#1 2022-04-25 20:06:27

manray
Member
Registered: 2022-01-01
Posts: 17

GPU Governor change does not appear to change core frequency.

I am using the Dell XPS15-9510 with the Nvidia gpu turned off.

I am attempting to use auto_cpufreq to save some power. The application appears to work as specified, however when switching from the performance to the powersave governor, the frequency of each core remains the same. I would expect each core to spin down to about 800, but most of them stay at max clock for 99% of the time.

Plugged in (performance governor)

-------------------------------------------------------------------------------

			"auto-cpufreq" refresh in: 1
		Executed on: April 25 (Monday) - 15:59:23

-------------------------------------------------------------------------------

Linux distro: Arch Linux rolling n/a
Linux kernel: 5.17.4-arch1-1
Processor: 11th Gen Intel(R) Core(TM) i7-11800H @ 2.30GHz
Cores: 16
Architecture: x86_64
Driver: intel_pstate

------------------------------ Current CPU stats ------------------------------

CPU max frequency: 2300 MHz
CPU min frequency: 800 MHz

Core	Usage	Temperature	Frequency
CPU0:	  0.0%     38 °C     2300 MHz
CPU1:	  1.0%     41 °C     2300 MHz
CPU2:	  0.0%     36 °C     2300 MHz
CPU3:	  0.0%     40 °C     2300 MHz
CPU4:	  0.0%     38 °C     2300 MHz
CPU5:	  0.0%     38 °C     2300 MHz
CPU6:	  0.0%     38 °C     2300 MHz
CPU7:	  0.0%     36 °C     2300 MHz
CPU8:	  0.0%     38 °C     2300 MHz
CPU9:	  0.0%     41 °C     2300 MHz
CPU10:	  0.0%     36 °C     2300 MHz
CPU11:	  0.0%     40 °C     2300 MHz
CPU12:	  0.0%     38 °C     2300 MHz
CPU13:	  0.0%     38 °C     2300 MHz
CPU14:	  0.0%     38 °C     1810 MHz
CPU15:	  0.0%     36 °C     2300 MHz

---------------------------- CPU frequency scaling ----------------------------

Battery is: charging

Setting to use: "performance" governor

Total CPU usage: 0.1 %
Total system load: 0.21142578125
Average temp. of all cores: 38.125 °C

Load optimal
setting turbo boost: off

Unplugged (powersave governor)

-------------------------------------------------------------------------------

			"auto-cpufreq" refresh in: 1
		Executed on: April 25 (Monday) - 15:59:45

-------------------------------------------------------------------------------

Linux distro: Arch Linux rolling n/a
Linux kernel: 5.17.4-arch1-1
Processor: 11th Gen Intel(R) Core(TM) i7-11800H @ 2.30GHz
Cores: 16
Architecture: x86_64
Driver: intel_pstate

------------------------------ Current CPU stats ------------------------------

CPU max frequency: 2300 MHz
CPU min frequency: 800 MHz

Core	Usage	Temperature	Frequency
CPU0:	  0.0%     39 °C     2300 MHz
CPU1:	  0.0%     42 °C     2300 MHz
CPU2:	  1.0%     36 °C     2300 MHz
CPU3:	  0.0%     41 °C     2300 MHz
CPU4:	  0.0%     39 °C     2300 MHz
CPU5:	  0.0%     38 °C     2300 MHz
CPU6:	  0.0%     38 °C     1140 MHz
CPU7:	  0.0%     38 °C     2300 MHz
CPU8:	  0.0%     39 °C     2300 MHz
CPU9:	  0.0%     42 °C     2300 MHz
CPU10:	  0.0%     36 °C     2300 MHz
CPU11:	  0.0%     41 °C     2300 MHz
CPU12:	  0.0%     39 °C     2300 MHz
CPU13:	  0.0%     38 °C     2300 MHz
CPU14:	  0.0%     38 °C     2300 MHz
CPU15:	  0.0%     38 °C     2300 MHz

---------------------------- CPU frequency scaling ----------------------------

Battery is: discharging

Setting to use: "powersave" governor

Total CPU usage: 0.2 %
Total system load: 0.15087890625
Average temp. of all cores: 38.875 °C

Load optimal
setting turbo boost: off

As you can see, the behavior of the cpus is identical between powersave and performace mode. This must be why my battery life is terrible. To my knowledge, I have no other powersaving daemons enabled (powertop, tlp, etc).

Any ideas?

Offline

#2 2022-04-25 20:17:35

manray
Member
Registered: 2022-01-01
Posts: 17

Re: GPU Governor change does not appear to change core frequency.

The solution was to add `intel_pstate=disable` to `GRUB_CMDLINE_LINUX_DEFAULT` in `/etc/default/grub` then run `sudo update grub`.

Offline

Board footer

Powered by FluxBB